aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-igeoportal
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-08-15 03:26:48 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-08-15 03:26:48 +0000
commitb8442867a087d62d1e80612a232953b0d7e607d2 (patch)
tree430deb19a61621de47dda9a7425084e431af078e /graphics/deegree-igeoportal
parent8188a73e66b6ac5279f64a24a59006d26389223d (diff)
downloadports-b8442867a087d62d1e80612a232953b0d7e607d2.tar.gz
ports-b8442867a087d62d1e80612a232953b0d7e607d2.zip
Stagify.
Notes
Notes: svn path=/head/; revision=364926
Diffstat (limited to 'graphics/deegree-igeoportal')
-rw-r--r--graphics/deegree-igeoportal/Makefile16
-rw-r--r--graphics/deegree-igeoportal/pkg-plist2
2 files changed, 6 insertions, 12 deletions
diff --git a/graphics/deegree-igeoportal/Makefile b/graphics/deegree-igeoportal/Makefile
index 07928309f87a..188cbafa0ab7 100644
--- a/graphics/deegree-igeoportal/Makefile
+++ b/graphics/deegree-igeoportal/Makefile
@@ -21,16 +21,13 @@ APPHOME= ${LOCALBASE}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
PORTDOCS= README.txt README_owswatch.txt deegree_igeoportal_documentation_en.pdf
DOCSDIR= ${PREFIX}/share/doc/deegree-igeoportal
-PLIST_SUB= TOMCATDIR=${TOMCATDIR:S|^${PREFIX}/||}
+PLIST_SUB= TOMCATDIR=${TOMCATDIR:S|^${PREFIX}/||} WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
SUB_FILES= pkg-message
SUB_LIST= TCPORT=${TCPORT}
OPTIONS_SINGLE= AS
OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
-
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
@@ -54,13 +51,10 @@ post-extract:
@${TAR} xf ${WRKDIR}/igeoportal-std.war -C ${WRKDIR}/${PORTDIRNAME}
do-install:
- ${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
- @cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
+ ${INSTALL} -d ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
+ @cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/graphics/deegree-igeoportal/pkg-plist b/graphics/deegree-igeoportal/pkg-plist
index e214f727f41d..82bdc6f57f14 100644
--- a/graphics/deegree-igeoportal/pkg-plist
+++ b/graphics/deegree-igeoportal/pkg-plist
@@ -1,3 +1,4 @@
+@exec chown %%WWWOWN%%:%%WWWGRP%% %D/%%TOMCATDIR%%/webapps/deegree-igeoportal
%%TOMCATDIR%%/webapps/deegree-igeoportal/META-INF/MANIFEST.MF
%%TOMCATDIR%%/webapps/deegree-igeoportal/README.txt
%%TOMCATDIR%%/webapps/deegree-igeoportal/WEB-INF/classes/de/latlon/BBoxInputValidationListener.class
@@ -1846,4 +1847,3 @@
@dirrm %%TOMCATDIR%%/webapps/deegree-igeoportal/WEB-INF
@dirrm %%TOMCATDIR%%/webapps/deegree-igeoportal/META-INF
@dirrm %%TOMCATDIR%%/webapps/deegree-igeoportal
-@dirrm %%TOMCATDIR%%/webapps