aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-wcs
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-10-30 22:07:30 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-10-30 22:07:30 +0000
commit60b862d4dccc0c3da4643047035188b844ba51cb (patch)
treeb9a830495de23a83de832bf1cddaa288075611b3 /graphics/deegree-wcs
parent13c8106d8b8fbc29ecf19c068a7a8d5baebd184e (diff)
downloadports-60b862d4dccc0c3da4643047035188b844ba51cb.tar.gz
ports-60b862d4dccc0c3da4643047035188b844ba51cb.zip
- add additional support for tomcat7 and adjust pkg-message accordingly
PR: 173092 Submitted by: nemysis@gmx.ch Patch by: jgh Approved by: maintainer, wen Feature safe: yes
Notes
Notes: svn path=/head/; revision=306722
Diffstat (limited to 'graphics/deegree-wcs')
-rw-r--r--graphics/deegree-wcs/Makefile35
-rw-r--r--graphics/deegree-wcs/files/pkg-message.in (renamed from graphics/deegree-wcs/pkg-message)2
2 files changed, 26 insertions, 11 deletions
diff --git a/graphics/deegree-wcs/Makefile b/graphics/deegree-wcs/Makefile
index 703740619eb5..56c388319efc 100644
--- a/graphics/deegree-wcs/Makefile
+++ b/graphics/deegree-wcs/Makefile
@@ -13,25 +13,43 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Deegree Web Coverage Service(WCS)
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
-
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
+APPHOME= ${LOCALBASE}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
-PORTDOCS= *
+PORTDOCS= README.txt deegree_wcs_documentation_en.pdf
DOCSDIR= ${PREFIX}/share/doc/deegree-wcs
PLIST_SUB= TOMCATDIR=${TOMCATDIR:S|^${PREFIX}/||}
+SUB_FILES= pkg-message
+SUB_LIST= TCPORT=${TCPORT}
+
+OPTIONS_SINGLE= AS
+OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
+OPTIONS_DEFAULT= TOMCAT6
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTOMCAT6}
+TOMCATVER= apache-tomcat-6.0
+TCPORT= 8180
+BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
+RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
+.endif
+
+.if ${PORT_OPTIONS:MTOMCAT7}
+TOMCATVER= apache-tomcat-7.0
+TCPORT= 8080
+BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
+RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
+.endif
post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/deegree-wcs.war -C ${WRKDIR}/${PORTDIRNAME}
-.include <bsd.port.options.mk>
-
do-install:
cd ${WRKDIR} && \
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@@ -39,11 +57,8 @@ do-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/deegree_wcs_documentation_en.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${DOCSDIR}
.endif
-
-post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/graphics/deegree-wcs/pkg-message b/graphics/deegree-wcs/files/pkg-message.in
index 13df82f03621..45764bcf9961 100644
--- a/graphics/deegree-wcs/pkg-message
+++ b/graphics/deegree-wcs/files/pkg-message.in
@@ -4,7 +4,7 @@ To start DeeGree correctly, please set the variable JAVA_OPTS with:
setenv JAVA_OPTS "-server -Xms256m -Xmx512m"
Now you should start your Tomcat server and browse with:
- http://your-server:8180/deegree-wcs
+ http://your-server:%%TCPORT%%/deegree-wcs
Enjoy it !
==========================================================================