aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-wcs
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:19:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:19:43 +0000
commit9780f18e7f2324c2172ca352710e00c7e81ba224 (patch)
treef3261b72727c1f7fc91e97cc15a64da18783f48d /graphics/deegree-wcs
parent48777d6973790ebe72953c3031e247dfd2fb45c4 (diff)
downloadports-9780f18e7f2324c2172ca352710e00c7e81ba224.tar.gz
ports-9780f18e7f2324c2172ca352710e00c7e81ba224.zip
deegree's Web Coverage Service (WCS) is able to read coverages from
different storage formats and deliver it to any client that is able to perform an according HTTP GET or POST request. At the moment supported formats are limited to several raster data formats; but in general a coverage has not to be a raster dataset at all. WWW: http://www.deegree.org/ PR: ports/133805 Submitted by: wenheping at gmail.com
Notes
Notes: svn path=/head/; revision=232565
Diffstat (limited to 'graphics/deegree-wcs')
-rw-r--r--graphics/deegree-wcs/Makefile46
-rw-r--r--graphics/deegree-wcs/distinfo3
-rw-r--r--graphics/deegree-wcs/pkg-descr7
-rw-r--r--graphics/deegree-wcs/pkg-message10
4 files changed, 66 insertions, 0 deletions
diff --git a/graphics/deegree-wcs/Makefile b/graphics/deegree-wcs/Makefile
new file mode 100644
index 000000000000..ca8682c39c98
--- /dev/null
+++ b/graphics/deegree-wcs/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: deegree-wcs
+# Date created: 17 April, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= wcs
+PORTVERSION= 2.2
+CATEGORIES= graphics java
+MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
+PKGNAMEPREFIX= deegree-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_v${PORTVERSION:S/./_/}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Deegree Web Coverage Service(WCS)
+
+RUN_DEPENDS= ${TOMCATDIR}:${PORTSDIR}/www/tomcat55
+
+USE_ZIP= yes
+USE_JAVA= 1.5+
+
+NO_BUILD= yes
+TOMCATVER= tomcat5.5
+TOMCATDIR= ${PREFIX}/${TOMCATVER}
+TOMCATOWN= www
+TOMCATGRP= www
+WEBAPPDIR= ${TOMCATDIR}/webapps
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/deegree-wcs
+PLIST_FILES= ${TOMCATVER}/webapps/deegree-wcs.war
+
+do-install:
+ cd ${WRKDIR} && \
+ ${INSTALL} -g ${TOMCATGRP} -o ${TOMCATOWN} -m 444 deegree-wcs.war ${WEBAPPDIR};
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/README_WCS.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/deegree_wcs_documentation_en.pdf ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/graphics/deegree-wcs/distinfo b/graphics/deegree-wcs/distinfo
new file mode 100644
index 000000000000..96c95b758510
--- /dev/null
+++ b/graphics/deegree-wcs/distinfo
@@ -0,0 +1,3 @@
+MD5 (deegree-wcs_v2_2.zip) = 05663c70180b86a81b7f8f5f2bf218da
+SHA256 (deegree-wcs_v2_2.zip) = e5fafb3da71b65b63b9e7b44947d3c216fd49cf2fe8f2ee37bed172949ee1b97
+SIZE (deegree-wcs_v2_2.zip) = 121416846
diff --git a/graphics/deegree-wcs/pkg-descr b/graphics/deegree-wcs/pkg-descr
new file mode 100644
index 000000000000..61702d866d76
--- /dev/null
+++ b/graphics/deegree-wcs/pkg-descr
@@ -0,0 +1,7 @@
+deegree's Web Coverage Service (WCS) is able to read coverages from
+different storage formats and deliver it to any client that is able to
+perform an according HTTP GET or POST request. At the moment supported
+formats are limited to several raster data formats; but in general a
+coverage has not to be a raster dataset at all.
+
+WWW: http://www.deegree.org/
diff --git a/graphics/deegree-wcs/pkg-message b/graphics/deegree-wcs/pkg-message
new file mode 100644
index 000000000000..13df82f03621
--- /dev/null
+++ b/graphics/deegree-wcs/pkg-message
@@ -0,0 +1,10 @@
+==========================================================================
+To start DeeGree correctly, please set the variable JAVA_OPTS with:
+
+setenv JAVA_OPTS "-server -Xms256m -Xmx512m"
+
+Now you should start your Tomcat server and browse with:
+ http://your-server:8180/deegree-wcs
+
+Enjoy it !
+==========================================================================