aboutsummaryrefslogtreecommitdiff
path: root/graphics/digikam-kde4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-04-08 17:10:56 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-04-08 17:10:56 +0000
commite7ae0125df81fadd3e2ddfa76cf808fdfebbe843 (patch)
treeb81149ea12ce6a5f92464207866d518bb355ed3c /graphics/digikam-kde4
parentf4de7e74148d628cfdcb794a6ac3edb300408848 (diff)
- Update to digiKam and Kipi Plugins ports to 3.1.0
- Split documentations and l10ns to separate ports - Split kipi-plugins-kde4 port Approved by: portmgr (miwi)
Notes
Notes: svn path=/head/; revision=315762
Diffstat (limited to 'graphics/digikam-kde4')
-rw-r--r--graphics/digikam-kde4/Makefile26
-rw-r--r--graphics/digikam-kde4/Makefile.common134
-rw-r--r--graphics/digikam-kde4/distinfo4
-rw-r--r--graphics/digikam-kde4/files/patch-CMakeLists.txt17
-rw-r--r--graphics/digikam-kde4/files/patch-cmake__modules__FindPGF.cmake53
-rw-r--r--graphics/digikam-kde4/files/patch-digikam__album__albumwatch.cpp20
-rw-r--r--graphics/digikam-kde4/pkg-plist359
7 files changed, 157 insertions, 456 deletions
diff --git a/graphics/digikam-kde4/Makefile b/graphics/digikam-kde4/Makefile
index 6082665d9b25..b281f6436e48 100644
--- a/graphics/digikam-kde4/Makefile
+++ b/graphics/digikam-kde4/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: digikam
-# Date created: 3 February 2003
-# Whom: Arjan van Leeuwen <avleeuwen@piwebs.com>
-#
+# Created by: Arjan van Leeuwen <avleeuwen@piwebs.com>
# $FreeBSD$
-#
PORTNAME= digikam
PORTVERSION= ${DIGIKAM_VER}
-PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= graphics kde
@@ -28,7 +23,7 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
LATEST_LINK= ${PORTNAME}-kde4
-OPTIONS_DEFINE= NLS GPHOTO2 PIMLIBS MYSQL
+OPTIONS_DEFINE= DOCS NLS GPHOTO2 PIMLIBS MYSQL
OPTIONS_DEFAULT= GPHOTO2 PIMLIBS
NO_OPTIONS_SORT= yes
@@ -38,6 +33,8 @@ PIMLIBS_DESC= Enable address book support
USE_PKGCONFIG= build
USE_KDE4+= libkdcraw libkexiv2 libkipi
USE_QT4+= sql-sqlite3_run
+USE_LDCONFIG= yes
+CMAKE_ARGS+= -DWITH_Sqlite2=off
MAN1= digitaglinktree.1 \
cleanup_digikamdb.1
@@ -47,11 +44,11 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/core
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.else
-CMAKE_ARGS+= -DWITH_NLS:BOOL=OFF
-PLIST_SUB+= NLS="@comment "
+RUN_DEPENDS+= digikam-l10n>=${DIGIKAM_VER}:${PORTSDIR}/graphics/digikam-kde4-l10n
+.endif
+
+.if ${PORT_OPTIONS:MDOCS}
+RUN_DEPENDS+= digikam-doc>=${DIGIKAM_VER}:${PORTSDIR}/graphics/digikam-kde4-doc
.endif
.if ${PORT_OPTIONS:MGPHOTO2}
@@ -77,9 +74,4 @@ CMAKE_ARGS+= -DENABLE_INTERNALMYSQL:BOOL=OFF
PLIST_SUB+= MYSQL="@comment "
.endif
-post-patch:
- ${LN} -s ../doc ${WRKSRC}/doc
- ${LN} -s ../po ${WRKSRC}/po
- ${RM} ${WRKSRC}/po/*/libkgeomap.po ${WRKSRC}/po/*/kipi*
-
.include <bsd.port.mk>
diff --git a/graphics/digikam-kde4/Makefile.common b/graphics/digikam-kde4/Makefile.common
index d580dea6621d..6a9f57172f41 100644
--- a/graphics/digikam-kde4/Makefile.common
+++ b/graphics/digikam-kde4/Makefile.common
@@ -3,24 +3,150 @@
# Make sure when DIGIKAM_VER is updated that the following ports are updated:
# astro/libkgeomap
# graphics/digikam-kde4
+# digikam-kde4-doc
+# digikam-kde4-l10n
+# graphics/kipi-plugin-*
# graphics/kipi-plugins-kde4
# graphics/libkface
+# graphics/libkipiplugins
# net/libkvkontakte
# net/libmediawiki
-DIGIKAM_VER= 2.9.0
-MASTER_SITES= SF/digikam/digikam/${DIGIKAM_VER}
+DIGIKAM_VER= 3.1.0
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/digikam
+
+KIPI_PLUGINS_ALL= acquireimages \
+ advancedslideshow \
+ batchprocess \
+ calendar \
+ debianscreenshots \
+ dngconverter \
+ expoblending \
+ facebook \
+ flashexport \
+ flickrexport \
+ galleryexport \
+ gpssync \
+ htmlexport \
+ imageshackexport \
+ imageviewer \
+ imgurexport \
+ ipodexport \
+ jpeglossless \
+ kioexport \
+ kmlexport \
+ kopete \
+ mediawiki \
+ metadataedit \
+ panorama \
+ photolayoutseditor \
+ picasawebexport \
+ piwigoexport \
+ printimages \
+ rajceexport \
+ rawconverter \
+ removeredeyes \
+ sendimages \
+ shwup \
+ smug \
+ timeadjust \
+ videoslideshow \
+ vkontakte \
+ yandexfotki
+
+# libkipiplugins is special: it's not listed in KIPI_PLUGINS_ALL,
+# and every plugin depends on it
+libkipiplugins_DIR= common
+libkipiplugins_DESC= Common library for kipi plugins
+
+batchprocess_DIR= batchprocessimages
+kioexport_DIR= kioexportimport
+
+acquireimages_DESC= Acquire images using flat scanner
+advancedslideshow_DESC= Slide images with 2D and 3D effects using OpenGL
+batchprocess_DESC= Batch process images (convert, resize, rename, etc.)
+calendar_DESC= Create calendars
+# broken
+# dlnaexport_DESC= Export collection on DLNA network service
+debianscreenshots_DESC= Export images to Debian Screenshots web service
+dngconverter_DESC= Convert Raw Image to Digital NeGative
+expoblending_DESC= Create pseudo HDR image with a stack of bracketed images
+facebook_DESC= Import/export images to/from a remote Facebook web service
+flashexport_DESC= Export images to Flash using SimpleViewer
+flickrexport_DESC= Export images to a remote Flickr based web service
+gpssync_DESC= Geolocalize pictures
+galleryexport_DESC= Export images to a remote Gallery
+htmlexport_DESC= Export images collections into a static XHTML page
+imageshackexport_DESC= Export images to ImageShack web service
+imageviewer_DESC= Preview images using OpenGL
+imgurexport_DESC= Export images to ImgUr web service
+ipodexport_DESC= Export pictures to an Ipod device
+jpeglossless_DESC= Rotate/flip images without losing quality
+kioexport_DESC= Export images to remote computer using network protocol
+kmlexport_DESC= Create KML files to present images with coordinates
+kopete_DESC= Export images to an instant messaging contact
+mediawiki_DESC= Export images to Mediawiki based web service
+metadataedit_DESC= Edit EXIF, IPTC and XMP metadata
+panorama_DESC= Assemble panoramic photo automatically
+# not ready for production yet
+# photivointegration_DESC= Integration of the Photivo RAW-Processor
+photolayoutseditor_DESC=Assemble images together
+picasawebexport_DESC= Export images to a remote Picasa web service
+piwigoexport_DESC= Export images to a remote Piwigo (PHPWebGallery) server
+printimages_DESC= Print images in various format
+rajceexport_DESC= Export images to Rajce web service
+rawconverter_DESC= Convert Raw Image to JPEG/PNG/TIFF
+removeredeyes_DESC= Remove red eyes on image automatically
+sendimages_DESC= Send images by e-mail
+shwup_DESC= Export images to Shwup web service
+smug_DESC= Import/export images to/from a remote SmugMug web service
+timeadjust_DESC= Adjust date and time
+videoslideshow_DESC= Export images as Video Slide Show
+vkontakte_DESC= Export images to VKontakte web service
+# Requires https://bugs.kde.org/show_bug.cgi?id=217950
+# wallpaper_DESC= Set image as background on desktop
+yandexfotki_DESC= Export images to Yandex web service
+
+.if !defined(NO_BUILD)
DISTNAME= digikam-${DIGIKAM_VER}
LICENSE?= GPLv2
USE_BZIP2= yes
-USES= cmake
+USES+= cmake
USE_KDE4+= automoc4 kdehier kdeprefix kdelibs
USE_QT4+= qmake_build moc_build rcc_build uic_build
-USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
WRKSRC?= ${WRKDIR}/${DISTNAME}/extra/${PORTNAME}
DISTINFO_FILE= ${.CURDIR}/../../graphics/digikam-kde4/distinfo
+
+. if defined(KIPI_PLUGIN)
+CONFLICTS_INSTALL= kipi-plugins-2.*
+
+DESCR= ${.CURDIR}/../../graphics/kipi-plugins-kde4/pkg-descr
+USE_PKGCONFIG= build
+
+.if ${KIPI_PLUGIN} != "libkipiplugins"
+EXTRA_PATCHES= ${.CURDIR}/../../graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt
+LIB_DEPENDS+= kipiplugins:${PORTSDIR}/graphics/libkipiplugins
+.endif
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/extra/kipi-plugins
+BUILD_WRKSRC= ${WRKSRC}/${${KIPI_PLUGIN}_DIR}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+${KIPI_PLUGIN}_DIR?= ${KIPI_PLUGIN}
+
+post-configure: post-kipi-configure
+
+post-kipi-configure:
+ ${ECHO_CMD} '#define GITVERSION "unknown"' > ${WRKSRC}/common/libkipiplugins/gitversion.h
+.if ${KIPI_PLUGIN} != "libkipiplugins"
+ ${LN} -s ${KDE4_PREFIX}/lib/libkipiplugins.so ${WRKSRC}/lib/libkipiplugins.so
+.endif
+
+. endif # defined(KIPI_PLUGIN)
+.endif # !defined(NO_BUILD)
diff --git a/graphics/digikam-kde4/distinfo b/graphics/digikam-kde4/distinfo
index 076961537ef5..26ef8cb7c2be 100644
--- a/graphics/digikam-kde4/distinfo
+++ b/graphics/digikam-kde4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (digikam-2.9.0.tar.bz2) = 73dd0f3820fc44bba7b72c98cab73d0391e98687674da8be11ff07590c703ba0
-SIZE (digikam-2.9.0.tar.bz2) = 56765772
+SHA256 (digikam-3.1.0.tar.bz2) = f70fc84f3a680a855642fcc4664710116406bbe4068b0ad4d2cfb4127684c2aa
+SIZE (digikam-3.1.0.tar.bz2) = 58559707
diff --git a/graphics/digikam-kde4/files/patch-CMakeLists.txt b/graphics/digikam-kde4/files/patch-CMakeLists.txt
index 0cc5595e7a9e..5d85151a9c23 100644
--- a/graphics/digikam-kde4/files/patch-CMakeLists.txt
+++ b/graphics/digikam-kde4/files/patch-CMakeLists.txt
@@ -25,20 +25,3 @@
IF(USE_SCRIPT_IFACE)
INCLUDE_DIRECTORIES(${QT_QTSCRIPT_INCLUDE_DIR})
ENDIF(USE_SCRIPT_IFACE)
-@@ -1689,6 +1694,16 @@
- MACRO_OPTIONAL_ADD_SUBDIRECTORY(tests)
- ENDIF(KDE4_BUILD_TESTS)
-
-+ OPTION(WITH_NLS "NLS Support" ON)
-+ IF(WITH_NLS)
-+ FIND_PACKAGE(Msgfmt REQUIRED)
-+ FIND_PACKAGE(Gettext REQUIRED)
-+ ADD_SUBDIRECTORY(po)
-+ ENDIF(WITH_NLS)
-+
-+ ADD_SUBDIRECTORY(doc/digikam/digikam)
-+ ADD_SUBDIRECTORY(doc/digikam/showfoto)
-+
- IF(NOT WIN32)
- CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/digikam.lsm.cmake ${CMAKE_CURRENT_BINARY_DIR}/digikam.lsm)
- ENDIF(NOT WIN32)
diff --git a/graphics/digikam-kde4/files/patch-cmake__modules__FindPGF.cmake b/graphics/digikam-kde4/files/patch-cmake__modules__FindPGF.cmake
deleted file mode 100644
index f3de1430b4d1..000000000000
--- a/graphics/digikam-kde4/files/patch-cmake__modules__FindPGF.cmake
+++ /dev/null
@@ -1,53 +0,0 @@
---- ./cmake/modules/FindPGF.cmake.orig 2012-07-07 19:25:02.000000000 -0400
-+++ ./cmake/modules/FindPGF.cmake 2012-07-14 10:17:02.000000000 -0400
-@@ -4,27 +4,34 @@
- # PGF_FOUND - system has libgf
- # PGF_INCLUDE_DIRS - the libpgf include directory
- # PGF_LIBRARIES - Link these to use libpgf
--# PGF_CODEC_VERSION_ID - PGF codec version ID.
-
--# PKG-CONFIG is required.
--INCLUDE(FindPkgConfig REQUIRED)
-+INCLUDE(FindPkgConfig)
-
- IF(PKG_CONFIG_FOUND)
-
-- INCLUDE(FindPkgConfig)
-+ PKG_CHECK_MODULES(PC_LIBPGF libpgf)
-
-- PKG_CHECK_MODULES(PGF libpgf)
-+ENDIF(PKG_CONFIG_FOUND)
-
-- IF(PGF_FOUND)
-- MESSAGE(STATUS "PGF_INCLUDE_DIRS = ${PGF_INCLUDE_DIRS}")
-- MESSAGE(STATUS "PGF_INCLUDEDIR = ${PGF_INCLUDEDIR}")
-- MESSAGE(STATUS "PGF_LIBRARIES = ${PGF_LIBRARIES}")
-- MESSAGE(STATUS "PGF_LDFLAGS = ${PGF_LDFLAGS}")
-- MESSAGE(STATUS "PGF_CFLAGS = ${PGF_CFLAGS}")
-- MESSAGE(STATUS "PGF_VERSION = ${PGF_VERSION}")
-+FIND_LIBRARY (PGF_LIBRARIES
-+ NAMES
-+ pgf
-+ HINTS
-+ ${PC_LIBPGF_LIBDIR}
-+ ${PC_LIBPGF_LIBRARY_DIRS}
-+ ${LIB_INSTALL_DIR}
-+)
-
-- STRING(REPLACE "." "" PGF_CODEC_VERSION_ID "${PGF_VERSION}")
-- MESSAGE(STATUS "PGF_CODEC_VERSION_ID = ${PGF_CODEC_VERSION_ID}")
-- ENDIF(PGF_FOUND)
-+FIND_PATH (PGF_INCLUDE_DIRS
-+ NAMES
-+ PGFtypes.h
-+ PATH_SUFFIXES
-+ libpgf
-+ HINTS
-+ ${PC_LIBPGF_INCLUDEDIR}
-+ ${PC_LIBPGF_INCLUDE_DIRS}
-+ ${INCLUDE_INSTALL_DIR}
-+)
-
--ENDIF(PKG_CONFIG_FOUND)
-+INCLUDE(FindPackageHandleStandardArgs)
-+FIND_PACKAGE_HANDLE_STANDARD_ARGS(PGF DEFAULT_MSG PGF_LIBRARIES PGF_INCLUDE_DIRS)
diff --git a/graphics/digikam-kde4/files/patch-digikam__album__albumwatch.cpp b/graphics/digikam-kde4/files/patch-digikam__album__albumwatch.cpp
index efec65a1df73..d742f6dc1639 100644
--- a/graphics/digikam-kde4/files/patch-digikam__album__albumwatch.cpp
+++ b/graphics/digikam-kde4/files/patch-digikam__album__albumwatch.cpp
@@ -1,11 +1,11 @@
---- ./digikam/album/albumwatch.cpp.orig 2012-09-05 19:38:42.000000000 -0400
-+++ ./digikam/album/albumwatch.cpp 2012-09-05 19:40:59.000000000 -0400
-@@ -221,7 +221,7 @@
- #ifdef Q_WS_MAC
+--- ./digikam/album/albumwatch.cpp.orig 2013-04-04 16:03:45.920385000 +0000
++++ ./digikam/album/albumwatch.cpp 2013-04-04 16:04:05.410385977 +0000
+@@ -278,7 +278,7 @@
+ // Disable file watch for OS X and Windows and hope for future
+ // improvement (possibly with the improvements planned for
+ // QFileSystemWatcher in Qt 5.1)
+-#if defined(Q_WS_MAC) || defined(Q_WS_WIN)
++#if defined(Q_WS_MAC) || defined(Q_WS_WIN) || defined(Q_OS_FREEBSD)
d->dirWatch->addDir(dir, KDirWatch::WatchDirOnly);
- #else
-- d->dirWatch->addDir(dir, KDirWatch::WatchFiles | KDirWatch::WatchDirOnly);
-+ d->dirWatch->addDir(dir, KDirWatch::WatchDirOnly);
- #endif
- }
- }
+ #else
+ d->dirWatch->addDir(dir, KDirWatch::WatchFiles | KDirWatch::WatchDirOnly);
diff --git a/graphics/digikam-kde4/pkg-plist b/graphics/digikam-kde4/pkg-plist
index 12c3c76fedeb..1b61616334aa 100644
--- a/graphics/digikam-kde4/pkg-plist
+++ b/graphics/digikam-kde4/pkg-plist
@@ -7,7 +7,6 @@ lib/kde4/digikamimageplugin_decorate.so
lib/kde4/digikamimageplugin_enhance.so
lib/kde4/digikamimageplugin_fxfilters.so
lib/kde4/digikamimageplugin_transform.so
-lib/kde4/digikamnepomukservice.so
lib/kde4/kio_digikamalbums.so
lib/kde4/kio_digikamdates.so
lib/kde4/kio_digikammapimages.so
@@ -15,17 +14,16 @@ lib/kde4/kio_digikamsearch.so
lib/kde4/kio_digikamtags.so
%%MYSQL%%lib/kde4/libexec/digikamdatabaseserver
lib/libdigikamcore.so
-lib/libdigikamcore.so.2
-lib/libdigikamcore.so.2.0.0
+lib/libdigikamcore.so.3
+lib/libdigikamcore.so.3.0.0
lib/libdigikamdatabase.so
-lib/libdigikamdatabase.so.2
-lib/libdigikamdatabase.so.2.0.0
+lib/libdigikamdatabase.so.3
+lib/libdigikamdatabase.so.3.0.0
share/applications/kde4/digikam.desktop
share/applications/kde4/showfoto.desktop
share/apps/digikam/about/digikam.css
share/apps/digikam/about/main.html
share/apps/digikam/about/top-left-digikam.png
-share/apps/digikam/cameraui.rc
share/apps/digikam/data/assistant-collection.png
share/apps/digikam/data/assistant-metadata.png
share/apps/digikam/data/assistant-openfile.png
@@ -62,6 +60,7 @@ share/apps/digikam/data/ice-pattern.png
share/apps/digikam/data/image-full.png
share/apps/digikam/data/image-selection.png
share/apps/digikam/data/leaf-pattern.png
+share/apps/digikam/data/logo-beta.png
share/apps/digikam/data/logo-cimg.png
share/apps/digikam/data/logo-digikam.png
share/apps/digikam/data/logo-exiv2.png
@@ -499,41 +498,7 @@ share/apps/digikam/icons/hicolor/scalable/actions/superimpose.svgz
share/apps/digikam/icons/hicolor/scalable/actions/texture.svgz
share/apps/digikam/icons/hicolor/scalable/actions/tonemap.svgz
share/apps/digikam/icons/hicolor/scalable/actions/whitebalance.svgz
-share/apps/digikam/lensfun/6x6.xml
-share/apps/digikam/lensfun/compact-canon.xml
-share/apps/digikam/lensfun/compact-casio.xml
-share/apps/digikam/lensfun/compact-fujifilm.xml
-share/apps/digikam/lensfun/compact-kodak.xml
-share/apps/digikam/lensfun/compact-konica-minolta.xml
-share/apps/digikam/lensfun/compact-leica.xml
-share/apps/digikam/lensfun/compact-nikon.xml
-share/apps/digikam/lensfun/compact-olympus.xml
-share/apps/digikam/lensfun/compact-panasonic.xml
-share/apps/digikam/lensfun/compact-pentax.xml
-share/apps/digikam/lensfun/compact-ricoh.xml
-share/apps/digikam/lensfun/compact-sigma.xml
-share/apps/digikam/lensfun/compact-sony.xml
-share/apps/digikam/lensfun/generic.xml
-share/apps/digikam/lensfun/mil-olympus.xml
-share/apps/digikam/lensfun/mil-panasonic.xml
-share/apps/digikam/lensfun/mil-samsung.xml
-share/apps/digikam/lensfun/mil-sony.xml
-share/apps/digikam/lensfun/rf-leica.xml
-share/apps/digikam/lensfun/slr-canon.xml
-share/apps/digikam/lensfun/slr-contax.xml
-share/apps/digikam/lensfun/slr-hasselblad.xml
-share/apps/digikam/lensfun/slr-konica-minolta.xml
-share/apps/digikam/lensfun/slr-nikon.xml
-share/apps/digikam/lensfun/slr-olympus.xml
-share/apps/digikam/lensfun/slr-panasonic.xml
-share/apps/digikam/lensfun/slr-pentax.xml
-share/apps/digikam/lensfun/slr-samsung.xml
-share/apps/digikam/lensfun/slr-schneider.xml
-share/apps/digikam/lensfun/slr-sigma.xml
-share/apps/digikam/lensfun/slr-sony.xml
-share/apps/digikam/lensfun/slr-tamron.xml
-share/apps/digikam/lensfun/slr-tokina.xml
-share/apps/digikam/lensfun/slr-ussr.xml
+share/apps/digikam/importui.rc
share/apps/digikam/lighttablewindowui.rc
share/apps/digikam/queuemgrwindowui.rc
share/apps/digikam/tips
@@ -544,259 +509,6 @@ share/apps/showfoto/data/logo-showfoto.png
share/apps/showfoto/data/splash-showfoto.png
share/apps/showfoto/showfotoui.rc
share/apps/solid/actions/digikam-opencamera.desktop
-share/doc/HTML/en/digikam/2Greens.png
-share/doc/HTML/en/digikam/542px-CIExy1931_sRGB_svg.png
-share/doc/HTML/en/digikam/DAM-Metadata.png
-share/doc/HTML/en/digikam/DAM-Workflow.png
-share/doc/HTML/en/digikam/DAM-errors.png
-share/doc/HTML/en/digikam/DAM-pyramid.png
-share/doc/HTML/en/digikam/DAM-story.png
-share/doc/HTML/en/digikam/DAM-transmission.png
-share/doc/HTML/en/digikam/ICCworkflowlogic.png
-share/doc/HTML/en/digikam/addinglibraries.png
-share/doc/HTML/en/digikam/adjustcurvesdialog.png
-share/doc/HTML/en/digikam/adjustcurvespreview.png
-share/doc/HTML/en/digikam/adjustlevelsdialog.png
-share/doc/HTML/en/digikam/adjustlevelspreview.png
-share/doc/HTML/en/digikam/antivignettingdialog.png
-share/doc/HTML/en/digikam/antivignettingpreview.png
-share/doc/HTML/en/digikam/blowupdialog.png
-share/doc/HTML/en/digikam/blowuppreview.png
-share/doc/HTML/en/digikam/blowupsettings1.png
-share/doc/HTML/en/digikam/blowupsettings2.png
-share/doc/HTML/en/digikam/blurfx_farblur.png
-share/doc/HTML/en/digikam/blurfx_focusblur.png
-share/doc/HTML/en/digikam/blurfx_frostglass.png
-share/doc/HTML/en/digikam/blurfx_mosaic.png
-share/doc/HTML/en/digikam/blurfx_motionblur.png
-share/doc/HTML/en/digikam/blurfx_radialblur.png
-share/doc/HTML/en/digikam/blurfx_shakeblur.png
-share/doc/HTML/en/digikam/blurfx_smartblur.png
-share/doc/HTML/en/digikam/blurfx_softenerblur.png
-share/doc/HTML/en/digikam/blurfx_zoomblur.png
-share/doc/HTML/en/digikam/blurfxpreview.png
-share/doc/HTML/en/digikam/borderpreview.png
-share/doc/HTML/en/digikam/cameraclient.png
-share/doc/HTML/en/digikam/cameraclientdownload.png
-share/doc/HTML/en/digikam/cameraclientidentity.png
-share/doc/HTML/en/digikam/cameraclientitemproperties.png
-share/doc/HTML/en/digikam/cameraclientsetting1.png
-share/doc/HTML/en/digikam/cameraclientsetting2.png
-share/doc/HTML/en/digikam/cameraclientsetting3.png
-share/doc/HTML/en/digikam/camerafolderselectiondialog.png
-share/doc/HTML/en/digikam/cameratargetalbumdialog.png
-share/doc/HTML/en/digikam/channelmixerdialog.png
-share/doc/HTML/en/digikam/channelmixerpreview.png
-share/doc/HTML/en/digikam/charcoalpreview.png
-share/doc/HTML/en/digikam/cimg-logo.png
-share/doc/HTML/en/digikam/color-management.docbook
-share/doc/HTML/en/digikam/colormanagement.png
-share/doc/HTML/en/digikam/common
-share/doc/HTML/en/digikam/credits-annex.docbook
-share/doc/HTML/en/digikam/digikamlogo.png
-share/doc/HTML/en/digikam/distortionfx_blockwaves1.png
-share/doc/HTML/en/digikam/distortionfx_blockwaves2.png
-share/doc/HTML/en/digikam/distortionfx_caricature.png
-share/doc/HTML/en/digikam/distortionfx_circularwaves1.png
-share/doc/HTML/en/digikam/distortionfx_circularwaves2.png
-share/doc/HTML/en/digikam/distortionfx_corners.png
-share/doc/HTML/en/digikam/distortionfx_cylinderh.png
-share/doc/HTML/en/digikam/distortionfx_cylinderhv.png
-share/doc/HTML/en/digikam/distortionfx_cylinderv.png
-share/doc/HTML/en/digikam/distortionfx_fisheyes.png
-share/doc/HTML/en/digikam/distortionfx_polarcoord.png
-share/doc/HTML/en/digikam/distortionfx_tiles.png
-share/doc/HTML/en/digikam/distortionfx_twirl.png
-share/doc/HTML/en/digikam/distortionfx_unpolarcoord.png
-share/doc/HTML/en/digikam/distortionfx_wavesh.png
-share/doc/HTML/en/digikam/distortionfx_wavesv.png
-share/doc/HTML/en/digikam/distortionfxpreview.png
-share/doc/HTML/en/digikam/distortions.png
-share/doc/HTML/en/digikam/duplicates_albumsfilter.png
-share/doc/HTML/en/digikam/editor-color.docbook
-share/doc/HTML/en/digikam/editor-decorate.docbook
-share/doc/HTML/en/digikam/editor-enhance.docbook
-share/doc/HTML/en/digikam/editor-filters.docbook
-share/doc/HTML/en/digikam/editor-redeyes-correction.png
-share/doc/HTML/en/digikam/editor-transform.docbook
-share/doc/HTML/en/digikam/editorautolevels.png
-share/doc/HTML/en/digikam/editorautosizebutton.png
-share/doc/HTML/en/digikam/editorbcgadjust.png
-share/doc/HTML/en/digikam/editorblurplugin.png
-share/doc/HTML/en/digikam/editorbwfilter.png
-share/doc/HTML/en/digikam/editorcolorbalance.png
-share/doc/HTML/en/digikam/editorcommondialogtools.png
-share/doc/HTML/en/digikam/editorconvert_brown.png
-share/doc/HTML/en/digikam/editorconvert_bw.png
-share/doc/HTML/en/digikam/editorconvert_bwgreen.png
-share/doc/HTML/en/digikam/editorconvert_bworange.png
-share/doc/HTML/en/digikam/editorconvert_bwred.png
-share/doc/HTML/en/digikam/editorconvert_bwyellow.png
-share/doc/HTML/en/digikam/editorconvert_cold.png
-share/doc/HTML/en/digikam/editorconvert_original.png
-share/doc/HTML/en/digikam/editorconvert_platinium.png
-share/doc/HTML/en/digikam/editorconvert_selenium.png
-share/doc/HTML/en/digikam/editorconvert_sepia.png
-share/doc/HTML/en/digikam/editorcropbutton.png
-share/doc/HTML/en/digikam/editorequalize.png
-share/doc/HTML/en/digikam/editorgoldensectionsexample.png
-share/doc/HTML/en/digikam/editorgoldenspiralexample.png
-share/doc/HTML/en/digikam/editorgoldenspiralsectionsexample.png
-share/doc/HTML/en/digikam/editorgoldentrianglesexample.png
-share/doc/HTML/en/digikam/editorharmonioustrianglesexample.png
-share/doc/HTML/en/digikam/editorhistogramdescription.png
-share/doc/HTML/en/digikam/editorhistogramsample1.png
-share/doc/HTML/en/digikam/editorhistogramsample2.png
-share/doc/HTML/en/digikam/editorhistogramsample3.png
-share/doc/HTML/en/digikam/editorhsladjust.png
-share/doc/HTML/en/digikam/editoriccprofile.png
-share/doc/HTML/en/digikam/editorimageselection.png
-share/doc/HTML/en/digikam/editorneon.png
-share/doc/HTML/en/digikam/editornoisereductionplugin.png
-share/doc/HTML/en/digikam/editornormalize.png
-share/doc/HTML/en/digikam/editorpreview.png
-share/doc/HTML/en/digikam/editorraindropsplugin.png
-share/doc/HTML/en/digikam/editorratiocroptool.png
-share/doc/HTML/en/digikam/editorresizetool.png
-share/doc/HTML/en/digikam/editorrevertbutton.png
-share/doc/HTML/en/digikam/editorrulethirdlinesexample.png
-share/doc/HTML/en/digikam/editorsharpenplugin.png
-share/doc/HTML/en/digikam/editorstretchcontrast.png
-share/doc/HTML/en/digikam/editortoolbar.png
-share/doc/HTML/en/digikam/editorunsharpedmaskplugin.png
-share/doc/HTML/en/digikam/editorvivid.png
-share/doc/HTML/en/digikam/editorzoombuttons.png
-share/doc/HTML/en/digikam/embosspreview.png
-share/doc/HTML/en/digikam/file-formats.docbook
-share/doc/HTML/en/digikam/filmgrainpreview.png
-share/doc/HTML/en/digikam/firstrunassistant_step1.png
-share/doc/HTML/en/digikam/firstrunassistant_step2.png
-share/doc/HTML/en/digikam/firstrunassistant_step3.png
-share/doc/HTML/en/digikam/firstrunassistant_step4.png
-share/doc/HTML/en/digikam/firstrunassistant_step5.png
-share/doc/HTML/en/digikam/firstrunassistant_step6.png
-share/doc/HTML/en/digikam/firstrunassistant_step7.png
-share/doc/HTML/en/digikam/firstrunassistant_step8.png
-share/doc/HTML/en/digikam/freerotationpreview.png
-share/doc/HTML/en/digikam/fuzzysearchsimilar.png
-share/doc/HTML/en/digikam/handheld_gps.png
-share/doc/HTML/en/digikam/hotpixelsdialog.png
-share/doc/HTML/en/digikam/hotpixelspreview.png
-share/doc/HTML/en/digikam/ie-menu.docbook
-share/doc/HTML/en/digikam/index.cache.bz2
-share/doc/HTML/en/digikam/index.docbook
-share/doc/HTML/en/digikam/infraredpreview.png
-share/doc/HTML/en/digikam/inpaintingdialog.png
-share/doc/HTML/en/digikam/inpaintingpreview.png
-share/doc/HTML/en/digikam/inpaintingsettings1.png
-share/doc/HTML/en/digikam/inpaintingsettings2.png
-share/doc/HTML/en/digikam/inserttextpreview.png
-share/doc/HTML/en/digikam/introductionfirewireconnector.png
-share/doc/HTML/en/digikam/introductionfirstrundialog.png
-share/doc/HTML/en/digikam/introductionfoldericon.png
-share/doc/HTML/en/digikam/introductionplugininterfaces.png
-share/doc/HTML/en/digikam/introductionscandialog.png
-share/doc/HTML/en/digikam/introductionserialconnector.png
-share/doc/HTML/en/digikam/introductionusbconnector.png
-share/doc/HTML/en/digikam/lensdistortiondialog.png
-share/doc/HTML/en/digikam/lensdistortionpreview.png
-share/doc/HTML/en/digikam/lighttable.png
-share/doc/HTML/en/digikam/logo.png
-share/doc/HTML/en/digikam/maininterfacealbumproperties.png
-share/doc/HTML/en/digikam/maininterfaceassigntags.png
-share/doc/HTML/en/digikam/maininterfacedateview.png
-share/doc/HTML/en/digikam/maininterfacepreview.png
-share/doc/HTML/en/digikam/maininterfacequicksearch.png
-share/doc/HTML/en/digikam/maininterfacesearchview.png
-share/doc/HTML/en/digikam/maininterfacetagsview.png
-share/doc/HTML/en/digikam/maininterfacetoolbar.png
-share/doc/HTML/en/digikam/maininterfaceview.png
-share/doc/HTML/en/digikam/menu-descriptions.docbook
-share/doc/HTML/en/digikam/menualbum.png
-share/doc/HTML/en/digikam/menucamera.png
-share/doc/HTML/en/digikam/menuexport.png
-share/doc/HTML/en/digikam/menuhelp.png
-share/doc/HTML/en/digikam/menuimage.png
-share/doc/HTML/en/digikam/menuimagemetadata.png
-share/doc/HTML/en/digikam/menuimport.png
-share/doc/HTML/en/digikam/menuselect.png
-share/doc/HTML/en/digikam/menusettings.png
-share/doc/HTML/en/digikam/menutag.png
-share/doc/HTML/en/digikam/menutools.png
-share/doc/HTML/en/digikam/menutoolsbatch.png
-share/doc/HTML/en/digikam/menuview.png
-share/doc/HTML/en/digikam/noisereductiondialog.png
-share/doc/HTML/en/digikam/noisereductionpreview.png
-share/doc/HTML/en/digikam/noiseremovaltool.png
-share/doc/HTML/en/digikam/oilpaintpreview.png
-share/doc/HTML/en/digikam/perspectivepreview.png
-share/doc/HTML/en/digikam/photo-editing.docbook
-share/doc/HTML/en/digikam/raindropspreview.png
-share/doc/HTML/en/digikam/rawcamerasupport.png
-share/doc/HTML/en/digikam/refocus-notsharpened.png
-share/doc/HTML/en/digikam/refocus-refocus.png
-share/doc/HTML/en/digikam/refocus-sharped.png
-share/doc/HTML/en/digikam/refocus-unsharpmask.png
-share/doc/HTML/en/digikam/refocusdialog.png
-share/doc/HTML/en/digikam/restorationdialog.png
-share/doc/HTML/en/digikam/restorationpreview.png
-share/doc/HTML/en/digikam/restorationpreview2.png
-share/doc/HTML/en/digikam/restorationsettings1.png
-share/doc/HTML/en/digikam/restorationsettings2.png
-share/doc/HTML/en/digikam/searchinterface.png
-share/doc/HTML/en/digikam/setupaddcamera.png
-share/doc/HTML/en/digikam/setupalbum.png
-share/doc/HTML/en/digikam/setupcamera.png
-share/doc/HTML/en/digikam/setupcollections.png
-share/doc/HTML/en/digikam/setupembeddedinfo.png
-share/doc/HTML/en/digikam/setupiccprofiles.png
-share/doc/HTML/en/digikam/setupimageeditor.png
-share/doc/HTML/en/digikam/setupimageplugins.png
-share/doc/HTML/en/digikam/setupkipiplugins.png
-share/doc/HTML/en/digikam/setuplighttable.png
-share/doc/HTML/en/digikam/setupmimetypes.png
-share/doc/HTML/en/digikam/setupmisc.png
-share/doc/HTML/en/digikam/setuprawfiledecoding.png
-share/doc/HTML/en/digikam/setupsaveimages.png
-share/doc/HTML/en/digikam/setupslideshow.png
-share/doc/HTML/en/digikam/setupthemeclean.png
-share/doc/HTML/en/digikam/setupthemedark.png
-share/doc/HTML/en/digikam/setupthemedefault.png
-share/doc/HTML/en/digikam/setupthemedessert.png
-share/doc/HTML/en/digikam/setupthemedigicasa.png
-share/doc/HTML/en/digikam/setupthemedreary.png
-share/doc/HTML/en/digikam/setupthememarine.png
-share/doc/HTML/en/digikam/setupthemeorangecrush.png
-share/doc/HTML/en/digikam/setupthemesandy.png
-share/doc/HTML/en/digikam/setuptooltip.png
-share/doc/HTML/en/digikam/sheartoolpreview.png
-share/doc/HTML/en/digikam/sidebar.docbook
-share/doc/HTML/en/digikam/sidebarcolorshistogramviewer.png
-share/doc/HTML/en/digikam/sidebarcommentstags.png
-share/doc/HTML/en/digikam/sidebarfileproperties.png
-share/doc/HTML/en/digikam/sidebargeolocation.png
-share/doc/HTML/en/digikam/sidebarmetadata.png
-share/doc/HTML/en/digikam/sidebarmetadataexif.png
-share/doc/HTML/en/digikam/sidebarmetadatagps.png
-share/doc/HTML/en/digikam/sidebarmetadataiptc.png
-share/doc/HTML/en/digikam/sidebarmetadatamakernote.png
-share/doc/HTML/en/digikam/sidebartagfilters.png
-share/doc/HTML/en/digikam/solarizepreview.png
-share/doc/HTML/en/digikam/superimposepreview.png
-share/doc/HTML/en/digikam/texturedialog.png
-share/doc/HTML/en/digikam/texturepreview.png
-share/doc/HTML/en/digikam/timeline.png
-share/doc/HTML/en/digikam/unsharpdialog.png
-share/doc/HTML/en/digikam/unsharppreview.png
-share/doc/HTML/en/digikam/vignettingcorrectiondialog.png
-share/doc/HTML/en/digikam/whitebalancedialog.png
-share/doc/HTML/en/showfoto/common
-share/doc/HTML/en/showfoto/index.cache.bz2
-share/doc/HTML/en/showfoto/index.docbook
-share/doc/HTML/en/showfoto/introductionplugininterfaces.png
-share/doc/HTML/en/showfoto/setupgeneral.png
-share/doc/HTML/en/showfoto/setupplugins.png
-share/doc/HTML/en/showfoto/setupslideshow.png
share/icons/hicolor/128x128/apps/digikam.png
share/icons/hicolor/128x128/apps/showfoto.png
share/icons/hicolor/16x16/apps/digikam.png
@@ -821,71 +533,12 @@ share/kde4/services/digikamimageplugin_enhance.desktop
share/kde4/services/digikamimageplugin_fxfilters.desktop
share/kde4/services/digikamimageplugin_transform.desktop
share/kde4/services/digikammapimages.protocol
-share/kde4/services/digikamnepomukservice.desktop
share/kde4/services/digikamsearch.protocol
share/kde4/services/digikamtags.protocol
share/kde4/servicetypes/digikamimageplugin.desktop
-%%NLS%%share/locale/ar/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/be/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/bg/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/bs/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/ca/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/da/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/de/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/el/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/en_GB/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/eo/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/es/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/et/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/eu/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/fa/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/ga/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/gl/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/he/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/hi/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/hr/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/is/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/it/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/km/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/lv/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/ms/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/nb/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/nds/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/ne/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/nn/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/pa/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/pt/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/se/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/sk/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/sl/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/sq/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/th/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/digikam.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/digikam.mo
-@dirrmtry share/icons/hicolor/256x256/apps
-@dirrmtry share/icons/hicolor/256x256
-@dirrm share/doc/HTML/en/showfoto
-@dirrm share/doc/HTML/en/digikam
@dirrm share/apps/showfoto/data
@dirrm share/apps/showfoto
@dirrm share/apps/digikam/utils
-@dirrm share/apps/digikam/lensfun
@dirrm share/apps/digikam/icons/hicolor/scalable/actions
@dirrm share/apps/digikam/icons/hicolor/scalable
@dirrm share/apps/digikam/icons/hicolor/64x64/mimetypes