aboutsummaryrefslogtreecommitdiff
path: root/graphics/digikam/files
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2020-07-17 15:34:03 +0000
committerDima Panov <fluffy@FreeBSD.org>2020-07-17 15:34:03 +0000
commit515e79eeb102086f38044b1fe93441de21f679bc (patch)
tree8785db4be204db875a8b68a574168271e16a5694 /graphics/digikam/files
parent95116534c36cd8188d2bb4cb87b61407060c40c3 (diff)
downloadports-515e79eeb102086f38044b1fe93441de21f679bc.tar.gz
ports-515e79eeb102086f38044b1fe93441de21f679bc.zip
graphics/digikam: update to 7.0.0 release
Notes
Notes: svn path=/head/; revision=542441
Diffstat (limited to 'graphics/digikam/files')
-rw-r--r--graphics/digikam/files/patch-CMakeLists.txt8
-rw-r--r--graphics/digikam/files/patch-core_CMakeLists.txt21
-rw-r--r--graphics/digikam/files/patch-core_cmake_modules_FindQtAV.cmake10
-rw-r--r--graphics/digikam/files/patch-core_dplugins_generic_view_presentation_opengl_presentationgl.cpp10
-rw-r--r--graphics/digikam/files/patch-core_libs_dimg_filters_curves_curveswidget.cpp10
-rw-r--r--graphics/digikam/files/patch-core_libs_dimg_filters_levels_histogrampainter.cpp10
-rw-r--r--graphics/digikam/files/patch-core_libs_rawengine_libraw_internal_libraw__x3f.cpp11
-rw-r--r--graphics/digikam/files/patch-remove-libxmp33
8 files changed, 21 insertions, 92 deletions
diff --git a/graphics/digikam/files/patch-CMakeLists.txt b/graphics/digikam/files/patch-CMakeLists.txt
index a3ee6fa9f401..cd2f07e9b296 100644
--- a/graphics/digikam/files/patch-CMakeLists.txt
+++ b/graphics/digikam/files/patch-CMakeLists.txt
@@ -1,11 +1,11 @@
---- CMakeLists.txt.orig 2019-08-30 21:55:44 UTC
+--- CMakeLists.txt.orig 2020-04-23 11:51:20 UTC
+++ CMakeLists.txt
-@@ -14,6 +14,8 @@ set(ECM_MIN_VERSION "1.5.0")
+@@ -9,6 +9,8 @@ set(ECM_MIN_VERSION "1.7.0")
cmake_minimum_required(VERSION ${CMAKE_MIN_VERSION})
+cmake_policy(SET CMP0063 OLD) # Suppress visibility warnings
+
- ############## ECM setup #################################################################################################################
+ execute_process(COMMAND ${CMAKE_COMMAND} --version OUTPUT_VARIABLE VERSION_CMAKE_INFO)
+ message(STATUS "CMake version: ${VERSION_CMAKE_INFO}")
- find_package(ECM ${ECM_MIN_VERSION} CONFIG REQUIRED)
diff --git a/graphics/digikam/files/patch-core_CMakeLists.txt b/graphics/digikam/files/patch-core_CMakeLists.txt
index 67e7582b9b74..42ed65623cb8 100644
--- a/graphics/digikam/files/patch-core_CMakeLists.txt
+++ b/graphics/digikam/files/patch-core_CMakeLists.txt
@@ -1,22 +1,25 @@
---- core/CMakeLists.txt.orig 2019-07-31 16:12:57 UTC
+--- core/CMakeLists.txt.orig 2020-04-23 11:51:20 UTC
+++ core/CMakeLists.txt
-@@ -8,6 +8,7 @@
+@@ -10,6 +10,7 @@ APPLY_COMMON_POLICIES()
- project(digikam)
+ # ==============================================================================
+cmake_policy(SET CMP0063 OLD) # Suppress visibility warnings
message(STATUS "----------------------------------------------------------------------------------")
- message(STATUS "Starting CMake configuration for: ${PROJECT_NAME}")
-
-@@ -401,6 +402,11 @@ endif()
+ message(STATUS "Check dependencies for ${PROJECT_NAME} version ${DIGIKAM_VERSION_STRING}")
+ message(STATUS "")
+@@ -341,8 +342,13 @@ endif()
find_package(Doxygen)
- find_package(Lqr-1)
+
+-if(NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
++#if(NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
+ find_package(Lqr-1)
++#endif()
+if(LQR-1_FOUND)
+ include_directories(${LQR-1_INCLUDE_DIRS})
+ set(liblqr_LIBS ${LQR-1_LIBRARIES})
+ link_directories(${LQR-1_LIBDIR})
-+endif()
+ endif()
# -- libgphoto2 rules ----------------------------------------------------------
-
diff --git a/graphics/digikam/files/patch-core_cmake_modules_FindQtAV.cmake b/graphics/digikam/files/patch-core_cmake_modules_FindQtAV.cmake
index 03142953ede9..c8109722b04a 100644
--- a/graphics/digikam/files/patch-core_cmake_modules_FindQtAV.cmake
+++ b/graphics/digikam/files/patch-core_cmake_modules_FindQtAV.cmake
@@ -1,20 +1,20 @@
Add PATH_SUFFIXES to properly find the QtAV library.
---- core/cmake/modules/FindQtAV.cmake.orig 2017-01-08 22:08:44 UTC
+--- core/cmake/modules/FindQtAV.cmake.orig 2020-04-23 11:51:20 UTC
+++ core/cmake/modules/FindQtAV.cmake
-@@ -43,6 +43,7 @@ if (NOT APPLE)
+@@ -52,6 +52,7 @@ if (NOT APPLE)
libQtAV
libQtAV1
HINTS ${_qt5_install_prefix}/../
+ PATH_SUFFIXES qt5
)
-
+
find_library(QTAV_WIDGETS_LIBRARY
-@@ -51,6 +52,7 @@ if (NOT APPLE)
+@@ -60,6 +61,7 @@ if (NOT APPLE)
libQtAVWidgets
libQtAVWidgets1
HINTS ${_qt5_install_prefix}/../
+ PATH_SUFFIXES qt5
)
-
+
set(QTAV_INCLUDE_DIRS "${QTAV_CORE_INCLUDE_DIR} ${QTAV_WIDGETS_INCLUDE_DIR}")
diff --git a/graphics/digikam/files/patch-core_dplugins_generic_view_presentation_opengl_presentationgl.cpp b/graphics/digikam/files/patch-core_dplugins_generic_view_presentation_opengl_presentationgl.cpp
deleted file mode 100644
index 6e97b45a6aae..000000000000
--- a/graphics/digikam/files/patch-core_dplugins_generic_view_presentation_opengl_presentationgl.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- core/dplugins/generic/view/presentation/opengl/presentationgl.cpp.orig 2020-05-19 18:08:49 UTC
-+++ core/dplugins/generic/view/presentation/opengl/presentationgl.cpp
-@@ -44,6 +44,7 @@
- #include <QMatrix>
- #include <QMouseEvent>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QPixmap>
- #include <QTimer>
- #include <QWheelEvent>
diff --git a/graphics/digikam/files/patch-core_libs_dimg_filters_curves_curveswidget.cpp b/graphics/digikam/files/patch-core_libs_dimg_filters_curves_curveswidget.cpp
deleted file mode 100644
index f4258ffbc756..000000000000
--- a/graphics/digikam/files/patch-core_libs_dimg_filters_curves_curveswidget.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- core/libs/dimg/filters/curves/curveswidget.cpp.orig 2020-05-19 18:09:18 UTC
-+++ core/libs/dimg/filters/curves/curveswidget.cpp
-@@ -41,6 +41,7 @@
- #include <QFont>
- #include <QFontMetrics>
- #include <QPaintEvent>
-+#include <QPainterPath>
- #include <QMouseEvent>
-
- // KDE includes
diff --git a/graphics/digikam/files/patch-core_libs_dimg_filters_levels_histogrampainter.cpp b/graphics/digikam/files/patch-core_libs_dimg_filters_levels_histogrampainter.cpp
deleted file mode 100644
index b1bfc9894481..000000000000
--- a/graphics/digikam/files/patch-core_libs_dimg_filters_levels_histogrampainter.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- core/libs/dimg/filters/levels/histogrampainter.cpp.orig 2020-05-19 18:09:04 UTC
-+++ core/libs/dimg/filters/levels/histogrampainter.cpp
-@@ -30,6 +30,7 @@
- // Qt includes
-
- #include <QPainter>
-+#include <QPainterPath>
-
- // KDE includes
-
diff --git a/graphics/digikam/files/patch-core_libs_rawengine_libraw_internal_libraw__x3f.cpp b/graphics/digikam/files/patch-core_libs_rawengine_libraw_internal_libraw__x3f.cpp
deleted file mode 100644
index 25163017ed82..000000000000
--- a/graphics/digikam/files/patch-core_libs_rawengine_libraw_internal_libraw__x3f.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- core/libs/rawengine/libraw/internal/libraw_x3f.cpp.orig 2016-11-06 10:43:01 UTC
-+++ core/libs/rawengine/libraw/internal/libraw_x3f.cpp
-@@ -1392,7 +1392,7 @@ static void huffman_decode_row(x3f_info_
- x3f_directory_entry_t *DE,
- int bits,
- int row,
-- int offset,
-+ int16_t offset,
- int *minimum)
- {
- x3f_directory_entry_header_t *DEH = &DE->header;
diff --git a/graphics/digikam/files/patch-remove-libxmp b/graphics/digikam/files/patch-remove-libxmp
deleted file mode 100644
index d50bc0873d78..000000000000
--- a/graphics/digikam/files/patch-remove-libxmp
+++ /dev/null
@@ -1,33 +0,0 @@
-Digikam bundles libxmp. Since this is already in Exiv2, we end up
-with two copies of a bunch of symbols, and when Digikam loads
-both libraries, and it then initializes Exiv2, that in turn calls
-into the *wrong* copy of libxmp.
-
-Just remove the bundled copy.
-
-diff --git core/app/DigikamCoreTarget.cmake core/app/DigikamCoreTarget.cmake
-index bf8c9f09e7..53284724b4 100644
---- core/app/DigikamCoreTarget.cmake
-+++ core/app/DigikamCoreTarget.cmake
-@@ -24,7 +24,7 @@ set(DIGIKAMCORE_OBJECTS
- $<TARGET_OBJECTS:libwso2_src>
-
- $<TARGET_OBJECTS:libmd5_src>
-- $<TARGET_OBJECTS:libxmp_src>
-+ # $<TARGET_OBJECTS:libxmp_src>
- $<TARGET_OBJECTS:libdng_src>
- $<TARGET_OBJECTS:dngwriter_src>
-
-diff --git core/libs/dngwriter/CMakeLists.txt core/libs/dngwriter/CMakeLists.txt
-index dc28a9c865..dc83173b37 100644
---- core/libs/dngwriter/CMakeLists.txt
-+++ core/libs/dngwriter/CMakeLists.txt
-@@ -66,7 +66,7 @@ foreach(_currentfile ${libxmp_SRCS})
- endif()
- endforeach()
-
--add_library(libxmp_src OBJECT ${libxmp_SRCS})
-+# add_library(libxmp_src OBJECT ${libxmp_SRCS})
-
- #------------------------------------------------------------------------------------
-