aboutsummaryrefslogtreecommitdiff
path: root/graphics/dilay
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-06 19:48:39 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-08-06 19:48:39 +0000
commitc5d58a8706e1c237cfb6425c196df44be420d60c (patch)
treebb3960ee129f41a543ccdef5652039b3c404c854 /graphics/dilay
parentb6e16dc3983d4f8031abf58e217aeb2105179500 (diff)
downloadports-c5d58a8706e1c237cfb6425c196df44be420d60c.tar.gz
ports-c5d58a8706e1c237cfb6425c196df44be420d60c.zip
graphics/dilay: fix build with GCC-based architectures
GCC needs -Wno-narrowing: src/isosurface-extraction/grid.cpp:309:53: error: narrowing conversion of '-1' from 'int' to 'char' inside { } [-Wnarrowing] While here also add USES=gl. PR: 239312 Approved by: yuri (maintainer), tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D21143
Notes
Notes: svn path=/head/; revision=508280
Diffstat (limited to 'graphics/dilay')
-rw-r--r--graphics/dilay/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/dilay/Makefile b/graphics/dilay/Makefile
index db8b23a3397d..45ebc55af971 100644
--- a/graphics/dilay/Makefile
+++ b/graphics/dilay/Makefile
@@ -14,13 +14,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:math/glm
-USES= compiler:c++14-lang gmake qmake qt:5
+USES= compiler:c++14-lang gl gmake qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= abau
USE_CXXSTD= c++14
USE_GL= gl
USE_QT= core gui opengl widgets xml buildtools_build
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_gcc= -Wno-narrowing
MAKE_JOBS_UNSAFE= yes # Workaround for: https://github.com/abau/dilay/issues/19 parallel build fails (still a problem despite having been closed)
PLIST_FILES= bin/dilay \