aboutsummaryrefslogtreecommitdiff
path: root/graphics/djview4
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /graphics/djview4
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'graphics/djview4')
-rw-r--r--graphics/djview4/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/djview4/Makefile b/graphics/djview4/Makefile
index 1d2a29e0d985..07a1f240f80f 100644
--- a/graphics/djview4/Makefile
+++ b/graphics/djview4/Makefile
@@ -24,10 +24,10 @@ QT_NONSTANDARD= yes
CONFIGURE_ARGS= --x-includes="${X11BASE}/include" \
--x-libraries="${X11BASE}/lib"
CONFIGURE_ENV= QMAKE="${LOCALBASE}/bin/qmake-qt4" \
- QMAKESPEC="${QMAKESPEC}" \
- CFLAGS="-I${LOCALBASE}/include" \
- CXXFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ QMAKESPEC="${QMAKESPEC}"
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
.if defined(CXX) && ${CXX:M*icc}