aboutsummaryrefslogtreecommitdiff
path: root/graphics/drawpile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-10-04 06:24:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-10-04 06:24:09 +0000
commit31553aaf86854b6304da2f741afc8e36612d2347 (patch)
treecee6a24fec7f1f7c3eccc23e3916fea6f5194169 /graphics/drawpile
parent62fb1252f851530c2a4af4a270090d59ab5e47bb (diff)
downloadports-31553aaf86854b6304da2f741afc8e36612d2347.tar.gz
ports-31553aaf86854b6304da2f741afc8e36612d2347.zip
graphics/drawpile: Backport patch fixing compilation with libmicrohttpd 0.9.71; Backport patches fixing missing #include <QPainterPath>
PR: 250087 Submitted by: daniel.engberg.lists@pyret.net
Notes
Notes: svn path=/head/; revision=551356
Diffstat (limited to 'graphics/drawpile')
-rw-r--r--graphics/drawpile/Makefile5
-rw-r--r--graphics/drawpile/distinfo6
-rw-r--r--graphics/drawpile/files/patch-src_desktop_bundled_QtColorWidgets_color__wheel.cpp10
-rw-r--r--graphics/drawpile/files/patch-src_desktop_widgets_popupmessage.h10
4 files changed, 10 insertions, 21 deletions
diff --git a/graphics/drawpile/Makefile b/graphics/drawpile/Makefile
index 961821302829..d18e0e003103 100644
--- a/graphics/drawpile/Makefile
+++ b/graphics/drawpile/Makefile
@@ -2,8 +2,13 @@
PORTNAME= Drawpile
DISTVERSION= 2.1.17
+PORTREVISION= 1
CATEGORIES= graphics python
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= b46115160c5587aae9306e57d4223906e74ed512.patch:-p1 # patch adding #include <QPainterPath>
+PATCHFILES+= ed1a75deb113da2d1df91a28f557509c4897130e.patch:-p1 # fix compilation with libmicrohttpd 0.9.71
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= Collaborative drawing program
diff --git a/graphics/drawpile/distinfo b/graphics/drawpile/distinfo
index 213f1456b393..3c51d9f97ed4 100644
--- a/graphics/drawpile/distinfo
+++ b/graphics/drawpile/distinfo
@@ -1,3 +1,7 @@
-TIMESTAMP = 1581960642
+TIMESTAMP = 1601753384
SHA256 (drawpile-Drawpile-2.1.17_GH0.tar.gz) = 67e569856ca5031dadd349f17e5185e93d42020f560016540fc32b5b52653a2f
SIZE (drawpile-Drawpile-2.1.17_GH0.tar.gz) = 2521569
+SHA256 (b46115160c5587aae9306e57d4223906e74ed512.patch) = 7fdd509c62f2d0754aa0b89821d77384a4f49a3f74ef606dccd2b3cd5c01a593
+SIZE (b46115160c5587aae9306e57d4223906e74ed512.patch) = 1119
+SHA256 (ed1a75deb113da2d1df91a28f557509c4897130e.patch) = 3748bcd763757ba098087af1bfc9715daabe4246486146d208b509e2a9b6292d
+SIZE (ed1a75deb113da2d1df91a28f557509c4897130e.patch) = 3770
diff --git a/graphics/drawpile/files/patch-src_desktop_bundled_QtColorWidgets_color__wheel.cpp b/graphics/drawpile/files/patch-src_desktop_bundled_QtColorWidgets_color__wheel.cpp
deleted file mode 100644
index 862e4e792e0b..000000000000
--- a/graphics/drawpile/files/patch-src_desktop_bundled_QtColorWidgets_color__wheel.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/desktop/bundled/QtColorWidgets/color_wheel.cpp.orig 2020-05-29 16:35:46 UTC
-+++ src/desktop/bundled/QtColorWidgets/color_wheel.cpp
-@@ -25,6 +25,7 @@
- #include <QtMath>
- #include <QMouseEvent>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QLineF>
- #include <QDragEnterEvent>
- #include <QMimeData>
diff --git a/graphics/drawpile/files/patch-src_desktop_widgets_popupmessage.h b/graphics/drawpile/files/patch-src_desktop_widgets_popupmessage.h
deleted file mode 100644
index 923fa0d1e4f8..000000000000
--- a/graphics/drawpile/files/patch-src_desktop_widgets_popupmessage.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/desktop/widgets/popupmessage.h.orig 2020-05-29 16:32:32 UTC
-+++ src/desktop/widgets/popupmessage.h
-@@ -20,6 +20,7 @@
- #define POPUPMESSAGE_H
-
- #include <QWidget>
-+#include <QPainterPath>
-
- class QTextDocument;
- class QTimer;