aboutsummaryrefslogtreecommitdiff
path: root/graphics/drawpile
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2018-04-02 20:12:15 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2018-04-02 20:12:15 +0000
commitcf7175bd8a2e54ae66ba9f4bbacf49b2ef7723d0 (patch)
tree5cd812b75e67520b92ea54f05a79eeeb6583ef03 /graphics/drawpile
parentf8906302f6abe559b4e461af237d6aefa4407457 (diff)
downloadports-cf7175bd8a2e54ae66ba9f4bbacf49b2ef7723d0.tar.gz
ports-cf7175bd8a2e54ae66ba9f4bbacf49b2ef7723d0.zip
Fix graphics/Drawfile ahead of CMake 3.11.
The order in which files are placed in mocs_compilation.cpp has changed in CMake 3.11 compared to CMake 3.10. This shows up places where not all of the includes needed for a bit of code, are included -- because by chance, everywhere else they are already included by the time the compiler gets to the offending header. In switching the order around, compiles fail. The error message is in the patch -- just a missing type declaration. Approved by: tcberner (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D14770
Notes
Notes: svn path=/head/; revision=466260
Diffstat (limited to 'graphics/drawpile')
-rw-r--r--graphics/drawpile/Makefile1
-rw-r--r--graphics/drawpile/files/patch-src_desktop_widgets_userlistwidget.h13
2 files changed, 14 insertions, 0 deletions
diff --git a/graphics/drawpile/Makefile b/graphics/drawpile/Makefile
index 74d3bd098313..b0b2688a868f 100644
--- a/graphics/drawpile/Makefile
+++ b/graphics/drawpile/Makefile
@@ -2,6 +2,7 @@
PORTNAME= Drawpile
DISTVERSION= 2.0.10
+PORTREVISION= 1
CATEGORIES= graphics python
MAINTAINER= yuri@FreeBSD.org
diff --git a/graphics/drawpile/files/patch-src_desktop_widgets_userlistwidget.h b/graphics/drawpile/files/patch-src_desktop_widgets_userlistwidget.h
new file mode 100644
index 000000000000..212b6758462d
--- /dev/null
+++ b/graphics/drawpile/files/patch-src_desktop_widgets_userlistwidget.h
@@ -0,0 +1,13 @@
+Missing include:
+ userlistwidget.h:64:30: error: unknown type name 'QItemSelection'
+
+--- src/desktop/widgets/userlistwidget.h.orig 2018-03-17 15:25:30 UTC
++++ src/desktop/widgets/userlistwidget.h
+@@ -23,6 +23,7 @@
+
+ #include <QWidget>
+ #include <QItemDelegate>
++#include <QItemSelection>
+
+ class Ui_UserBox;
+