aboutsummaryrefslogtreecommitdiff
path: root/graphics/drm-fbsd11.2-kmod
diff options
context:
space:
mode:
authorJohannes M Dieterich <jmd@FreeBSD.org>2018-12-10 03:02:11 +0000
committerJohannes M Dieterich <jmd@FreeBSD.org>2018-12-10 03:02:11 +0000
commitbfbf8bd33e4704a04b7042db079708a29a9c4cc9 (patch)
tree6318246feb61bce8e42ec341702cb84b50c16bea /graphics/drm-fbsd11.2-kmod
parentac9db327ac4b091633425f6e0a2cbd750bf7119e (diff)
downloadports-bfbf8bd33e4704a04b7042db079708a29a9c4cc9.tar.gz
ports-bfbf8bd33e4704a04b7042db079708a29a9c4cc9.zip
LinuxKPI-based DRM ports: move to new ports nomenclature.
After some discussions within the x11 team, it was decided to move to a new nomenclature for the LinuxKPI-based DRM ports that correctly reflects the FreeBSD version the ports are for. This will also allow us to move to dedicated branches per FreeBSD release and eases porting work. Functionally, this commit is a no-op as we are not moving to new snapshots. Reflect the move in UPDATING and MOVED. Users using the graphics/drm-kmod meta port should not be affected. Direct consumers of the DRM ports shall move, as in MOVED, as follows: drm-stable-kmod is drm-fbsd11.2-kmod drm-next-kmod is drm-fbsd12.0-kmod drm-devel-kmod is drm-current-kmod Reviewed by: zeising (x11) Approved by: zeising (x11) Differential Revision: https://reviews.freebsd.org/D18328
Notes
Notes: svn path=/head/; revision=487117
Diffstat (limited to 'graphics/drm-fbsd11.2-kmod')
-rw-r--r--graphics/drm-fbsd11.2-kmod/Makefile40
-rw-r--r--graphics/drm-fbsd11.2-kmod/distinfo3
-rw-r--r--graphics/drm-fbsd11.2-kmod/pkg-descr5
-rw-r--r--graphics/drm-fbsd11.2-kmod/pkg-message15
-rw-r--r--graphics/drm-fbsd11.2-kmod/pkg-plist7
5 files changed, 70 insertions, 0 deletions
diff --git a/graphics/drm-fbsd11.2-kmod/Makefile b/graphics/drm-fbsd11.2-kmod/Makefile
new file mode 100644
index 000000000000..c8ea76b1de23
--- /dev/null
+++ b/graphics/drm-fbsd11.2-kmod/Makefile
@@ -0,0 +1,40 @@
+# Created by: Johannes Dieterich <jmd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= drm-fbsd11.2-kmod
+PORTVERSION= g20180822
+PORTREVISION= 1
+CATEGORIES= graphics
+
+MAINTAINER= jmd@FreeBSD.org
+COMMENT= DRM modules for the linuxkpi-based KMS components
+
+LICENSE= BSD2CLAUSE MIT GPLv2
+LICENSE_COMB= multi
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= the new KMS components are only supported on amd64
+
+RUN_DEPENDS= gpu-firmware-kmod>=g20180319:graphics/gpu-firmware-kmod
+
+CONFLICTS_INSTALL= drm-fbsd12.0-kmod drm-current-kmod drm-legacy-kmod
+
+OPTIONS_DEFINE= DEBUG
+
+USES= kmod uidfix
+
+USE_GITHUB= yes
+GH_ACCOUNT= FreeBSDDesktop
+GH_PROJECT= kms-drm
+GH_TAGNAME= ef4d156
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200045
+IGNORE= not supported on older CURRENT, no kernel support
+.endif
+.if ${OPSYS} != FreeBSD
+IGNORE= not supported on anything but FreeBSD (missing linuxkpi functionality)
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/drm-fbsd11.2-kmod/distinfo b/graphics/drm-fbsd11.2-kmod/distinfo
new file mode 100644
index 000000000000..41f0ac178785
--- /dev/null
+++ b/graphics/drm-fbsd11.2-kmod/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1534993813
+SHA256 (FreeBSDDesktop-kms-drm-g20180822-ef4d156_GH0.tar.gz) = c20bfb2554dc39839f72018f6c15fc4b371233039209132312017141af81dec6
+SIZE (FreeBSDDesktop-kms-drm-g20180822-ef4d156_GH0.tar.gz) = 6678309
diff --git a/graphics/drm-fbsd11.2-kmod/pkg-descr b/graphics/drm-fbsd11.2-kmod/pkg-descr
new file mode 100644
index 000000000000..a0debdffcbb3
--- /dev/null
+++ b/graphics/drm-fbsd11.2-kmod/pkg-descr
@@ -0,0 +1,5 @@
+amdgpu, i915, and radeon DRM modules for the linuxkpi-based KMS components.
+Currently corresponding to Linux 4.9 DRM. More stable state. amdgpu and
+radeonkms are known to fail with EFI boot.
+
+WWW: https://github.com/FreeBSDDesktop/kms-drm
diff --git a/graphics/drm-fbsd11.2-kmod/pkg-message b/graphics/drm-fbsd11.2-kmod/pkg-message
new file mode 100644
index 000000000000..f406d554fe2d
--- /dev/null
+++ b/graphics/drm-fbsd11.2-kmod/pkg-message
@@ -0,0 +1,15 @@
+The drm-stable-kmod port can be enabled for amdgpu (for AMD GPUs starting with
+the HD7000 series / Tahiti) or i915kms (for Intel APUs starting with HD3000 /
+Sandy Bridge) through kld_list in /etc/rc.conf. radeonkms for older AMD GPUs
+can be loaded and there are some positive reports if EFI boot is NOT enabled
+(similar to amdgpu).
+
+For amdgpu: kld_list="amdgpu"
+For Intel: kld_list="/boot/modules/i915kms.ko"
+For radeonkms: kld_list="/boot/modules/radeonkms.ko"
+
+Please ensure that all users requiring graphics are members of the
+"video" group.
+
+Older generations are supported by the legacy kms modules (radeonkms /
+i915kms) in base or by installing graphics/drm-legacy-kmod.
diff --git a/graphics/drm-fbsd11.2-kmod/pkg-plist b/graphics/drm-fbsd11.2-kmod/pkg-plist
new file mode 100644
index 000000000000..8930f98d203a
--- /dev/null
+++ b/graphics/drm-fbsd11.2-kmod/pkg-plist
@@ -0,0 +1,7 @@
+/%%KMODDIR%%/amdgpu.ko
+/%%KMODDIR%%/amdkfd.ko
+/%%KMODDIR%%/debugfs.ko
+/%%KMODDIR%%/drm.ko
+/%%KMODDIR%%/i915kms.ko
+/%%KMODDIR%%/linuxkpi_gplv2.ko
+/%%KMODDIR%%/radeonkms.ko