aboutsummaryrefslogtreecommitdiff
path: root/graphics/duhdraw
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-01-31 08:33:44 +0000
committerJohn Marino <marino@FreeBSD.org>2016-01-31 08:33:44 +0000
commitcab639f13ac6e24a8c916075b6654728e6094cf9 (patch)
treeb4c479cce00618fec2a81a5c776fb80eefff8fcb /graphics/duhdraw
parentc66d842480231d6fe46b33abbc688a1f6f289ac2 (diff)
downloadports-cab639f13ac6e24a8c916075b6654728e6094cf9.tar.gz
ports-cab639f13ac6e24a8c916075b6654728e6094cf9.zip
graphics/duhdraw: USES+= ncurses and respect LDFLAGS
Notes
Notes: svn path=/head/; revision=407587
Diffstat (limited to 'graphics/duhdraw')
-rw-r--r--graphics/duhdraw/Makefile2
-rw-r--r--graphics/duhdraw/files/patch-Makefile16
2 files changed, 18 insertions, 0 deletions
diff --git a/graphics/duhdraw/Makefile b/graphics/duhdraw/Makefile
index ef0e25306cbd..499bb0ba001e 100644
--- a/graphics/duhdraw/Makefile
+++ b/graphics/duhdraw/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= http://www.cs.helsinki.fi/u/penberg/duhdraw/
MAINTAINER= ports@FreeBSD.org
COMMENT= ANSI graphic drawing program
+USES= ncurses
+
MAKE_ARGS= CC="${CC} ${CFLAGS}"
PLIST_FILES= bin/ansi bin/ansitoc bin/duhdraw
diff --git a/graphics/duhdraw/files/patch-Makefile b/graphics/duhdraw/files/patch-Makefile
new file mode 100644
index 000000000000..dbe3159002e7
--- /dev/null
+++ b/graphics/duhdraw/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile.orig 2005-03-02 08:22:46 UTC
++++ Makefile
+@@ -11,11 +11,11 @@ LIBS=-lncurses
+ all: duhdraw ansitoc ansi
+
+ ansi: cleanansi
+- $(CC) -o ansi ansi.c ansi-esc.c $(LIBS)
++ $(CC) -o ansi ansi.c ansi-esc.c $(LDFLAGS) $(LIBS)
+ $(STRIP) ansi
+
+ duhdraw: cleandd
+- $(CC) -o duhdraw duhdraw.c ansi-esc.c $(LIBS)
++ $(CC) -o duhdraw duhdraw.c ansi-esc.c $(LDFLAGS) $(LIBS)
+ $(STRIP) duhdraw
+
+ ansitoc: cleanansitoc