aboutsummaryrefslogtreecommitdiff
path: root/graphics/ebsynth
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 08:57:34 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 08:57:34 +0000
commit07d0c5c3ce3553789c7852ca374481165838c4ce (patch)
tree668d3c04ddd798d7e384f1dd7af830111a2ff245 /graphics/ebsynth
parent8f313982c46347978e09ab3b5df4d230b8ea467f (diff)
downloadports-07d0c5c3ce3553789c7852ca374481165838c4ce.tar.gz
ports-07d0c5c3ce3553789c7852ca374481165838c4ce.zip
graphics/ebsynth: fix build on powerpc
LLVM on powerpc doesn't have libomp: src/ebsynth_cpu.cpp:15:12: fatal error: 'omp.h' file not found
Diffstat (limited to 'graphics/ebsynth')
-rw-r--r--graphics/ebsynth/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/graphics/ebsynth/Makefile b/graphics/ebsynth/Makefile
index 235246c62b51..724761c24d20 100644
--- a/graphics/ebsynth/Makefile
+++ b/graphics/ebsynth/Makefile
@@ -8,13 +8,20 @@ COMMENT= Example-based Image Synthesis and Style Transfer
LICENSE= PD
-USES= compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= jamriska
GH_TAGNAME= 2f5c97c0c21a
PLIST_FILES= bin/ebsynth
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES= compiler:gcc-c++11-lib
+.else
+USES= compiler:c++11-lang
+.endif
+
do-build:
@(cd ${BUILD_WRKSRC} && ${CXX} src/ebsynth.cpp \
src/ebsynth_cpu.cpp src/ebsynth_nocuda.cpp \