aboutsummaryrefslogtreecommitdiff
path: root/graphics/ebsynth
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2019-10-11 09:52:47 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2019-10-11 09:52:47 +0000
commit5719091be576742dd4c59493cf49883d41b3f7ce (patch)
treefd5df9dc68999721158b8e93850af056dddac0d7 /graphics/ebsynth
parent55864ffa7ef8934cfe375926a65966aa88954065 (diff)
downloadports-5719091be576742dd4c59493cf49883d41b3f7ce.tar.gz
ports-5719091be576742dd4c59493cf49883d41b3f7ce.zip
New port graphics/ebsynth
ebsynth is a tool for by-example synthesis of images. PR: 240632 Submitted by: Shane <FreeBSD@ShaneWare.Biz>
Notes
Notes: svn path=/head/; revision=514272
Diffstat (limited to 'graphics/ebsynth')
-rw-r--r--graphics/ebsynth/Makefile30
-rw-r--r--graphics/ebsynth/distinfo3
-rw-r--r--graphics/ebsynth/pkg-descr6
3 files changed, 39 insertions, 0 deletions
diff --git a/graphics/ebsynth/Makefile b/graphics/ebsynth/Makefile
new file mode 100644
index 000000000000..708b4594ca4b
--- /dev/null
+++ b/graphics/ebsynth/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= ebsynth
+PORTVERSION= 0.0.0.20190510
+CATEGORIES= graphics
+
+MAINTAINER= FreeBSD@ShaneWare.biz
+COMMENT= Example-based Image Synthesis and Style Transfer
+
+LICENSE= PD
+
+LIB_DEPENDS= libomp.so:devel/openmp
+
+USES= localbase
+USE_GITHUB= yes
+GH_ACCOUNT= jamriska
+GH_TAGNAME= 2f5c97c0c21a
+
+PLIST_FILES= bin/ebsynth
+
+do-build:
+ @(cd ${BUILD_WRKSRC} && ${CXX} src/ebsynth.cpp \
+ src/ebsynth_cpu.cpp src/ebsynth_nocuda.cpp \
+ -DNDEBUG -O3 -fopenmp -Iinclude -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib -std=c++11 -o ebsynth)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ebsynth ${STAGEDIR}${LOCALBASE}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/ebsynth/distinfo b/graphics/ebsynth/distinfo
new file mode 100644
index 000000000000..cc3a270ef990
--- /dev/null
+++ b/graphics/ebsynth/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568869871
+SHA256 (jamriska-ebsynth-0.0.0.20190510-2f5c97c0c21a_GH0.tar.gz) = 87c375141cfd00b5ea27a32762764496b821c394c540a2fd2a7af60e9e5efcd5
+SIZE (jamriska-ebsynth-0.0.0.20190510-2f5c97c0c21a_GH0.tar.gz) = 12569648
diff --git a/graphics/ebsynth/pkg-descr b/graphics/ebsynth/pkg-descr
new file mode 100644
index 000000000000..9758b26e5eb1
--- /dev/null
+++ b/graphics/ebsynth/pkg-descr
@@ -0,0 +1,6 @@
+ebsynth is a tool for by-example synthesis of images. It can be used
+for a variety of image synthesis tasks, including guided texture
+synthesis, artistic style transfer, content-aware inpainting and
+super-resolution.
+
+WWW: https://ebsynth.com