aboutsummaryrefslogtreecommitdiff
path: root/graphics/egl-wayland
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-02-13 04:12:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-02-13 04:12:32 +0000
commit87762c1bbcb6f965ce3f7001dd16cd37dbce7752 (patch)
tree5d3ebf5d8a2d143f1b704c0ad7c328576d11bb46 /graphics/egl-wayland
parentee9d838b4122f8c568c836ec1207624bc1d24d52 (diff)
downloadports-87762c1bbcb6f965ce3f7001dd16cd37dbce7752.tar.gz
ports-87762c1bbcb6f965ce3f7001dd16cd37dbce7752.zip
x11-servers/xwayland-devel: expose x11/nvidia-driver support
Disabled for now as runtime wasn't tested. EGLStreams is supported by x11-wm/mutter and x11-wm/plasma5-kwin.
Notes
Notes: svn path=/head/; revision=526006
Diffstat (limited to 'graphics/egl-wayland')
-rw-r--r--graphics/egl-wayland/Makefile30
-rw-r--r--graphics/egl-wayland/distinfo3
-rw-r--r--graphics/egl-wayland/files/10_nvidia_wayland.json6
-rw-r--r--graphics/egl-wayland/pkg-descr8
-rw-r--r--graphics/egl-wayland/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/graphics/egl-wayland/Makefile b/graphics/egl-wayland/Makefile
new file mode 100644
index 000000000000..1a7268909ec7
--- /dev/null
+++ b/graphics/egl-wayland/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= egl-wayland
+DISTVERSION= 1.1.4
+CATEGORIES= graphics
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= EGLStream-based Wayland external platform
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= eglexternalplatform>=1.1:graphics/eglexternalplatform
+LIB_DEPENDS= libwayland-server.so:graphics/wayland
+
+USES= gl meson pkgconfig
+USE_GITHUB= yes
+USE_GL= egl
+GH_ACCOUNT= NVIDIA
+
+post-patch:
+ @${REINPLACE_CMD} -e "/install/s/datadir')/prefix'), 'libdata'/" \
+ ${WRKSRC}/meson.build
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/egl/egl_external_platform.d
+ ${INSTALL_DATA} ${FILESDIR}/10_nvidia_wayland.json \
+ ${STAGEDIR}${PREFIX}/share/egl/egl_external_platform.d
+
+.include <bsd.port.mk>
diff --git a/graphics/egl-wayland/distinfo b/graphics/egl-wayland/distinfo
new file mode 100644
index 000000000000..a670b0985369
--- /dev/null
+++ b/graphics/egl-wayland/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1570655351
+SHA256 (NVIDIA-egl-wayland-1.1.4_GH0.tar.gz) = b3cfb99803a0324478f0824e35521a42ade118e7c11aa9a6829a2dc82ca2453c
+SIZE (NVIDIA-egl-wayland-1.1.4_GH0.tar.gz) = 48479
diff --git a/graphics/egl-wayland/files/10_nvidia_wayland.json b/graphics/egl-wayland/files/10_nvidia_wayland.json
new file mode 100644
index 000000000000..c08a64112af8
--- /dev/null
+++ b/graphics/egl-wayland/files/10_nvidia_wayland.json
@@ -0,0 +1,6 @@
+{
+ "file_format_version" : "1.0.0",
+ "ICD" : {
+ "library_path" : "libnvidia-egl-wayland.so.1"
+ }
+}
diff --git a/graphics/egl-wayland/pkg-descr b/graphics/egl-wayland/pkg-descr
new file mode 100644
index 000000000000..9b5d11c3ae63
--- /dev/null
+++ b/graphics/egl-wayland/pkg-descr
@@ -0,0 +1,8 @@
+This is a work-in-progress implementation of a EGL External Platform
+library to add client-side Wayland support to EGL on top of EGLDevice
+and EGLStream families of extensions.
+
+This library implements an EGL External Platform interface to work
+along with EGL drivers that support the external platform mechanism.
+
+WWW: https://github.com/NVIDIA/egl-wayland
diff --git a/graphics/egl-wayland/pkg-plist b/graphics/egl-wayland/pkg-plist
new file mode 100644
index 000000000000..47e16e111b56
--- /dev/null
+++ b/graphics/egl-wayland/pkg-plist
@@ -0,0 +1,8 @@
+lib/libnvidia-egl-wayland.so
+lib/libnvidia-egl-wayland.so.1
+lib/libnvidia-egl-wayland.so.1.1.4
+libdata/pkgconfig/wayland-eglstream-protocols.pc
+libdata/pkgconfig/wayland-eglstream.pc
+share/egl/egl_external_platform.d/10_nvidia_wayland.json
+share/wayland-eglstream/wayland-eglstream-controller.xml
+share/wayland-eglstream/wayland-eglstream.xml