aboutsummaryrefslogtreecommitdiff
path: root/graphics/embree
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-06-01 14:16:13 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-06-01 14:16:13 +0000
commit8dac5cecaa0aad9c8621c43892e987cea60ec027 (patch)
treeacd01659c31e63436053dec40e5cee244e11fe6e /graphics/embree
parent649d5fceacd71c9f18b870d95dd4ce4083581ce0 (diff)
downloadports-8dac5cecaa0aad9c8621c43892e987cea60ec027.tar.gz
ports-8dac5cecaa0aad9c8621c43892e987cea60ec027.zip
Fix installed header by replacing vendor-specific (mainly MSVC) keyword
`__forceinline' with `inline __attribute__((always_inline))', which is how upstream originally defines it in order to be understood by both Clang and GCC, and don't force CHOSEN_COMPILER_TYPE as it is not needed anymore. Bump port revision.
Notes
Notes: svn path=/head/; revision=416244
Diffstat (limited to 'graphics/embree')
-rw-r--r--graphics/embree/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/embree/Makefile b/graphics/embree/Makefile
index 1b99c6324dbe..6409366d3575 100644
--- a/graphics/embree/Makefile
+++ b/graphics/embree/Makefile
@@ -4,6 +4,7 @@
PORTNAME= embree
DISTVERSIONPREFIX= v
DISTVERSION= 2.10.0
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= danfe@FreeBSD.org
@@ -24,8 +25,7 @@ USE_XORG= xmu
USE_LDCONFIG= yes
CMAKE_ARGS= -DRTCORE_TASKING_SYSTEM:STRING=INTERNAL \
- -DENABLE_ISPC_SUPPORT:BOOL=OFF \
- -DCOMPILER:STRING=${CHOSEN_COMPILER_TYPE:tu}
+ -DENABLE_ISPC_SUPPORT:BOOL=OFF
CXXFLAGS+= -msse2 # required on i386
@@ -57,5 +57,7 @@ post-patch:
@${REINPLACE_CMD} -e '/encodeRGB8_to_JPEG/s,size_t \*,unsigned \
long *,' ${WRKSRC}/tutorials/common/image/image.h \
${WRKSRC}/tutorials/common/image/jpeg.cpp
+ @${REINPLACE_CMD} -e 's,__forceinline,inline __attribute__((always_inline)),' \
+ ${WRKSRC}/include/embree2/rtcore_ray.h
.include <bsd.port.mk>