aboutsummaryrefslogtreecommitdiff
path: root/graphics/eog-plugins
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
commitaad09bc5e23eb75a7a865a8b0002fbc6e13d4659 (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /graphics/eog-plugins
parent5c818b158c5b9479669f8322b4da8c48f5c30ef9 (diff)
downloadports-aad09bc5e23eb75a7a865a8b0002fbc6e13d4659.tar.gz
ports-aad09bc5e23eb75a7a865a8b0002fbc6e13d4659.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Notes
Notes: svn path=/head/; revision=351936
Diffstat (limited to 'graphics/eog-plugins')
-rw-r--r--graphics/eog-plugins/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/eog-plugins/Makefile b/graphics/eog-plugins/Makefile
index 38c55aec5876..629c76772321 100644
--- a/graphics/eog-plugins/Makefile
+++ b/graphics/eog-plugins/Makefile
@@ -4,7 +4,7 @@
PORTNAME= eog-plugins
PORTVERSION= 2.30.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,9 +16,9 @@ BUILD_DEPENDS= eog:${PORTSDIR}/graphics/eog
LIB_DEPENDS= libgdata.so:${PORTSDIR}/devel/libgdata
RUN_DEPENDS= eog:${PORTSDIR}/graphics/eog
+USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_GL= gl
USE_GNOME= gnomeprefix intlhack gtk20
-USES= gettext pathfix libtool gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib