aboutsummaryrefslogtreecommitdiff
path: root/graphics/eos-movrec
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-09-21 06:13:38 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-09-21 06:13:38 +0000
commit83914147070c7228ba1dc1000b2d52f7ff982f90 (patch)
tree153cb02a6ae46e929fb74cef24b24c57d2e0e24b /graphics/eos-movrec
parent4529f159a6a10c09898eeb8c2dc4a554c4bc6ed2 (diff)
downloadports-83914147070c7228ba1dc1000b2d52f7ff982f90.tar.gz
ports-83914147070c7228ba1dc1000b2d52f7ff982f90.zip
- Update to 0.3.2_beta
- Change maintainer email gmx.ch --> FreeBSD.org - Use the new format for LIB_DEPENDS [1] - Add USE_DOS2UNIX - Change dependencies for QT4 - Use pkg-plist instead of PLIST_FILES and PLIST_DIRS - Change desktop entry and icons - Add patch, fix build at 10.x [1] PR: ports/182233 [1] Submitted by: bsam (me) [1] Final patch by: nemysis (maintainer)
Notes
Notes: svn path=/head/; revision=327791
Diffstat (limited to 'graphics/eos-movrec')
-rw-r--r--graphics/eos-movrec/Makefile43
-rw-r--r--graphics/eos-movrec/distinfo6
-rw-r--r--graphics/eos-movrec/files/patch-main.cpp10
3 files changed, 36 insertions, 23 deletions
diff --git a/graphics/eos-movrec/Makefile b/graphics/eos-movrec/Makefile
index 1cda1a13adac..58eff34df01e 100644
--- a/graphics/eos-movrec/Makefile
+++ b/graphics/eos-movrec/Makefile
@@ -2,39 +2,44 @@
# $FreeBSD$
PORTNAME= eos-movrec
-DISTVERSION= 0.3.1_beta
-PORTREVISION= 4
+DISTVERSION= 0.3.2_beta
CATEGORIES= graphics multimedia
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.3_beta/ \
- SF/nemysisfreebsdp/:icons
-DISTFILES= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX} \
- ${PORTNAME}.png:icons
-DIST_SUBDIR= ${PORTNAME}
-EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX}
-
-MAINTAINER= nemysis@gmx.ch
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}/
+
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Capture short movies with Canon DSLR camera
LICENSE= GPLv2
-LIB_DEPENDS= gphoto2:${PORTSDIR}/graphics/libgphoto2
+LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
USE_BZIP2= yes
USES= cmake pkgconfig
-USE_QT4= qmake_build moc_build rcc_build uic_build gui
+USE_DOS2UNIX= *.pro *.cpp *.h
+USE_QT4= corelib dbus declarative designer gui help iconengines imageformats \
+ moc_build multimedia network opengl phonon qmake_build qt3support \
+ rcc_build script scripttools sql qt3support uic_build webkit xml xmlpatterns
-PLIST_FILES= bin/eos_movrec \
- share/pixmaps/${PORTNAME}.png
+INSTALLS_ICONS= yes
+ICON_SIZES= 16x16 32x32 128x128 256x256 512x512
-DESKTOP_ENTRIES= "eos_movrec" "EOS Camera Movie Recorder" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
- "eos_movrec" "Graphics;Photography;Qt;" false
+DESKTOP_ENTRIES="EOS Camera Movie Recorder" "${COMMENT}" "${PORTNAME}" \
+ "eos_movrec" "Graphics;Photography;Qt;" false
NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's,GLIBC,${OPSYS},' ${WRKSRC}/os_api.h
+ @${REINPLACE_CMD} -e 's|GLIBC|${OPSYS}|' ${WRKSRC}/os_api.h
+.for s in 16 32 128 256 512
+ @cd ${WRKSRC}/mac.icons && \
+ ${MV} ${s}.png ${PORTNAME}_${s}x${s}.png
+.endfor
post-install:
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKSRC}/mac.icons/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/32x32/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps/
.include <bsd.port.mk>
diff --git a/graphics/eos-movrec/distinfo b/graphics/eos-movrec/distinfo
index af0ffab50bd6..5790a9288fba 100644
--- a/graphics/eos-movrec/distinfo
+++ b/graphics/eos-movrec/distinfo
@@ -1,4 +1,2 @@
-SHA256 (eos-movrec/eos-movrec-0.3.1_beta-src.tar.bz2) = 044cf8b6428d66d6d03c3df53103f985e5b669cad3c8f78a94f9ef308259deea
-SIZE (eos-movrec/eos-movrec-0.3.1_beta-src.tar.bz2) = 3955037
-SHA256 (eos-movrec/eos-movrec.png) = ad7bd2b870b2b63d4868f49c34b8ddf5e801f3c2e878bba455817b66b53ecd85
-SIZE (eos-movrec/eos-movrec.png) = 1085
+SHA256 (eos-movrec-0.3.2_beta.tar.bz2) = a793e1961a1e1a701932415d653040bb27500daea5f0e65bf4c06e47cd94fe0f
+SIZE (eos-movrec-0.3.2_beta.tar.bz2) = 3828236
diff --git a/graphics/eos-movrec/files/patch-main.cpp b/graphics/eos-movrec/files/patch-main.cpp
new file mode 100644
index 000000000000..fe6e7f95e4fa
--- /dev/null
+++ b/graphics/eos-movrec/files/patch-main.cpp
@@ -0,0 +1,10 @@
+--- main.cpp.orig 2013-09-19 22:25:36.000000000 +0400
++++ main.cpp 2013-09-19 22:26:10.000000000 +0400
+@@ -19,6 +19,7 @@
+ ***************************************************************************/
+
+ #include <qapplication.h>
++#include <clocale>
+ #include "mainwnd.h"
+
+ int main(int argc, char **argv)