aboutsummaryrefslogtreecommitdiff
path: root/graphics/eos-movrec
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-11-06 10:20:47 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-11-06 10:20:47 +0000
commit85aaa70bf0b44a2c73c54b9e0c4ff6c22c85c144 (patch)
tree72a6f431cdb7ce78ba1a83d11ecf4787c07c2b24 /graphics/eos-movrec
parentba5714cb8edf410c8b1578a4ae595fe83db83eb3 (diff)
downloadports-85aaa70bf0b44a2c73c54b9e0c4ff6c22c85c144.tar.gz
ports-85aaa70bf0b44a2c73c54b9e0c4ff6c22c85c144.zip
- Download pregenerated icon file and drop dependency on `graphics/netpbm'
- Reorder Makefile header to more common form - Drop DISTVERSIONSUFFIX altogether: it does not make sense now since we have to assign DISTFILES manually - Remove redundant assignment of WRKSRC - In DESKTOP_ENTRIES, do not rely on the fact that ${FALSE} will always be "false" as required by fd.o spec; literal value should be used instead PR: ports/173386 Submitted by: maintainer Feature safe: yes
Notes
Notes: svn path=/head/; revision=307058
Diffstat (limited to 'graphics/eos-movrec')
-rw-r--r--graphics/eos-movrec/Makefile23
-rw-r--r--graphics/eos-movrec/distinfo6
2 files changed, 14 insertions, 15 deletions
diff --git a/graphics/eos-movrec/Makefile b/graphics/eos-movrec/Makefile
index fdcc31c615c2..d3332e513d89 100644
--- a/graphics/eos-movrec/Makefile
+++ b/graphics/eos-movrec/Makefile
@@ -1,11 +1,16 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= eos-movrec
DISTVERSION= 0.3.1_beta
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics multimedia
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.3_beta/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/0.3_beta/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX}
MAINTAINER= nemysis@gmx.ch
COMMENT= Capture short movies with Canon DSLR camera
@@ -13,29 +18,21 @@ COMMENT= Capture short movies with Canon DSLR camera
LICENSE= GPLv2
LIB_DEPENDS= gphoto2:${PORTSDIR}/graphics/libgphoto2
-BUILD_DEPENDS= pnmtopng:${PORTSDIR}/graphics/netpbm
USE_BZIP2= yes
USE_CMAKE= yes
USE_QT4= qmake_build moc_build rcc_build uic_build gui
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-DISTVERSIONSUFFIX= -src
-
PLIST_FILES= bin/eos_movrec \
share/pixmaps/${PORTNAME}.png
DESKTOP_ENTRIES= "EOS Camera Movie Record" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME:S/-/_/}" "Application;Graphics;" ${FALSE}
+ "${PORTNAME:S/-/_/}" "Application;Graphics;" false
post-patch:
@${REINPLACE_CMD} -e 's,GLIBC,${OPSYS},' ${WRKSRC}/os_api.h
-post-build:
- @(cd ${WRKSRC} && ${LOCALBASE}/bin/winicontoppm -bestqual eos-movrec2.ico | \
- ${LOCALBASE}/bin/pnmtopng > eos-movrec.png)
-
post-install:
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
.include <bsd.port.mk>
diff --git a/graphics/eos-movrec/distinfo b/graphics/eos-movrec/distinfo
index e5da54644ed2..af0ffab50bd6 100644
--- a/graphics/eos-movrec/distinfo
+++ b/graphics/eos-movrec/distinfo
@@ -1,2 +1,4 @@
-SHA256 (eos-movrec-0.3.1_beta-src.tar.bz2) = 044cf8b6428d66d6d03c3df53103f985e5b669cad3c8f78a94f9ef308259deea
-SIZE (eos-movrec-0.3.1_beta-src.tar.bz2) = 3955037
+SHA256 (eos-movrec/eos-movrec-0.3.1_beta-src.tar.bz2) = 044cf8b6428d66d6d03c3df53103f985e5b669cad3c8f78a94f9ef308259deea
+SIZE (eos-movrec/eos-movrec-0.3.1_beta-src.tar.bz2) = 3955037
+SHA256 (eos-movrec/eos-movrec.png) = ad7bd2b870b2b63d4868f49c34b8ddf5e801f3c2e878bba455817b66b53ecd85
+SIZE (eos-movrec/eos-movrec.png) = 1085