aboutsummaryrefslogtreecommitdiff
path: root/graphics/eos-movrec
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-02-25 17:49:37 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-02-25 17:49:37 +0000
commitf827f03fb1fe53e09dc211eed31c4f184a4b1262 (patch)
tree02508fbacc097c5fdfb78f6526c702b1159f19a4 /graphics/eos-movrec
parente8888f06e29e95203c4d4cdd28b641f7b8e0a048 (diff)
downloadports-f827f03fb1fe53e09dc211eed31c4f184a4b1262.tar.gz
ports-f827f03fb1fe53e09dc211eed31c4f184a4b1262.zip
- Backport upstream r141 (switch to Qt5) and resurrect
- Narrow down `dos2unix' fixup to one needed file only - Fix symlink which was pointing to an absolute path - Drop INSTALLS_ICONS knob (not applicable to Qt ports)
Notes
Notes: svn path=/head/; revision=527098
Diffstat (limited to 'graphics/eos-movrec')
-rw-r--r--graphics/eos-movrec/Makefile42
-rw-r--r--graphics/eos-movrec/distinfo2
-rw-r--r--graphics/eos-movrec/files/patch-CMakeLists.txt77
-rw-r--r--graphics/eos-movrec/files/patch-main.cpp10
-rw-r--r--graphics/eos-movrec/pkg-descr15
-rw-r--r--graphics/eos-movrec/pkg-plist7
6 files changed, 153 insertions, 0 deletions
diff --git a/graphics/eos-movrec/Makefile b/graphics/eos-movrec/Makefile
new file mode 100644
index 000000000000..2ec83244c170
--- /dev/null
+++ b/graphics/eos-movrec/Makefile
@@ -0,0 +1,42 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= eos-movrec
+DISTVERSION= 0.3.2_beta
+PORTREVISION= 6
+CATEGORIES= graphics multimedia
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Capture short movies with Canon DSLR camera
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libgphoto2.so:graphics/libgphoto2
+
+USES= cmake dos2unix pkgconfig qt:5 tar:bzip2
+DOS2UNIX_FILES= main.cpp
+USE_QT= buildtools_build qmake_build core gui widgets
+
+ICON_SIZES= 16x16 32x32 128x128 256x256 512x512
+
+DESKTOP_ENTRIES="EOS Camera Movie Recorder" "" "${PORTNAME}" \
+ "eos_movrec" "Graphics;Photography;Qt;" ""
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|GLIBC|${OPSYS}|' ${WRKSRC}/os_api.h
+.for s in 16 32 128 256 512
+ @cd ${WRKSRC}/mac.icons && \
+ ${MV} ${s}.png ${PORTNAME}_${s}x${s}.png
+.endfor
+
+post-install:
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
+ ${INSTALL_DATA} ${WRKSRC}/mac.icons/${PORTNAME}_${s}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ../icons/hicolor/32x32/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>
diff --git a/graphics/eos-movrec/distinfo b/graphics/eos-movrec/distinfo
new file mode 100644
index 000000000000..5790a9288fba
--- /dev/null
+++ b/graphics/eos-movrec/distinfo
@@ -0,0 +1,2 @@
+SHA256 (eos-movrec-0.3.2_beta.tar.bz2) = a793e1961a1e1a701932415d653040bb27500daea5f0e65bf4c06e47cd94fe0f
+SIZE (eos-movrec-0.3.2_beta.tar.bz2) = 3828236
diff --git a/graphics/eos-movrec/files/patch-CMakeLists.txt b/graphics/eos-movrec/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..8d0f63c1ed30
--- /dev/null
+++ b/graphics/eos-movrec/files/patch-CMakeLists.txt
@@ -0,0 +1,77 @@
+--- CMakeLists.txt.orig 2015-01-27 14:22:56 UTC
++++ CMakeLists.txt
+@@ -24,12 +24,14 @@ if(WIN32)
+ endif(MINGW)
+ endif(WIN32)
+
+-find_package(Qt4 4.4.2 COMPONENTS QtCore QtGui REQUIRED)
+-include(${QT_USE_FILE})
+
+-add_definitions (${QT_DEFINITIONS})
+-include_directories (${QT_INCLUDES} ${CMAKE_BINARY_DIR})
++# Find the Qt5 libraries
++find_package(Qt5Core REQUIRED)
++find_package(Qt5Gui REQUIRED)
++find_package(Qt5Widgets REQUIRED)
+
++include_directories(${CMAKE_BINARY_DIR})
++
+ set(EDSDK_LDFLAGS "")
+ if(WIN32)
+ set(EDSDKPATH "${CMAKE_SOURCE_DIR}/EDSDK")
+@@ -50,6 +52,13 @@ elseif(UNIX)
+ add_definitions(-DGPHOTO2=1)
+ endif(WIN32)
+
++# Find includes in corresponding current build & source directories
++set(CMAKE_INCLUDE_CURRENT_DIR ON)
++
++# Instruct CMake to run moc automatically when needed.
++set(CMAKE_AUTOMOC ON)
++set(CMAKE_AUTOUIC ON)
++
+ set(eos_movrec_SRCS
+ main.cpp
+ mainwnd.cpp
+@@ -73,12 +82,6 @@ if(WIN32)
+ set_property(SOURCE eos_movrec.rc PROPERTY OBJECT_DEPENDS ${CMAKE_SOURCE_DIR}/CMakeLists.txt)
+ endif(WIN32)
+
+-# headers with Q_OBJECT
+-set(eos_movrec_MOC_HEADERS
+- mainwnd.h
+- blinklabel.h
+-)
+-
+ # force use exceptions
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fexceptions")
+ # add debug defines
+@@ -86,12 +89,13 @@ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG}
+ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -DNDEBUG")
+
+ add_definitions(-D_FILE_OFFSET_BITS=64 -D_LARGE_FILES=1)
+-QT4_WRAP_CPP(MOC_SRCS ${eos_movrec_MOC_HEADERS})
+
+ if (WIN32)
+ set(CMAKE_RC_COMPILER windres)
+ # set rc syntax
+ set(CMAKE_RC_COMPILE_OBJECT "<CMAKE_RC_COMPILER> <FLAGS> <DEFINES> -O coff -o <OBJECT> <SOURCE>")
++ set(CMAKE_RC_SOURCE_FILE_EXTENSIONS rc)
++ set(CMAKE_RC_FLAGS "-I${CMAKE_BINARY_DIR}")
+
+ # enable resource language
+ enable_language(RC)
+@@ -102,10 +106,10 @@ if (WIN32)
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--enable-auto-import")
+ endif(WIN32)
+
+-add_executable(eos_movrec ${eos_movrec_SRCS} ${MOC_SRCS})
++add_executable(eos_movrec WIN32 ${eos_movrec_SRCS})
+ if (WIN32)
+- TARGET_LINK_LIBRARIES(eos_movrec ${QT_LIBRARIES} ${EDSDK_LDFLAGS})
++ TARGET_LINK_LIBRARIES(eos_movrec Qt5::Core Qt5::Gui Qt5::Widgets ${EDSDK_LDFLAGS})
+ elseif(UNIX)
+- TARGET_LINK_LIBRARIES(eos_movrec ${QT_LIBRARIES} ${LIBGPHOTO2_LDFLAGS})
++ TARGET_LINK_LIBRARIES(eos_movrec Qt5::Core Qt5::Gui Qt5::Widgets ${LIBGPHOTO2_LDFLAGS})
+ endif(WIN32)
+ install(TARGETS eos_movrec RUNTIME DESTINATION bin)
diff --git a/graphics/eos-movrec/files/patch-main.cpp b/graphics/eos-movrec/files/patch-main.cpp
new file mode 100644
index 000000000000..fe6e7f95e4fa
--- /dev/null
+++ b/graphics/eos-movrec/files/patch-main.cpp
@@ -0,0 +1,10 @@
+--- main.cpp.orig 2013-09-19 22:25:36.000000000 +0400
++++ main.cpp 2013-09-19 22:26:10.000000000 +0400
+@@ -19,6 +19,7 @@
+ ***************************************************************************/
+
+ #include <qapplication.h>
++#include <clocale>
+ #include "mainwnd.h"
+
+ int main(int argc, char **argv)
diff --git a/graphics/eos-movrec/pkg-descr b/graphics/eos-movrec/pkg-descr
new file mode 100644
index 000000000000..6f60eb1f7af1
--- /dev/null
+++ b/graphics/eos-movrec/pkg-descr
@@ -0,0 +1,15 @@
+This program writes short movies with your Canon DSLR camera directly to the
+computer. The camera must have Live View feature to work; supported models
+include Canon EOS 450D, Canon EOS 1000D, Canon 40D, Canon 50D, Canon 5D Mark
+II, Canon 1Ds Mark III. The program offers preview, Av, Tv, and WB control.
+While some newer models provide video recording natively, this program can
+be useful if your camera does not have this option.
+
+Video will be recorded using MJPEG codec, with no sound, roughly at 22 FPS
+(depends on your hardware: camera and computer). Image size is also camera
+dependent: 848x560 for 450D; 1024x680 for 40D, 50D, and top models; 768x512
+for 1000D. Resulting file is simply a collection of Live View frames stored
+sequentially without any compression in AVI container (expect file size to
+be quite large).
+
+WWW: https://sourceforge.net/projects/eos-movrec/
diff --git a/graphics/eos-movrec/pkg-plist b/graphics/eos-movrec/pkg-plist
new file mode 100644
index 000000000000..c5033ff47c19
--- /dev/null
+++ b/graphics/eos-movrec/pkg-plist
@@ -0,0 +1,7 @@
+bin/eos_movrec
+share/icons/hicolor/128x128/apps/eos-movrec.png
+share/icons/hicolor/16x16/apps/eos-movrec.png
+share/icons/hicolor/256x256/apps/eos-movrec.png
+share/icons/hicolor/32x32/apps/eos-movrec.png
+share/icons/hicolor/512x512/apps/eos-movrec.png
+share/pixmaps/eos-movrec.png