aboutsummaryrefslogtreecommitdiff
path: root/graphics/epix/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-07-02 07:55:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-07-02 07:55:27 +0000
commitf4fe78d3ea480221c7a65e60f2dd08944f826baa (patch)
tree78d5ab277888a0f948516767d35401770f2714d0 /graphics/epix/Makefile
parent0b9ab7e48a395affd2a4e088290ae6d7d53a7a30 (diff)
downloadports-f4fe78d3ea480221c7a65e60f2dd08944f826baa.tar.gz
ports-f4fe78d3ea480221c7a65e60f2dd08944f826baa.zip
Notes
Diffstat (limited to 'graphics/epix/Makefile')
-rw-r--r--graphics/epix/Makefile43
1 files changed, 33 insertions, 10 deletions
diff --git a/graphics/epix/Makefile b/graphics/epix/Makefile
index 809e8022342a..ae05c1b5f7ee 100644
--- a/graphics/epix/Makefile
+++ b/graphics/epix/Makefile
@@ -7,27 +7,50 @@
#
PORTNAME= epix
-PORTVERSION= 1.2.7
-PORTREVISION= 2
+PORTVERSION= 1.2.8
CATEGORIES= graphics
MASTER_SITES= http://mathcs.holycross.edu/~ahwang/epix/
MAINTAINER= ports@FreeBSD.org
COMMENT= Creates math plots and line figures using easy-to-learn syntax
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
- dvips:${PORTSDIR}/print/dvipsk-tetex \
- latex:${PORTSDIR}/print/teTeX
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
- latex:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS= dvips:${PORTSDIR}/print/dvipsk-tetex \
+ latex-pgf>=0:${PORTSDIR}/print/latex-pgf \
+ latex:${PORTSDIR}/print/teTeX-base \
+ bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
+ bash:${PORTSDIR}/shells/bash
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
USE_BZIP2= yes
USE_GMAKE= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--prefix="${PREFIX}" --mandir="${PREFIX}/man" \
- --infodir="${PREFIX}/info" --with-bash=${LOCALBASE}/bin/bash
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-bash=${LOCALBASE}/bin/bash \
+ --with-runtime=${CXX}
MAN1= elaps.1 epix.1 flix.1 laps.1
INFO= epix
+post-patch:
+ @${REINPLACE_CMD} -e '/^install-data-am:/s|install-data-local||' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^install-data-am:/s|install-docDATA||' \
+ ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e '/usepackage/s|pstricks,xcolor|pstricks,tikz,xcolor|' \
+ ${WRKSRC}/doc/manual.tex
+ @${REINPLACE_CMD} -e '/^install-data-am:/s|install-docDATA||' \
+ ${WRKSRC}/samples/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} install-data-local)
+ @(cd ${WRKSRC}/doc && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} install-docDATA)
+ @(cd ${WRKSRC}/samples && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} install-docDATA)
+.endif
+
.include <bsd.port.mk>