aboutsummaryrefslogtreecommitdiff
path: root/graphics/epix/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-05 19:55:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-05 19:55:49 +0000
commitffee13f318a7b2c169b31dfa0ff305ce0c4eb5ea (patch)
treec25e64c9c728c36a6d95d9d41ba8fbce1da303ef /graphics/epix/Makefile
parente4cd19415fd53d4ab734c3bf5658aeac08ce5bd5 (diff)
downloadports-ffee13f318a7b2c169b31dfa0ff305ce0c4eb5ea.tar.gz
ports-ffee13f318a7b2c169b31dfa0ff305ce0c4eb5ea.zip
Notes
Diffstat (limited to 'graphics/epix/Makefile')
-rw-r--r--graphics/epix/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/graphics/epix/Makefile b/graphics/epix/Makefile
index 237a797c0343..703766c5ecae 100644
--- a/graphics/epix/Makefile
+++ b/graphics/epix/Makefile
@@ -7,28 +7,27 @@
#
PORTNAME= epix
-PORTVERSION= 0.8.10a
+PORTVERSION= 1.0.0
CATEGORIES= graphics
-MASTER_SITES= http://mathcs.holycross.edu/~ahwang/software/
+MASTER_SITES= http://mathcs.holycross.edu/~ahwang/epix/
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
MAINTAINER= ports@FreeBSD.org
COMMENT= Creates math plots and line figures using easy-to-learn syntax
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
latex:${PORTSDIR}/print/teTeX
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
-
USE_BZIP2= yes
+USE_GCC= 3.4
USE_REINPLACE= yes
MAKE_ARGS= CXX="${CXX}" CFLAGS="${CXXFLAGS} -c" \
INSTALL_PROGRAM="${INSTALL_DATA}" \
INSTALL_BIN="${INSTALL_SCRIPT}"
-PLIST_SUB= VERSION="${PORTVERSION:S/a//}"
+PLIST_SUB= VERSION="${PORTVERSION}"
-MAN1= epix.1
+MAN1= epix.1
post-patch:
@${REINPLACE_CMD} -e \