aboutsummaryrefslogtreecommitdiff
path: root/graphics/epix
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-05 05:45:54 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-05 05:45:54 +0000
commit1605945e85f2854b5e2e01aed5a230f338fec4a3 (patch)
tree1ecb66dcb3414cc051ed53df4109f9c97a9b514e /graphics/epix
parentd2da0c1df4546501cc7c80dcc73344fa6d2984a5 (diff)
downloadports-1605945e85f2854b5e2e01aed5a230f338fec4a3.tar.gz
ports-1605945e85f2854b5e2e01aed5a230f338fec4a3.zip
add epix 0.8.6
Creates math plots and line figures using easy-to-learn syntax
Notes
Notes: svn path=/head/; revision=65662
Diffstat (limited to 'graphics/epix')
-rw-r--r--graphics/epix/Makefile28
-rw-r--r--graphics/epix/distinfo1
-rw-r--r--graphics/epix/files/patch-samples.sh11
-rw-r--r--graphics/epix/pkg-comment1
-rw-r--r--graphics/epix/pkg-descr9
-rw-r--r--graphics/epix/pkg-plist30
6 files changed, 80 insertions, 0 deletions
diff --git a/graphics/epix/Makefile b/graphics/epix/Makefile
new file mode 100644
index 000000000000..89d4e45fb616
--- /dev/null
+++ b/graphics/epix/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: epix
+# Date created: Sep 5, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= epix
+PORTVERSION= 0.8.6
+CATEGORIES= graphics
+MASTER_SITES= http://mathcs.holycross.edu/~ahwang/software/
+DISTNAME= epix_src
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ latex:${PORTSDIR}/print/teTeX
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= epix.1
+
+pre-build:
+ @(cd ${WRKSRC} ; ./newbash.sh)
+
+.include <bsd.port.mk>
diff --git a/graphics/epix/distinfo b/graphics/epix/distinfo
new file mode 100644
index 000000000000..34ff523fa2ee
--- /dev/null
+++ b/graphics/epix/distinfo
@@ -0,0 +1 @@
+MD5 (epix_src.tar.gz) = ae17eb131dc9ecb25c20e549ada63eff
diff --git a/graphics/epix/files/patch-samples.sh b/graphics/epix/files/patch-samples.sh
new file mode 100644
index 000000000000..d6addc3f481f
--- /dev/null
+++ b/graphics/epix/files/patch-samples.sh
@@ -0,0 +1,11 @@
+--- samples.sh.orig Thu Sep 5 13:21:15 2002
++++ samples.sh Thu Sep 5 13:21:26 2002
+@@ -55,7 +55,7 @@
+ mv $TARBALL $EPIX_ROOTDIR/$SAMPLEDIR/$TARBALL
+
+ cd $EPIX_ROOTDIR/$SAMPLEDIR && tar -xf $TARBALL
+- chown $USER.$USER * && chmod go+rX *
++ chown $USER:$GROUP * && chmod go+rX *
+ ;;
+
+ --uninstall)
diff --git a/graphics/epix/pkg-comment b/graphics/epix/pkg-comment
new file mode 100644
index 000000000000..806211a44a23
--- /dev/null
+++ b/graphics/epix/pkg-comment
@@ -0,0 +1 @@
+Creates math plots and line figures using easy-to-learn syntax
diff --git a/graphics/epix/pkg-descr b/graphics/epix/pkg-descr
new file mode 100644
index 000000000000..382c361b1952
--- /dev/null
+++ b/graphics/epix/pkg-descr
@@ -0,0 +1,9 @@
+ePiX is a LATEX pre-processor that creates mathematically accurate plots and
+line figures using easy-to-learn syntax. The user interface is superficially
+that of LATEX itself: You prepare a short input file and ``run ePiX'' on this
+file, which produces a text file that is included into a LATEX document.
+Because the output is plain text, the output can be edited manually if
+necessary. However, for most visual tweaking it is easier and safer to change
+the source and re-run ePiX.
+
+WWW: http://mathcs.holycross.edu/~ahwang/current/ePiX.html
diff --git a/graphics/epix/pkg-plist b/graphics/epix/pkg-plist
new file mode 100644
index 000000000000..7fbfbc5e839f
--- /dev/null
+++ b/graphics/epix/pkg-plist
@@ -0,0 +1,30 @@
+bin/epix
+bin/laps
+bin/elaps
+include/epix.h
+lib/libepix.a
+share/epix/calculus.c
+share/epix/clipplot.c
+share/epix/contour.c
+share/epix/demoivre.c
+share/epix/denom.c
+share/epix/epix_samples.tar
+share/epix/flow-plot.c
+share/epix/geomsum.c
+share/epix/golden_rect.c
+share/epix/koch.c
+share/epix/levelset.c
+share/epix/lissajous.c
+share/epix/makefigs
+share/epix/polar.c
+share/epix/sample.aux
+share/epix/sample.tex
+share/epix/slopefield.c
+share/epix/sphere.c
+share/epix/stereo-left.c
+share/epix/stereo-right.c
+share/epix/template
+share/epix/uppersum.c
+share/epix/weierstrass.c
+share/epix/wheel.c
+@dirrm share/epix