aboutsummaryrefslogtreecommitdiff
path: root/graphics/epix
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-16 23:38:13 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-16 23:38:13 +0000
commit9d3f1af935a76fd36b10eff4fc8f58343c4da1a4 (patch)
treeb1b0421063ad345f371cdf7ba7b202db568e77e2 /graphics/epix
parent10cc64275c0d8b225fb38f3adfdbf70b944c5c7d (diff)
downloadports-9d3f1af935a76fd36b10eff4fc8f58343c4da1a4.tar.gz
ports-9d3f1af935a76fd36b10eff4fc8f58343c4da1a4.zip
Update to 0.8.8a
PR: 47076 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=73291
Diffstat (limited to 'graphics/epix')
-rw-r--r--graphics/epix/Makefile13
-rw-r--r--graphics/epix/distinfo2
-rw-r--r--graphics/epix/files/patch-newbash.sh12
-rw-r--r--graphics/epix/pkg-plist48
4 files changed, 43 insertions, 32 deletions
diff --git a/graphics/epix/Makefile b/graphics/epix/Makefile
index f198ec4e62d1..476cdd9c42a0 100644
--- a/graphics/epix/Makefile
+++ b/graphics/epix/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= epix
-PORTVERSION= 0.8.7a
+PORTVERSION= 0.8.8a
CATEGORIES= graphics
MASTER_SITES= http://mathcs.holycross.edu/~ahwang/software/
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
@@ -19,10 +19,21 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
latex:${PORTSDIR}/print/teTeX
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+MAKE_ARGS= CXX="${CXX}" CFLAGS="${CXXFLAGS} -c" \
+ INSTALL_PROGRAM="${INSTALL_DATA}" \
+ INSTALL_BIN="${INSTALL_SCRIPT}"
PLIST_SUB= VERSION="${PORTVERSION}"
MAN1= epix.1
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/newbash.sh
+ @${REINPLACE_CMD} -e 's|COPYING ||g' ${WRKSRC}/helpfiles.sh
+
pre-build:
@(cd ${WRKSRC} ; ./newbash.sh)
diff --git a/graphics/epix/distinfo b/graphics/epix/distinfo
index 1788a6d06b62..9eca4c334c96 100644
--- a/graphics/epix/distinfo
+++ b/graphics/epix/distinfo
@@ -1 +1 @@
-MD5 (epix-0.8.7a_src.tar.gz) = 88399be865d38569d2fa3788058e07ed
+MD5 (epix-0.8.8a_src.tar.bz2) = 93583d819b53f1b4cc0f65276e888376
diff --git a/graphics/epix/files/patch-newbash.sh b/graphics/epix/files/patch-newbash.sh
index 9596522f20b4..52c58af2d04f 100644
--- a/graphics/epix/files/patch-newbash.sh
+++ b/graphics/epix/files/patch-newbash.sh
@@ -1,6 +1,6 @@
---- newbash.sh.orig Sun Oct 27 23:53:05 2002
-+++ newbash.sh Sun Oct 27 23:53:54 2002
-@@ -1,7 +1,7 @@
+--- newbash.sh.orig Tue Sep 3 01:50:01 2002
++++ newbash.sh Sat Jan 11 15:16:11 2003
+@@ -1,10 +1,10 @@
#!/bin/sh
#
for FILE in elaps laps make_header post-uninst.sh pre-install.sh prepix \
@@ -8,4 +8,8 @@
+ helpfiles.sh samples/makefigs Makefile
do
mv $FILE $FILE.orig
- sed 's+/bin/bash+/usr/local/bin/bash+g' $FILE.orig > $FILE
+- sed 's+/bin/bash+/usr/local/bin/bash+g' $FILE.orig > $FILE
++ sed 's+/bin/bash+%%LOCALBASE%%/bin/bash+g' $FILE.orig > $FILE
+ ## ^-----------------^
+ ## Replace the portion from + to + of the line above with the path to
+ ## bash on your system. Sample replacement line:
diff --git a/graphics/epix/pkg-plist b/graphics/epix/pkg-plist
index 05fc2701c5c9..c9b53b9496a8 100644
--- a/graphics/epix/pkg-plist
+++ b/graphics/epix/pkg-plist
@@ -1,30 +1,26 @@
+bin/elaps
bin/epix
bin/laps
-bin/elaps
include/epix.h
lib/libepix.a
-share/epix/epix-%%VERSION%%_samples.tar
-share/epix/calculus.c
-share/epix/clipplot.c
-share/epix/contour.c
-share/epix/demoivre.c
-share/epix/denom.c
-share/epix/flow-plot.c
-share/epix/geomsum.c
-share/epix/golden_rect.c
-share/epix/koch.c
-share/epix/levelset.c
-share/epix/lissajous.c
-share/epix/makefigs
-share/epix/polar.c
-share/epix/sample.aux
-share/epix/sample.tex
-share/epix/slopefield.c
-share/epix/sphere.c
-share/epix/stereo-left.c
-share/epix/stereo-right.c
-share/epix/template
-share/epix/uppersum.c
-share/epix/weierstrass.c
-share/epix/wheel.c
-@dirrm share/epix
+share/epix/config/bash_completions
+share/epix/config/epix.el
+share/epix/config/epix.spec
+share/epix/config/epix.texi
+share/epix/config/update_figs.sh
+share/epix/notes/BUGS
+share/epix/notes/CHANGELOG
+share/epix/notes/INSTALL
+share/epix/notes/POST-INSTALL
+share/epix/notes/README
+share/epix/notes/README-authors
+share/epix/notes/README-changes
+share/epix/notes/THANKS
+share/epix/notes/TODO
+share/epix/samples/epix-%%VERSION%%_samples.tar
+@dirrm share/epix/samples
+@dirrm share/epix/notes
+@dirrm share/epix/config
+@exec mkdir -p %D/share/epix/tutorial
+@exec rmdir %D/share/epix/tutorial 2>/dev/null || true
+@exec rmdir %D/share/epix 2>/dev/null || true