aboutsummaryrefslogtreecommitdiff
path: root/graphics/evince/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /graphics/evince/Makefile
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Notes
Diffstat (limited to 'graphics/evince/Makefile')
-rw-r--r--graphics/evince/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 596aeece77bc..cd85c2f72e26 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -3,12 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/graphics/evince/Makefile,v 1.11 2010/06/24 10:03:54 kwm Exp $
+# $MCom: ports/graphics/evince/Makefile,v 1.147 2010/09/28 07:27:12 kwm Exp $
#
PORTNAME= evince
-PORTVERSION= 2.30.3
-PORTREVISION= 2
+PORTVERSION= 2.32.0
CATEGORIES= graphics print gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,7 +16,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME 2 multi-format document viewer
BUILD_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
-LIB_DEPENDS= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk \
+LIB_DEPENDS= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk \
spectre.1:${PORTSDIR}/print/libspectre
RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
@@ -33,10 +32,13 @@ USE_GNOME= gnomehack intlhack gnomeprefix desktopfileutils \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-GCONF_SCHEMAS= evince.schemas \
+GLIB_SCHEMAS= org.gnome.Evince.gschema.xml
+GCONF_SCHEMAS= \
evince-thumbnailer.schemas \
evince-thumbnailer-ps.schemas
+PLIST_SUB+= VERSION=2.32
+
MAN1= evince.1
OPTIONS= DVI "Enable DVI viewer support" off \
@@ -120,6 +122,7 @@ PLIST_SUB+= COMICS="@comment "
post-patch:
@${REINPLACE_CMD} -e 's|execinfo.h|#|g' \
+ -e 's|" == "|" = "|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^DOC_MODULE_VERSION/d' \
${WRKSRC}/help/reference/libdocument/Makefile.in \
@@ -127,5 +130,7 @@ post-patch:
post-install:
@-update-desktop-database
+ @${INSTALL_DATA} ${WRKSRC}/data/org.gnome.Evince.gschema.xml \
+ ${PREFIX}/share/glib-2.0/schemas
.include <bsd.port.post.mk>