aboutsummaryrefslogtreecommitdiff
path: root/graphics/evolvotron
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-15 05:53:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-15 05:53:59 +0000
commit2e963a6160d81873db6f416e226bff027c875bbe (patch)
treeea862216352b7d3462449b7fa3069d70bbe4d2b7 /graphics/evolvotron
parentbc2f03647922722b381f7e442a9e86e51c1a4bcf (diff)
downloadports-2e963a6160d81873db6f416e226bff027c875bbe.tar.gz
ports-2e963a6160d81873db6f416e226bff027c875bbe.zip
graphics/evolvotron: Update 0.6.3 -> 0.7.1
Port changes: * Change to DISTVERSION * Update LICENSE, add LICENSE_FILE * Change to Qt5 * Add USES=compiler:c++11-lib and USE_CXXSTD=c++11 * Delete redundant static libraries * Remove MAKE_JOBS_UNSAFE - build doesn't seem to fail with -j8
Notes
Notes: svn path=/head/; revision=474662
Diffstat (limited to 'graphics/evolvotron')
-rw-r--r--graphics/evolvotron/Makefile24
-rw-r--r--graphics/evolvotron/distinfo5
-rw-r--r--graphics/evolvotron/files/patch-USAGE13
-rw-r--r--graphics/evolvotron/files/patch-libevolvotron__dialog_help.cpp15
-rw-r--r--graphics/evolvotron/pkg-plist2
5 files changed, 15 insertions, 44 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index 2ae019ea07f5..3cbd98f57124 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= evolvotron
-PORTVERSION= 0.6.3
-PORTREVISION= 9
+DISTVERSION= 0.7.1
CATEGORIES= graphics
MASTER_SITES= SF \
SF/nemysisfreebsdp/${CATEGORIES}/:icons
@@ -13,21 +12,21 @@ DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Generative software that evolves images/textures/patterns
-LICENSE= GPLv3+ # LICENSE file is GPLv2 though
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_powerpc64= fails to link: evolvotron.o: undefined reference to boost::program_options::options_description::options_description
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-USES= python qmake qt:4
-USE_QT= corelib gui xml moc_build
+USES= compiler:c++11-lib python qmake qt:5
+USE_QT= core gui widgets xml buildtools_build
+USE_GL= gl
QMAKE_ARGS= VERSION_NUMBER="${PORTVERSION}"
QMAKE_SOURCE_PATH= ${WRKSRC}/main.pro
-MAKE_JOBS_UNSAFE= yes
+USE_CXXSTD= c++11
-PORTDOCS= NEWS README TODO USAGE evolvotron.html
+WRKSRC= ${WRKDIR}/${PORTNAME}
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
@@ -37,9 +36,7 @@ DESKTOP_ENTRIES="Evolvotron" "Interactive image generator" "${PORTNAME}" \
OPTIONS_DEFINE= DOCS
-.for i in libevolvotron libfunction
-CXXFLAGS+= -include ${WRKSRC}/${i}/${i}_precompiled.h
-.endfor
+PORTDOCS= NEWS README TODO USAGE evolvotron.html
post-patch:
@${REINPLACE_CMD} -e \
@@ -65,6 +62,9 @@ do-install:
${STAGEDIR}${MAN1PREFIX}/man/man1/
.endfor
+post-install: # delete static libs installed by mistake
+ @${RM} -r ${STAGEDIR}${PREFIX}/lib
+
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/evolvotron/distinfo b/graphics/evolvotron/distinfo
index 0f8e803762dd..ee36d3097db1 100644
--- a/graphics/evolvotron/distinfo
+++ b/graphics/evolvotron/distinfo
@@ -1,4 +1,5 @@
-SHA256 (evolvotron-0.6.3.tar.gz) = d1735fe84d90be004888017068f49fa00c97378fd7cca11a90a4a889ef681393
-SIZE (evolvotron-0.6.3.tar.gz) = 182357
+TIMESTAMP = 1531631740
+SHA256 (evolvotron-0.7.1.tar.gz) = 9a5bd7680aa3617de7b822ef1114f04548909be35facbf78c676bd0c4d42f9a9
+SIZE (evolvotron-0.7.1.tar.gz) = 179516
SHA256 (evolvotron_icons.tar.gz) = f7d98eab15bf39d6de66a548457223daaffab4e5fe4aa444c926343786400d85
SIZE (evolvotron_icons.tar.gz) = 93696
diff --git a/graphics/evolvotron/files/patch-USAGE b/graphics/evolvotron/files/patch-USAGE
deleted file mode 100644
index fffb20faf384..000000000000
--- a/graphics/evolvotron/files/patch-USAGE
+++ /dev/null
@@ -1,13 +0,0 @@
---- USAGE.orig
-+++ USAGE
-@@ -68,8 +68,8 @@
-
- -m, --multisample <multisample grid>
- Enables additional antialiasing passes.
-- Specifing 2 or 3 will provide an additional pass with 2x2 or 3x3 samples per pixel.
-- Specifiying 4 (of higher) will provide a 2x2 and a final 4x4 pass.
-+ Specifying 2 or 3 will provide an additional pass with 2x2 or 3x3 samples per pixel.
-+ Specifying 4 (of higher) will provide a 2x2 and a final 4x4 pass.
- Specifying 1 provides the default behaviour of one sample per pixel.
- For best rendering quality also specify -j.
-
diff --git a/graphics/evolvotron/files/patch-libevolvotron__dialog_help.cpp b/graphics/evolvotron/files/patch-libevolvotron__dialog_help.cpp
deleted file mode 100644
index 235c31977851..000000000000
--- a/graphics/evolvotron/files/patch-libevolvotron__dialog_help.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- libevolvotron/dialog_help.cpp.orig
-+++ libevolvotron/dialog_help.cpp
-@@ -45,10 +45,10 @@
- " Esc - Returns to normal mode from full-screen/menu-hidden mode."
- " </li>"
- " <li>"
--" R - Reset (reset mutation paramters and locks)"
-+" R - Reset (reset mutation parameters and locks)"
- " </li>"
- " <li>"
--" T - Restart (preserve mutation paramters and locks)"
-+" T - Restart (preserve mutation parameters and locks)"
- " </li>"
- " <li>"
- " X - Remix (randomize function weights and restart)"
diff --git a/graphics/evolvotron/pkg-plist b/graphics/evolvotron/pkg-plist
index c9e4983bd1fd..16b26ebc4035 100644
--- a/graphics/evolvotron/pkg-plist
+++ b/graphics/evolvotron/pkg-plist
@@ -1,8 +1,6 @@
bin/evolvotron
bin/evolvotron_mutate
bin/evolvotron_render
-lib/libevolvotron.a
-lib/libfunction.a
man/man1/evolvotron.1.gz
man/man1/evolvotron_mutate.1.gz
man/man1/evolvotron_render.1.gz