aboutsummaryrefslogtreecommitdiff
path: root/graphics/exiftags
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-13 08:53:14 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-13 08:53:14 +0000
commit2dc9da5db6e26a6718cd62a27ccca24ba2e70066 (patch)
tree39c23223586a96222e896e66730c14a78201f62c /graphics/exiftags
parentd0244caa3907486d52c3720103747ce4e42fece1 (diff)
downloadports-2dc9da5db6e26a6718cd62a27ccca24ba2e70066.tar.gz
ports-2dc9da5db6e26a6718cd62a27ccca24ba2e70066.zip
add exiftags 0.93
Parses a specified JPEG file for a JPEG APP1 section containing Exif data
Notes
Notes: svn path=/head/; revision=66246
Diffstat (limited to 'graphics/exiftags')
-rw-r--r--graphics/exiftags/Makefile28
-rw-r--r--graphics/exiftags/distinfo1
-rw-r--r--graphics/exiftags/pkg-comment1
-rw-r--r--graphics/exiftags/pkg-descr10
-rw-r--r--graphics/exiftags/pkg-plist1
5 files changed, 41 insertions, 0 deletions
diff --git a/graphics/exiftags/Makefile b/graphics/exiftags/Makefile
new file mode 100644
index 000000000000..781723bde13a
--- /dev/null
+++ b/graphics/exiftags/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: exiftags
+# Date created: Sep 13, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= exiftags
+PORTVERSION= 0.93
+CATEGORIES= graphics
+MASTER_SITES= http://johnst.org/sw/exiftags/
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_REINPLACE= yes
+
+MAN1= exiftags.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,^CC,#CC,g" -e "s,^CFLAGS,#CFLAGS,g" \
+ -e "s,^PREFIX,#PREFIX,g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/exiftags ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/exiftags.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/graphics/exiftags/distinfo b/graphics/exiftags/distinfo
new file mode 100644
index 000000000000..7d06ca0ba9a5
--- /dev/null
+++ b/graphics/exiftags/distinfo
@@ -0,0 +1 @@
+MD5 (exiftags-0.93.tar.gz) = 194b64e841741c64aca3ecea98067b10
diff --git a/graphics/exiftags/pkg-comment b/graphics/exiftags/pkg-comment
new file mode 100644
index 000000000000..3ce13a0cea28
--- /dev/null
+++ b/graphics/exiftags/pkg-comment
@@ -0,0 +1 @@
+Parses a specified JPEG file for a JPEG APP1 section containing Exif data
diff --git a/graphics/exiftags/pkg-descr b/graphics/exiftags/pkg-descr
new file mode 100644
index 000000000000..1a7a9021347b
--- /dev/null
+++ b/graphics/exiftags/pkg-descr
@@ -0,0 +1,10 @@
+The exiftags utility parses a specified JPEG file or, by default, its standard
+input, looking for a JPEG APP1 section containing Exif (Exchangeable Image
+File) data. The properties contained in these data are then printed to the
+standard output. Digital cameras typically add Exif data to the image files
+they produce, containing information about the camera and digitized image.
+
+The program supports a variety of cameras, and includes additional support for
+a portion of the maker notes for Canon, Fuji, Nikon, and Olympus cameras.
+
+WWW: http://johnst.org/sw/exiftags/
diff --git a/graphics/exiftags/pkg-plist b/graphics/exiftags/pkg-plist
new file mode 100644
index 000000000000..e2b2f62513aa
--- /dev/null
+++ b/graphics/exiftags/pkg-plist
@@ -0,0 +1 @@
+bin/exiftags