aboutsummaryrefslogtreecommitdiff
path: root/graphics/exiv2
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-07-10 19:30:55 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-07-10 19:30:55 +0000
commit6dc0b2cfc84b352a57ba4c627c97a71fb5ab8451 (patch)
treea3d23a1473ae547c3eb2b610311e35a9006eae4e /graphics/exiv2
parenta3289277ff67404b5ba8b518e9ec11b74fd7233e (diff)
downloadports-6dc0b2cfc84b352a57ba4c627c97a71fb5ab8451.tar.gz
ports-6dc0b2cfc84b352a57ba4c627c97a71fb5ab8451.zip
graphics/exiv2: update to 0.27.1
Exp-run by: antoine PR: 239028
Notes
Notes: svn path=/head/; revision=506383
Diffstat (limited to 'graphics/exiv2')
-rw-r--r--graphics/exiv2/Makefile5
-rw-r--r--graphics/exiv2/distinfo6
-rw-r--r--graphics/exiv2/files/patch-git_04c9b188
-rw-r--r--graphics/exiv2/pkg-plist9
4 files changed, 10 insertions, 98 deletions
diff --git a/graphics/exiv2/Makefile b/graphics/exiv2/Makefile
index 73a4c350637d..3ac826b7cdfb 100644
--- a/graphics/exiv2/Makefile
+++ b/graphics/exiv2/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= exiv2
-DISTVERSION= 0.27.0
-DISTVERSIONSUFFIX= a-Source
-PORTREVISION= 1
+DISTVERSION= 0.27.1
+DISTVERSIONSUFFIX= -Source
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://www.exiv2.org/builds/
diff --git a/graphics/exiv2/distinfo b/graphics/exiv2/distinfo
index aa82b1230a3f..da955a15ddb0 100644
--- a/graphics/exiv2/distinfo
+++ b/graphics/exiv2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1550640374
-SHA256 (exiv2-0.27.0a-Source.tar.gz) = a4adfa7aaf295b0383adead476f8e0493b9d6c6c7570d5884d2ebf8a2871902f
-SIZE (exiv2-0.27.0a-Source.tar.gz) = 27168207
+TIMESTAMP = 1557685573
+SHA256 (exiv2-0.27.1-Source.tar.gz) = f125286980fd1bcb28e188c02a93946951c61e10784720be2301b661a65b3081
+SIZE (exiv2-0.27.1-Source.tar.gz) = 27210365
diff --git a/graphics/exiv2/files/patch-git_04c9b1 b/graphics/exiv2/files/patch-git_04c9b1
deleted file mode 100644
index 55f3cce0cb79..000000000000
--- a/graphics/exiv2/files/patch-git_04c9b1
+++ /dev/null
@@ -1,88 +0,0 @@
-Slightly modified:
-
-From 04c9b181cc2c7741fcb134ccc43f2bafc1f86f19 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Luis=20D=C3=ADaz=20M=C3=A1s?= <piponazo@gmail.com>
-Date: Sat, 12 Jan 2019 12:15:27 +0000
-Subject: [PATCH] Fix #644. Export specializations of BasicError
-
-- Only export BasicError::setMsg which is the only implementation present in the .cpp
-- Only export BasicError specialization on __APPLE__
-
-It seems that gcc automatically adds the attribute when the visibility
-settings are set to hidden. See this link for more information:
-https://reviews.llvm.org/D35388
----
- cmake/mainSetup.cmake | 6 ++++--
- include/exiv2/error.hpp | 3 ++-
- src/error.cpp | 6 ++++--
- 3 files changed, 10 insertions(+), 5 deletions(-)
-
-diff --git a/cmake/mainSetup.cmake b/cmake/mainSetup.cmake
-index 05c16004d..a4d983d4c 100644
---- cmake/mainSetup.cmake
-+++ cmake/mainSetup.cmake
-@@ -13,8 +13,10 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
- set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_DEBUG ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
- set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_RELEASE ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
-
--set(CMAKE_CXX_VISIBILITY_PRESET hidden)
--set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
-+if (NOT CMAKE_CXX_COMPILER_ID MATCHES "Clang")
-+ set(CMAKE_CXX_VISIBILITY_PRESET hidden)
-+ set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
-+endif()
-
- set(CMAKE_CXX_STANDARD 98)
- set(CMAKE_CXX_STANDARD_REQUIRED ON)
-diff --git a/include/exiv2/error.hpp b/include/exiv2/error.hpp
-index 0f9714e5b..42a0959c4 100644
---- include/exiv2/error.hpp
-+++ include/exiv2/error.hpp
-@@ -315,7 +315,7 @@ namespace Exiv2 {
- std::basic_string<charT> arg3_; //!< Third argument
- std::string msg_; //!< Complete error message
- #ifdef EXV_UNICODE_PATH
-- std::wstring wmsg_; //!< Complete error message as a wide string
-+ std::wstring wmsg_; //!< Complete error message as a wide string
- #endif
- }; // class BasicError
-
-@@ -389,6 +389,7 @@ namespace Exiv2 {
- return wmsg_.c_str();
- }
- #endif
-+
- #ifdef _MSC_VER
- # pragma warning( default : 4275 )
- #endif
-diff --git a/src/error.cpp b/src/error.cpp
-index 6d3a24bd8..c8e2d9e0d 100644
---- src/error.cpp
-+++ src/error.cpp
-@@ -224,7 +224,6 @@ namespace Exiv2 {
- {
- }
-
-- //! @cond IGNORE
- template<>
- void BasicError<char>::setMsg()
- {
-@@ -257,7 +256,9 @@ namespace Exiv2 {
- wmsg_ = s2ws(msg);
- #endif
- }
-- //! @endcond
-+#ifdef __FreeBSD__
-+ template class EXIV2API BasicError<char>;
-+#endif
-
- #ifdef EXV_UNICODE_PATH
- template<>
-@@ -291,6 +292,7 @@ namespace Exiv2 {
- wmsg_ = wmsg;
- msg_ = ws2s(wmsg);
- }
-+ template class EXIV2API BasicError<wchar_t>;
- #endif
-
- const char* errMsg(int code)
diff --git a/graphics/exiv2/pkg-plist b/graphics/exiv2/pkg-plist
index b34eb5e13a7d..0a30988d1c46 100644
--- a/graphics/exiv2/pkg-plist
+++ b/graphics/exiv2/pkg-plist
@@ -82,15 +82,16 @@ include/exiv2/version.hpp
include/exiv2/webpimage.hpp
include/exiv2/xmp_exiv2.hpp
include/exiv2/xmpsidecar.hpp
+lib/exiv2/cmake/exiv2Config-%%CMAKE_BUILD_TYPE%%.cmake
+lib/exiv2/cmake/exiv2Config.cmake
+lib/exiv2/cmake/exiv2ConfigVersion.cmake
lib/libexiv2.so
-lib/libexiv2.so.0.27.0
+lib/libexiv2.so.0.27.1
lib/libexiv2.so.27
-lib/libxmp.a
+lib/libexiv2-xmp.a
libdata/pkgconfig/exiv2.pc
man/man1/exiv2.1.gz
%%SAMPLE%%man/man1/exiv2samples.1.gz
-%%DATADIR%%/cmake/exiv2Config-%%CMAKE_BUILD_TYPE%%.cmake
-%%DATADIR%%/cmake/exiv2Config.cmake
share/locale/bs/LC_MESSAGES/exiv2.mo
share/locale/ca/LC_MESSAGES/exiv2.mo
share/locale/de/LC_MESSAGES/exiv2.mo