aboutsummaryrefslogtreecommitdiff
path: root/graphics/exiv2
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2020-09-26 12:09:37 +0000
committerThomas Zander <riggs@FreeBSD.org>2020-09-26 12:09:37 +0000
commit9de8431a4a63f5a86255c2d5d51a42e5ecfde5c2 (patch)
tree1e3d0cb3184fabbe5f387ea108a77ea85c7c463f /graphics/exiv2
parent82b7b60e283250285a492a7425ba72aca62d977a (diff)
downloadports-9de8431a4a63f5a86255c2d5d51a42e5ecfde5c2.tar.gz
ports-9de8431a4a63f5a86255c2d5d51a42e5ecfde5c2.zip
Add NLS option.
PR: 248733 Submitted by: melanhit@gmail.com Reviewed by: daniel.engberg.lists@pyret.net, riggs
Notes
Notes: svn path=/head/; revision=550175
Diffstat (limited to 'graphics/exiv2')
-rw-r--r--graphics/exiv2/Makefile19
-rw-r--r--graphics/exiv2/pkg-plist34
2 files changed, 30 insertions, 23 deletions
diff --git a/graphics/exiv2/Makefile b/graphics/exiv2/Makefile
index 44567ed26526..6581f07b1a63 100644
--- a/graphics/exiv2/Makefile
+++ b/graphics/exiv2/Makefile
@@ -18,23 +18,23 @@ LIB_DEPENDS= libexpat.so:textproc/expat2
TEST_DEPENDS= bash:shells/bash
TEST_LIB_DEPENDS= libgtest.so:devel/googletest
-USES= cmake compiler:c++11-lang cpe dos2unix gettext iconv pathfix \
+USES= cmake compiler:c++11-lang cpe dos2unix gettext-tools pathfix \
python:3.5+,test localbase:ldflags
USE_LDCONFIG= yes
DOS2UNIX_FILES= cmake/compilerFlags.cmake
TEST_TARGET= tests
-LDFLAGS+= -lintl
-
-CMAKE_ON= EXIV2_ENABLE_VIDEO \
- EXIV2_ENABLE_NLS
+CMAKE_ON= EXIV2_ENABLE_VIDEO
CMAKE_OFF= EXIV2_ENABLE_LIBXMP
-OPTIONS_DEFINE= SAMPLE TEST
+OPTIONS_DEFINE= NLS SAMPLE TEST
OPTIONS_SUB= yes
TEST_IMPLIES= SAMPLE
+NLS_CMAKE_BOOL= EXIV2_ENABLE_NLS
+NLS_USES= gettext-runtime
+
SAMPLE_DESC= Include sample applications
SAMPLE_CMAKE_BOOL= EXIV2_BUILD_SAMPLES
@@ -44,6 +44,13 @@ PATHFIX_CMAKELISTSTXT= CMakeChecks.txt
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-Source
+.include <bsd.port.options.mk>
+
+LDFLAGS_powerpc= -lintl
+LDFLAGS_powerpc64= -lintl
+LDFLAGS_mips= -lintl
+LDFLAGS_mips64= -lintl
+
post-patch:
@${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' \
${WRKSRC}/test/Makefile
diff --git a/graphics/exiv2/pkg-plist b/graphics/exiv2/pkg-plist
index f3099e00d2b5..aa9767b448b6 100644
--- a/graphics/exiv2/pkg-plist
+++ b/graphics/exiv2/pkg-plist
@@ -74,20 +74,20 @@ lib/libexiv2.so.27
lib/libexiv2-xmp.a
libdata/pkgconfig/exiv2.pc
man/man1/exiv2.1.gz
-share/locale/bs/LC_MESSAGES/exiv2.mo
-share/locale/ca/LC_MESSAGES/exiv2.mo
-share/locale/de/LC_MESSAGES/exiv2.mo
-share/locale/es/LC_MESSAGES/exiv2.mo
-share/locale/fi/LC_MESSAGES/exiv2.mo
-share/locale/fr/LC_MESSAGES/exiv2.mo
-share/locale/gl/LC_MESSAGES/exiv2.mo
-share/locale/ms/LC_MESSAGES/exiv2.mo
-share/locale/nl/LC_MESSAGES/exiv2.mo
-share/locale/pl/LC_MESSAGES/exiv2.mo
-share/locale/pt/LC_MESSAGES/exiv2.mo
-share/locale/ru/LC_MESSAGES/exiv2.mo
-share/locale/sk/LC_MESSAGES/exiv2.mo
-share/locale/sv/LC_MESSAGES/exiv2.mo
-share/locale/ug/LC_MESSAGES/exiv2.mo
-share/locale/uk/LC_MESSAGES/exiv2.mo
-share/locale/vi/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/bs/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/de/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/es/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/exiv2.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/exiv2.mo