aboutsummaryrefslogtreecommitdiff
path: root/graphics/facedetect
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-07-20 11:53:59 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-07-20 11:53:59 +0000
commit1ba616cf80841b3d8cc7ad334e256bbd23e9fc36 (patch)
tree1913994aba25e603ede21c473fcc0011ebf45644 /graphics/facedetect
parentbcaf332da9c74ba6c0a80af2fae417cfcafcaa4e (diff)
downloadports-1ba616cf80841b3d8cc7ad334e256bbd23e9fc36.tar.gz
ports-1ba616cf80841b3d8cc7ad334e256bbd23e9fc36.zip
Add facedetect 0.1, simple face detector for batch processing.
Notes
Notes: svn path=/head/; revision=446258
Diffstat (limited to 'graphics/facedetect')
-rw-r--r--graphics/facedetect/Makefile34
-rw-r--r--graphics/facedetect/distinfo3
-rw-r--r--graphics/facedetect/files/patch-facedetect11
-rw-r--r--graphics/facedetect/pkg-descr9
4 files changed, 57 insertions, 0 deletions
diff --git a/graphics/facedetect/Makefile b/graphics/facedetect/Makefile
new file mode 100644
index 000000000000..372d6b07ebf0
--- /dev/null
+++ b/graphics/facedetect/Makefile
@@ -0,0 +1,34 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= facedetect
+PORTVERSION= 0.1
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Simple face detector for batch processing
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cv.py:graphics/py-opencv
+
+USES= python:run shebangfix
+USE_GITHUB= yes
+NO_BUILD= yes
+NO_ARCH= yes
+
+GH_ACCOUNT= wavexx
+
+SHEBANG_FILES= facedetect
+PLIST_FILES= bin/facedetect
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/facedetect/distinfo b/graphics/facedetect/distinfo
new file mode 100644
index 000000000000..220a59dadb96
--- /dev/null
+++ b/graphics/facedetect/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500542394
+SHA256 (wavexx-facedetect-v0.1_GH0.tar.gz) = d0e6814af5ffdb9bf064cfeb1fe78966fd98700e245650e3033dcdf64bf74f44
+SIZE (wavexx-facedetect-v0.1_GH0.tar.gz) = 121053
diff --git a/graphics/facedetect/files/patch-facedetect b/graphics/facedetect/files/patch-facedetect
new file mode 100644
index 000000000000..f275fffaccb5
--- /dev/null
+++ b/graphics/facedetect/files/patch-facedetect
@@ -0,0 +1,11 @@
+--- facedetect.orig 2017-07-20 10:43:10 UTC
++++ facedetect
+@@ -34,7 +34,7 @@ if 'cv' in dir(cv2):
+
+
+ # Profiles
+-DATA_DIR = '/usr/share/opencv/'
++DATA_DIR = '%%LOCALBASE%%/share/OpenCV/'
+ CASCADES = {}
+
+ PROFILES = {
diff --git a/graphics/facedetect/pkg-descr b/graphics/facedetect/pkg-descr
new file mode 100644
index 000000000000..0df047529a92
--- /dev/null
+++ b/graphics/facedetect/pkg-descr
@@ -0,0 +1,9 @@
+facedetect is a simple face detector for batch processing. It answers the basic
+question: "Is there a face in this image?" and gives back either an exit code or
+the coordinates of each detected face in the standard output.
+
+The aim is to provide a basic command-line interface that's consistent and easy
+to use with software such as ImageMagick, while progressively improving the
+detection algorithm over time.
+
+WWW: https://www.thregr.org/~wavexx/software/facedetect/