aboutsummaryrefslogtreecommitdiff
path: root/graphics/fig2sxd
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-09-04 06:54:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-09-04 06:54:09 +0000
commit16d58ef0ea7ce51a7544bfe915ef7fcf015cea50 (patch)
tree12352afd2b2e0d1b746b85ba5c5af7d5656b20f0 /graphics/fig2sxd
parent67729b7c8cda941141981374d652bafec0f673c3 (diff)
downloadports-16d58ef0ea7ce51a7544bfe915ef7fcf015cea50.tar.gz
ports-16d58ef0ea7ce51a7544bfe915ef7fcf015cea50.zip
- Remove dependency from GCC
- Specify LICENSE PR: 226178 (related)
Notes
Notes: svn path=/head/; revision=478930
Diffstat (limited to 'graphics/fig2sxd')
-rw-r--r--graphics/fig2sxd/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/graphics/fig2sxd/Makefile b/graphics/fig2sxd/Makefile
index 5e99c469e813..849e4a7c848d 100644
--- a/graphics/fig2sxd/Makefile
+++ b/graphics/fig2sxd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fig2sxd
PORTVERSION= 0.22.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics converters
MASTER_SITES= LOCAL/ehaupt SF
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
@@ -11,18 +11,16 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Convert .xfig files to the OpenOffice draw format
-USES= gmake
+LICENSE= GPLv2
+
+USES= compiler gmake
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/fig2sxd man/man1/fig2sxd.1.gz
-.include <bsd.port.pre.mk>
-
-# Does not compile with clang 6.0.0; PR 226178.
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200056
-USE_GCC= yes
-.endif
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
post-patch:
@${REINPLACE_CMD} -e \
@@ -33,4 +31,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>