aboutsummaryrefslogtreecommitdiff
path: root/graphics/flasm
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-10-10 05:51:56 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-10-10 05:51:56 +0000
commit711679ca32dcedc56cd658f8bbe2cebf63fc55cb (patch)
tree6966d89ce54a9611b114ca3532824daaabae5469 /graphics/flasm
parent565849eb48d5a0e499cbb58ad66483441e465112 (diff)
downloadports-711679ca32dcedc56cd658f8bbe2cebf63fc55cb.tar.gz
ports-711679ca32dcedc56cd658f8bbe2cebf63fc55cb.zip
- Upgrade to 1.62.
PR: ports/148832 Submitted by: Takefu <takefu@airport.fm>
Notes
Notes: svn path=/head/; revision=262738
Diffstat (limited to 'graphics/flasm')
-rw-r--r--graphics/flasm/Makefile13
-rw-r--r--graphics/flasm/distinfo6
-rw-r--r--graphics/flasm/files/patch-assembler.y257
-rw-r--r--graphics/flasm/files/patch-unflasm.c6
4 files changed, 13 insertions, 269 deletions
diff --git a/graphics/flasm/Makefile b/graphics/flasm/Makefile
index 0f9c3ba1b924..665750e073e7 100644
--- a/graphics/flasm/Makefile
+++ b/graphics/flasm/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= flasm
-PORTVERSION= 1.52
-PORTREVISION= 1
+PORTVERSION= 1.62
CATEGORIES= graphics
-#MASTER_SITES= http://www.nowrap.de/download/
-MASTER_SITES= http://dist.bsdlab.org/
-DISTNAME= flasm152src
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://www.nowrap.de/download/
+MASTER_SITE_SUBDIR= kuriyama
+DISTNAME= flasm16src
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Command line assembler/disassembler of flash actionscript bytecode
@@ -19,11 +19,12 @@ COMMENT= Command line assembler/disassembler of flash actionscript bytecode
PLIST_FILES= bin/flasm
USE_ZIP= YES
USE_GMAKE= YES
+USE_DOS2UNIX= YES
USE_BISON= build
NO_WRKSUBDIR= YES
MAKE_ARGS= CFLAGS="${CFLAGS}"
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/flasm ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/flasm ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/graphics/flasm/distinfo b/graphics/flasm/distinfo
index d1d06565e303..8d48e12a48be 100644
--- a/graphics/flasm/distinfo
+++ b/graphics/flasm/distinfo
@@ -1,3 +1,3 @@
-MD5 (flasm152src.zip) = b917dd7e3826f5796ca6f31d686a329c
-SHA256 (flasm152src.zip) = 1d8bc11b60ee6d1e1e840398cc2a96268971c5346823d89ec7693b925fe9d3b3
-SIZE (flasm152src.zip) = 109364
+MD5 (flasm16src.zip) = 28a4586409061b385d1cd27d3f120c0b
+SHA256 (flasm16src.zip) = df1273a506e2479cf95775197f5b7fa94e29fe1e0aae5aa190ed5bbebc4be5c6
+SIZE (flasm16src.zip) = 111912
diff --git a/graphics/flasm/files/patch-assembler.y b/graphics/flasm/files/patch-assembler.y
deleted file mode 100644
index 476d16639901..000000000000
--- a/graphics/flasm/files/patch-assembler.y
+++ /dev/null
@@ -1,257 +0,0 @@
-http://sourceforge.net/tracker/index.php?func=detail&aid=2615264&group_id=33473&atid=408391
-diff -up assembler.y.midrule assembler.y
---- assembler.y.midrule 2008-12-20 22:44:50.000000000 +0100
-+++ assembler.y 2008-12-20 22:54:03.000000000 +0100
-@@ -605,24 +605,24 @@ finally_opt
-
- trycatchfinally
- : TRY name_opt {
-- $$ = writeByte(SWFACTION_TRY);
-+ $<num>$ = writeByte(SWFACTION_TRY);
- /* action length */
-- $$ += writeShort(strlen($2)+8);
-+ $<num>$ += writeShort(strlen($2)+8);
- /* zero flag */
-- $$ += writeByte(0);
-+ $<num>$ += writeByte(0);
- /* zero try length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- /* zero catch length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- /* zero finally length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- /* error variable name */
-- $$ += writeString($2);
-+ $<num>$ += writeString($2);
- }
-
-- statements_opt { $$ = $<num>3 + $4; patchLength($$ - 6, $4); }
-- catch_opt { $$ = $<num>5 + $6; patchLength($$ - 8, $6); }
-- finally_opt { $$ = $<num>7 + $8; patchLength($$ - 10, $8); }
-+ statements_opt { $<num>$ = $<num>3 + $4; patchLength($<num>$ - 6, $4); }
-+ catch_opt { $<num>$ = $<num>5 + $6; patchLength($<num>$ - 8, $6); }
-+ finally_opt { $<num>$ = $<num>7 + $8; patchLength($<num>$ - 10, $8); }
- END {
- byte flag = 0;
- $$ = $<num>9;
-@@ -634,24 +634,24 @@ trycatchfinally
- }
-
- | TRY register {
-- $$ = writeByte(SWFACTION_TRY);
-+ $<num>$ = writeByte(SWFACTION_TRY);
- /* action length */
-- $$ += writeShort(8);
-+ $<num>$ += writeShort(8);
- /* zero flag */
-- $$ += writeByte(0);
-+ $<num>$ += writeByte(0);
- /* zero try length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- /* zero catch length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- /* zero finally length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- /* error register number */
-- $$ += writeByte((byte) $2);
-+ $<num>$ += writeByte((byte) $2);
- }
-
-- statements_opt { $$ = $<num>3 + $4; patchLength($$ - 6, $4); }
-- catch_opt { $$ = $<num>5 + $6; patchLength($$ - 8, $6); }
-- finally_opt { $$ = $<num>7 + $8; patchLength($$ - 10, $8); }
-+ statements_opt { $<num>$ = $<num>3 + $4; patchLength($<num>$ - 6, $4); }
-+ catch_opt { $<num>$ = $<num>5 + $6; patchLength($<num>$ - 8, $6); }
-+ finally_opt { $<num>$ = $<num>7 + $8; patchLength($<num>$ - 10, $8); }
- END {
- byte flag = 4;
- $$ = $<num>9;
-@@ -707,25 +707,25 @@ name_opt
-
- function
- : FUNCTION name_opt {
-- $$ = writeByte(SWFACTION_DEFINEFUNCTION);
-+ $<num>$ = writeByte(SWFACTION_DEFINEFUNCTION);
- /* zero block length */
-- $$ += writeShort(0);
-- $$ += writeString($2);
-+ $<num>$ += writeShort(0);
-+ $<num>$ += writeString($2);
- }
-
- '(' function_args ')' {
- unsigned int i;
- numArgs = $5;
-
-- $$ = $<num>3 + writeShort(numArgs);
-+ $<num>$ = $<num>3 + writeShort(numArgs);
-
- for(i = 0; i < numArgs; ++i)
-- $$ += writeString(func_args[i]);
-+ $<num>$ += writeString(func_args[i]);
-
- /* zero function length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- /* patch block length */
-- patchLength($$-3, $$-3);
-+ patchLength($<num>$-3, $<num>$-3);
- }
-
- statements_opt END {
-@@ -837,25 +837,25 @@ autoregarglist
-
- function2
- : FUNCTION2 name_opt {
-- $$ = writeByte(SWFACTION_DEFINEFUNCTION2);
-+ $<num>$ = writeByte(SWFACTION_DEFINEFUNCTION2);
- /* zero block length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- /* function name */
-- $$ += writeString($2);
-+ $<num>$ += writeString($2);
- curFunc++;
- memset(regfunc_args[curFunc], 0, sizeof (regfunc_args[curFunc]));
- numArgs = 0;
- /* zero num of function arguments */
-- $$ += writeShort(numArgs);
-+ $<num>$ += writeShort(numArgs);
- /* allocate zero registers */
- numRegisters[curFunc] = 0;
-- $$ += writeByte(numRegisters[curFunc]);
-+ $<num>$ += writeByte(numRegisters[curFunc]);
- /* zero automatic register flags */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- }
-
- '(' regarglist ')' {
-- $$ = $<num>3 + $5;
-+ $<num>$ = $<num>3 + $5;
- /* patch num of function arguments */
- patchLength($5 + 3, numArgs);
- autoregFlags = 0;
-@@ -866,9 +866,9 @@ function2
- byte curautoreg = 1;
- unsigned int i;
-
-- $$ = $<num>7;
-+ $<num>$ = $<num>7;
- /* zero body length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
-
- /* make sure auto registers are allocated in the right order */
- for (i = 0; i < MAX_AUTO_REGS; i++) {
-@@ -883,9 +883,9 @@ function2
- }
-
- /* patch automatic register flags */
-- patchLength($$ - $<num>3, autoregFlags);
-+ patchLength($<num>$ - $<num>3, autoregFlags);
- /* patch block length */
-- patchLength($$ - 3, $$ - 3);
-+ patchLength($<num>$ - 3, $<num>$ - 3);
- }
-
- statements_opt END {
-@@ -905,11 +905,11 @@ function2
-
- with
- : WITH {
-- $$ = writeByte(SWFACTION_WITH);
-+ $<num>$ = writeByte(SWFACTION_WITH);
- /* length of with action */
-- $$ += writeShort(2);
-+ $<num>$ += writeShort(2);
- /* length of with block - will be patched */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- }
-
- statements_opt END {
-@@ -921,9 +921,9 @@ with
-
- settarget
- : SETTARGET STRING {
-- $$ = writeByte(SWFACTION_SETTARGET);
-- $$ += writeShort(strlen($2)+1);
-- $$ += writeString($2);
-+ $<num>$ = writeByte(SWFACTION_SETTARGET);
-+ $<num>$ += writeShort(strlen($2)+1);
-+ $<num>$ += writeString($2);
- }
-
- statements_opt END {
-@@ -934,7 +934,7 @@ settarget
- ;
-
- settargetexpression
-- : SETTARGETEXPR { $$ = writeByte(SWFACTION_SETTARGETEXPRESSION); }
-+ : SETTARGETEXPR { $<num>$ = writeByte(SWFACTION_SETTARGETEXPRESSION); }
- statements_opt END {
- $$ = $3 + writeByte(SWFACTION_SETTARGET);
- $$ += $<num>2 + writeShort(1);
-@@ -946,9 +946,9 @@ ifframeloadedexpression
- : IFFRAMELOADEDEXPR {
- if (frameloadedStart>-1)
- yyerror("IfFrameLoaded actions can't be nested");
-- $$ = writeByte(SWFACTION_IFFRAMELOADEDEXPRESSION);
-- $$ += writeShort(1);
-- $$ += writeByte(0);
-+ $<num>$ = writeByte(SWFACTION_IFFRAMELOADEDEXPRESSION);
-+ $<num>$ += writeShort(1);
-+ $<num>$ += writeByte(0);
- frameloadedStart = numActions;
- }
-
-@@ -963,10 +963,10 @@ ifframeloaded
- : IFFRAMELOADED INTEGER {
- if (frameloadedStart>-1)
- yyerror("IfFrameLoaded actions can't be nested");
-- $$ = writeByte(SWFACTION_IFFRAMELOADED);
-- $$ += writeShort(3);
-- $$ += writeShort($2);
-- $$ += writeByte(0);
-+ $<num>$ = writeByte(SWFACTION_IFFRAMELOADED);
-+ $<num>$ += writeShort(3);
-+ $<num>$ += writeShort($2);
-+ $<num>$ += writeByte(0);
- frameloadedStart = numActions;
- }
-
-@@ -1199,9 +1199,9 @@ opcode
- constant_list_opt { $$ = writeConstants(); }
-
- | PUSH {
-- $$ = writeByte(SWFACTION_PUSHDATA);
-+ $<num>$ = writeByte(SWFACTION_PUSHDATA);
- /* length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- }
-
- push_list {
-@@ -1212,10 +1212,10 @@ opcode
- | SWFACTION HEX {
- if (xtoi($2)>0xff)
- yyerror("Action code out of range");
-- $$ = writeByte((char)xtoi($2));
-+ $<num>$ = writeByte((char)xtoi($2));
- if (xtoi($2)>=0x80)
- /* length */
-- $$ += writeShort(0);
-+ $<num>$ += writeShort(0);
- }
-
- hexlist_opt {
-
-
-
diff --git a/graphics/flasm/files/patch-unflasm.c b/graphics/flasm/files/patch-unflasm.c
index 36b1c12751f6..209a39b8baef 100644
--- a/graphics/flasm/files/patch-unflasm.c
+++ b/graphics/flasm/files/patch-unflasm.c
@@ -1,6 +1,6 @@
---- unflasm.c.orig Tue Jun 1 23:05:40 2004
-+++ unflasm.c Tue Jun 1 23:07:05 2004
-@@ -991,29 +991,11 @@
+--- unflasm.c.orig 2007-06-10 03:40:47.000000000 +0900
++++ unflasm.c 2010-07-22 12:09:29.000000000 +0900
+@@ -1012,29 +1012,11 @@
}
case SWFACTION_SETTARGET: