aboutsummaryrefslogtreecommitdiff
path: root/graphics/fly
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:53:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-27 09:53:07 +0000
commiteeaf87367af1160ad6138bc2541fd5175c7ae8e7 (patch)
tree2a8b250bc3088f0d5aa42041a3e185290b8b1221 /graphics/fly
parent5317a451d384730bc6b97218e2d217a8a22ac586 (diff)
downloadports-eeaf87367af1160ad6138bc2541fd5175c7ae8e7.tar.gz
ports-eeaf87367af1160ad6138bc2541fd5175c7ae8e7.zip
Notes
Diffstat (limited to 'graphics/fly')
-rw-r--r--graphics/fly/Makefile16
-rw-r--r--graphics/fly/pkg-plist53
2 files changed, 8 insertions, 61 deletions
diff --git a/graphics/fly/Makefile b/graphics/fly/Makefile
index b94a6752732b..fc594e3110e3 100644
--- a/graphics/fly/Makefile
+++ b/graphics/fly/Makefile
@@ -9,16 +9,18 @@ PORTNAME= fly
PORTVERSION= 2.0.1
PORTREVISION= 3
CATEGORIES= graphics
-MASTER_SITES= http://martin.gleeson.com/%SUBDIR%/ \
- http://members.optushome.com.au/martingleeson/%SUBDIR%/ \
- http://www.w3perl.com/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${PORTNAME}/dist
+MASTER_SITES= http://fossies.org/unix/www/ \
+ http://martin.gleeson.com/fly/dist/
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple drawing language to generate GIFs on the fly
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+PORTDOCS= *
+PORTEXAMPLES= *
+PLIST_FILES= bin/fly
+
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include fly.c -o fly \
-L${LOCALBASE}/lib -lgd
@@ -27,13 +29,11 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fly ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/doc && ${FIND} . | \
- ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR})
.endif
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${FIND} . | \
- ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>
diff --git a/graphics/fly/pkg-plist b/graphics/fly/pkg-plist
deleted file mode 100644
index 6ed6569a5da4..000000000000
--- a/graphics/fly/pkg-plist
+++ /dev/null
@@ -1,53 +0,0 @@
-bin/fly
-%%PORTDOCS%%%%DOCSDIR%%/FAQ.html
-%%PORTDOCS%%%%DOCSDIR%%/copyright.html
-%%PORTDOCS%%%%DOCSDIR%%/documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/example.gif
-%%PORTDOCS%%%%DOCSDIR%%/examples.html
-%%PORTDOCS%%%%DOCSDIR%%/feedback.html
-%%PORTDOCS%%%%DOCSDIR%%/flag-au.gif
-%%PORTDOCS%%%%DOCSDIR%%/flag-jp.gif
-%%PORTDOCS%%%%DOCSDIR%%/flag-us.gif
-%%PORTDOCS%%%%DOCSDIR%%/fly-logo.gif
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/installation.html
-%%PORTDOCS%%%%DOCSDIR%%/nav-copyright.gif
-%%PORTDOCS%%%%DOCSDIR%%/nav-docs.gif
-%%PORTDOCS%%%%DOCSDIR%%/nav-feedback.gif
-%%PORTDOCS%%%%DOCSDIR%%/nav-home.gif
-%%PORTDOCS%%%%DOCSDIR%%/new.gif
-%%PORTDOCS%%%%DOCSDIR%%/outthere.html
-%%PORTDOCS%%%%DOCSDIR%%/release-notes.html
-%%PORTDOCS%%%%DOCSDIR%%/style.css
-%%PORTDOCS%%%%DOCSDIR%%/using.html
-%%PORTDOCS%%%%DOCSDIR%%/valid_html.gif
-%%PORTDOCS%%%%DOCSDIR%%/Y2K.html
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.csh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gif/small-end.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gif/small.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jpeg/small-end.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jpeg/small.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jpeg/test.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/perl/cgi-perl-example.pl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/perl/fly-tester.pl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/perl/perl.example
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/perl/size.pl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/1.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/2.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/3.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/4.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/5.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/6.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/7.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/8.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/9.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/small-end.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/small.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/small2.fly
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/png/test.fly
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/png
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/perl
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/jpeg
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/gif
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%