aboutsummaryrefslogtreecommitdiff
path: root/graphics/fusefs-gphotofs/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-21 20:08:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-21 20:08:33 +0000
commit720b500484ac5378f07191fb8215c1b43a88510c (patch)
tree4601b297f3b35f0bbfc265643dd86a195f03b4a9 /graphics/fusefs-gphotofs/Makefile
parentea22d6eb2568dbc988111e0fb9c8eb9a096ee1a8 (diff)
downloadports-720b500484ac5378f07191fb8215c1b43a88510c.tar.gz
ports-720b500484ac5378f07191fb8215c1b43a88510c.zip
Notes
Diffstat (limited to 'graphics/fusefs-gphotofs/Makefile')
-rw-r--r--graphics/fusefs-gphotofs/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/fusefs-gphotofs/Makefile b/graphics/fusefs-gphotofs/Makefile
new file mode 100644
index 000000000000..da86e59e0bf4
--- /dev/null
+++ b/graphics/fusefs-gphotofs/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gphotofs
+# Date created: 21 June 2006
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gphotofs
+PORTVERSION= 0.2
+CATEGORIES= graphics sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gphoto
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Mount PTP camera as a file system
+
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs \
+ gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+USE_BZIP2= yes
+USE_GNOME= glib20
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|USE_VERSION=22|USE_VERSION=25|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>