aboutsummaryrefslogtreecommitdiff
path: root/graphics/fv
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-10-07 23:40:23 +0000
committerJohn Marino <marino@FreeBSD.org>2013-10-07 23:40:23 +0000
commit560d2eb0bf5f933214664a43ad5169397ea0dbff (patch)
treee61a78f0169c5b6d3db742a3a79532ae3afa9fab /graphics/fv
parentdcdd82a024e96cfa26ac85f4ccaa54fe053336b4 (diff)
downloadports-560d2eb0bf5f933214664a43ad5169397ea0dbff.tar.gz
ports-560d2eb0bf5f933214664a43ad5169397ea0dbff.zip
Explicitly link libraries on 10 unmaintained ports
The following ports will not build with a binutils 2.22+ linker built with standard options. This has been obvious with DPorts, but difficult to see on FreeBSD. However, setting the ports compiler as a recent gcc (e.g lang/gcc48) is an excellent way to detect the unspecified but needed libraries as these recent GCC compilers use the latest binutils linkers. These patches were tested on FreeBSD 8.4 and DragonFly 3.5
Notes
Notes: svn path=/head/; revision=329747
Diffstat (limited to 'graphics/fv')
-rw-r--r--graphics/fv/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index dd31405bc6f6..eb85bec57c14 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -24,7 +24,7 @@ ALL_TARGET= ${PORTNAME}
CXXFLAGS+= $$(pkg-config --cflags libpng15) \
-I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= $$(pkg-config --libs libpng15) \
- -L${LOCALBASE}/lib -lglut -lGLU -lGL -lbz2 -lm ${PTHREAD_LIBS}
+ -L${LOCALBASE}/lib -lglut -lGLU -lGL -lbz2 -lm -lz ${PTHREAD_LIBS}
PORTDOCS= AUTHORS ChangeLog README
PLIST_FILES= bin/${PORTNAME}