aboutsummaryrefslogtreecommitdiff
path: root/graphics/fv
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
commit9346b215f04cc84bbb7125ff2fcf03978f859a21 (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /graphics/fv
parent49ac3accb4fc378c681317849f4ae94655a61423 (diff)
downloadports-9346b215f04cc84bbb7125ff2fcf03978f859a21.tar.gz
ports-9346b215f04cc84bbb7125ff2fcf03978f859a21.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Notes
Notes: svn path=/head/; revision=301539
Diffstat (limited to 'graphics/fv')
-rw-r--r--graphics/fv/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index 8de82e1cb7e5..ce5835e2a0b6 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -17,12 +17,12 @@ COMMENT= A viewer of hdr/pfm images
LICENSE= GPLv2
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_ZIP= yes
USE_GL= glut
USE_GMAKE= yes
+USE_PKGCONFIG= yes
ALL_TARGET= ${PORTNAME}
MAKE_JOBS_SAFE= yes