aboutsummaryrefslogtreecommitdiff
path: root/graphics/gauche-gl
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-17 09:00:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-17 09:00:19 +0000
commit67cd5fca654a95e830c6d8e68e24fe1aae0875e7 (patch)
tree504f23a0265ecaaf58c72aa28671391c85878442 /graphics/gauche-gl
parent4db15cf3b9349b79305a71e7a393d8a15a2c39c6 (diff)
downloadports-67cd5fca654a95e830c6d8e68e24fe1aae0875e7.tar.gz
ports-67cd5fca654a95e830c6d8e68e24fe1aae0875e7.zip
- Switch to USES=localbase
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=426280
Diffstat (limited to 'graphics/gauche-gl')
-rw-r--r--graphics/gauche-gl/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/graphics/gauche-gl/Makefile b/graphics/gauche-gl/Makefile
index e896b4e9e05c..152e6e101c7f 100644
--- a/graphics/gauche-gl/Makefile
+++ b/graphics/gauche-gl/Makefile
@@ -16,17 +16,14 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gosh:lang/gauche
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= gosh:lang/gauche
-USES= makeinfo tar:tgz
+USES= localbase makeinfo tar:tgz
USE_XORG= ice sm x11 xext xmu xi
-USE_GL= glut
+USE_GL= gl glu glut
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
DOCSDIR= ${PREFIX}/share/doc/gauche/${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/gauche/${PORTNAME}
@@ -50,14 +47,16 @@ do-install:
${GZCAT} ${WRKSRC}/doc/${i}.info.gz \
> ${STAGEDIR}${PREFIX}/${INFO_PATH}/${i}.info
.endfor
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} README \
- ${STAGEDIR}${DOCSDIR})
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . \
- ${STAGEDIR}${EXAMPLESDIR})
@(cd ${STAGEDIR}${PREFIX}/lib/gauche-0.9/site/${CONFIGURE_TARGET} && \
${CHMOD} u+w libgauche-*.so && ${STRIP_CMD} libgauche-*.so && \
${CHMOD} u-w libgauche-*.so)
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
.include <bsd.port.mk>