aboutsummaryrefslogtreecommitdiff
path: root/graphics/gauche-gl
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-12-06 13:51:07 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-12-06 13:51:07 +0000
commitaa0dbd97507e945d6140e72c5e7a4494846fa3b1 (patch)
tree45e62219138e3b1d543bc86c9b6dd22bd3f3d094 /graphics/gauche-gl
parent03a978cff96689a20613b61748b94add5b4bd70a (diff)
downloadports-aa0dbd97507e945d6140e72c5e7a4494846fa3b1.tar.gz
ports-aa0dbd97507e945d6140e72c5e7a4494846fa3b1.zip
Add patch to respect CFLAGS. This fixes the build on powerpc64.
While here, add gl to USES, per modern usage. PR: 232859 Submitted by: Piotr Kubaj
Notes
Notes: svn path=/head/; revision=486757
Diffstat (limited to 'graphics/gauche-gl')
-rw-r--r--graphics/gauche-gl/Makefile2
-rw-r--r--graphics/gauche-gl/files/patch-src_Makefile.in11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/gauche-gl/Makefile b/graphics/gauche-gl/Makefile
index bb06be9b73c9..e423096a0a1c 100644
--- a/graphics/gauche-gl/Makefile
+++ b/graphics/gauche-gl/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gosh:lang/gauche
RUN_DEPENDS= gosh:lang/gauche
-USES= localbase makeinfo tar:tgz
+USES= gl localbase makeinfo tar:tgz
USE_CSTD= gnu99
USE_XORG= ice sm x11 xext xmu xi
USE_GL= gl glu glut
diff --git a/graphics/gauche-gl/files/patch-src_Makefile.in b/graphics/gauche-gl/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..92af171e4a7a
--- /dev/null
+++ b/graphics/gauche-gl/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2018-10-31 17:01:43 UTC
++++ src/Makefile.in
+@@ -17,7 +17,7 @@ DESTDIR =
+ # These are set by configure
+ # NB: cc and various flags must match the ones used to compile Gauche,
+ # so the make invocator shouldn't casually override them.
+-CFLAGS = @DEFS@ @X_CFLAGS@ @GLUT_INCDIR@ @GLEW_INCDIR@
++CFLAGS += @DEFS@ @X_CFLAGS@ @GLUT_INCDIR@ @GLEW_INCDIR@
+ LDFLAGS = @LDFLAGS@
+ OBJEXT = @OBJEXT@
+ SOEXT = @SOEXT@