aboutsummaryrefslogtreecommitdiff
path: root/graphics/gd
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-06-15 11:41:25 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-06-15 11:41:25 +0000
commit143f99034e8d6026004b0ab4126862d88b2a387d (patch)
tree69ca475cf9f07fe92c91335943d8575fe8ee3c38 /graphics/gd
parent308d88a41c159bfecc368f61f0717c6dbbaf66ea (diff)
downloadports-143f99034e8d6026004b0ab4126862d88b2a387d.tar.gz
ports-143f99034e8d6026004b0ab4126862d88b2a387d.zip
- fix to support interlaced gif
PR: 179537 Submitted by: Sergey Kandaurov Obtained from: libgd repo
Notes
Notes: svn path=/head/; revision=320987
Diffstat (limited to 'graphics/gd')
-rw-r--r--graphics/gd/Makefile2
-rw-r--r--graphics/gd/files/patch-gd_gif_out.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index 7ecf394cd3a4..4a28e68c0fde 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gd
PORTVERSION= 2.0.35
-PORTREVISION?= 8
+PORTREVISION?= 9
PORTEPOCH= 1
CATEGORIES+= graphics
MASTER_SITES= http://www.libgd.org/releases/ \
diff --git a/graphics/gd/files/patch-gd_gif_out.c b/graphics/gd/files/patch-gd_gif_out.c
new file mode 100644
index 000000000000..95ce116472c3
--- /dev/null
+++ b/graphics/gd/files/patch-gd_gif_out.c
@@ -0,0 +1,24 @@
+--- gd_gif_out.c~ 2007-01-04 15:44:31.000000000 +0300
++++ gd_gif_out.c 2013-06-13 17:11:11.000000000 +0400
+@@ -586,9 +586,9 @@
+ int InitCodeSize;
+ int i;
+ GifCtx ctx;
++ memset(&ctx, 0, sizeof(ctx));
+ ctx.Interlace = GInterlace;
+ ctx.in_count = 1;
+- memset(&ctx, 0, sizeof(ctx));
+ ColorMapSize = 1 << BitsPerPixel;
+
+ RWidth = ctx.Width = GWidth;
+@@ -735,9 +735,9 @@
+ int InitCodeSize;
+ int i;
+ GifCtx ctx;
++ memset(&ctx, 0, sizeof(ctx));
+ ctx.Interlace = GInterlace;
+ ctx.in_count = 1;
+- memset(&ctx, 0, sizeof(ctx));
+ ColorMapSize = 1 << BitsPerPixel;
+
+ if (LeftOfs < 0) LeftOfs = 0;