aboutsummaryrefslogtreecommitdiff
path: root/graphics/gd
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2019-09-19 08:01:58 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2019-09-19 08:01:58 +0000
commit69cda2d8ca1670f45ade7d7be532f312abdf3a87 (patch)
tree5953f14b5c9cbd31479b1b56813e1ba78abb1d62 /graphics/gd
parentd18b10de07a2ba860e8ad764f023359877ed674b (diff)
Notes
Diffstat (limited to 'graphics/gd')
-rw-r--r--graphics/gd/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index dbcbd3032463..91393c6cf93c 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -14,8 +14,7 @@ COMMENT?= Graphics library for fast creation of images
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libtiff.so:graphics/tiff \
- libpng.so:graphics/png \
+LIB_DEPENDS= libpng.so:graphics/png \
libfreetype.so:print/freetype2
CONFLICTS= bazaar-1.*
@@ -26,8 +25,8 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
TEST_TARGET= check
-OPTIONS_DEFINE= FONTCONFIG ICONV XPM WEBP
-OPTIONS_DEFAULT=FONTCONFIG WEBP
+OPTIONS_DEFINE= FONTCONFIG ICONV XPM WEBP TIFF
+OPTIONS_DEFAULT=FONTCONFIG WEBP TIFF
NO_OPTIONS_SORT=yes
FONTCONFIG_LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
FONTCONFIG_CONFIGURE_OFF= --with-fontconfig=no
@@ -38,6 +37,8 @@ XPM_CONFIGURE_ON= --with-x
XPM_CONFIGURE_OFF= --with-xpm=no
WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
WEBP_CONFIGURE_OFF= --without-webp
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_CONFIGURE_OFF= --without-tiff
.include <bsd.port.options.mk>