aboutsummaryrefslogtreecommitdiff
path: root/graphics/gd
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2017-01-28 19:57:50 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2017-01-28 19:57:50 +0000
commit72a3fa182566cb16f6450ba8b60983d8498f748c (patch)
treeaee0a6a58cc2528822eecf94122b14631b21a18e /graphics/gd
parent8eb33217de901a67c35b93a9937bf47a71b2e525 (diff)
downloadports-72a3fa182566cb16f6450ba8b60983d8498f748c.tar.gz
ports-72a3fa182566cb16f6450ba8b60983d8498f748c.zip
- update to 2.2.4
PR: 216507 Submitted by: Piotr Kubaj MFH: 2017Q1
Notes
Notes: svn path=/head/; revision=432648
Diffstat (limited to 'graphics/gd')
-rw-r--r--graphics/gd/Makefile5
-rw-r--r--graphics/gd/distinfo6
-rw-r--r--graphics/gd/files/patch-gd_webp.c27
-rw-r--r--graphics/gd/files/patch-gdft.c29
-rw-r--r--graphics/gd/pkg-plist2
5 files changed, 6 insertions, 63 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index c26caf2b24ff..710fc6b81f28 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libgd
-PORTVERSION= 2.2.3
-PORTREVISION?= 1
+PORTVERSION= 2.2.4
PORTEPOCH= 1
CATEGORIES+= graphics
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/gd-${PORTVERSION}/
@@ -89,6 +88,6 @@ pre-build:
post-install:
${INSTALL_DATA} ${WRKSRC}/src/gdhelpers.h \
${STAGEDIR}${PREFIX}/include/
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgd.so.6.0.3
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgd.so.6.0.4
.include <bsd.port.mk>
diff --git a/graphics/gd/distinfo b/graphics/gd/distinfo
index dbb43e1090a4..1b24d0eb2e42 100644
--- a/graphics/gd/distinfo
+++ b/graphics/gd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1472401416
-SHA256 (libgd-2.2.3.tar.xz) = 746b6cbd6769a22ff3ba6f5756f3512a769bd4cdf4695dff17f4867f25fa7d3c
-SIZE (libgd-2.2.3.tar.xz) = 2164152
+TIMESTAMP = 1485463341
+SHA256 (libgd-2.2.4.tar.xz) = 137f13a7eb93ce72e32ccd7cebdab6874f8cf7ddf31d3a455a68e016ecd9e4e6
+SIZE (libgd-2.2.4.tar.xz) = 2478528
diff --git a/graphics/gd/files/patch-gd_webp.c b/graphics/gd/files/patch-gd_webp.c
deleted file mode 100644
index 829890f6eda3..000000000000
--- a/graphics/gd/files/patch-gd_webp.c
+++ /dev/null
@@ -1,27 +0,0 @@
-LibGD Issue: https://github.com/libgd/libgd/issues/308
-Commit: https://github.com/libgd/libgd/commit/40bec0f38f50e8510f5bb71a82f516d46facde03
-
-Fix integer overflow in gdImageWebpCtx
-
-Integer overflow can be happened in expression gdImageSX(im) * 4 *
-gdImageSY(im). It could lead to heap buffer overflow in the following
-code. This issue has been reported to the PHP Bug Tracking System. The
-proof-of-concept file will be supplied some days later. This issue was
-discovered by Ke Liu of Tencent's Xuanwu LAB.
---- src/gd_webp.c.orig 2016-07-21 10:06:42.000000000 +0200
-+++ src/gd_webp.c 2016-10-16 20:27:17.150066000 +0200
-@@ -126,6 +126,14 @@
- quantization = 80;
- }
-
-+ if (overflow2(gdImageSX(im), 4)) {
-+ return;
-+ }
-+
-+ if (overflow2(gdImageSX(im) * 4, gdImageSY(im))) {
-+ return;
-+ }
-+
- argb = (uint8_t *)gdMalloc(gdImageSX(im) * 4 * gdImageSY(im));
- if (!argb) {
- return;
diff --git a/graphics/gd/files/patch-gdft.c b/graphics/gd/files/patch-gdft.c
deleted file mode 100644
index a77aa027706c..000000000000
--- a/graphics/gd/files/patch-gdft.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/gdft.c.orig 2016-07-21 10:32:27.000000000 +0200
-+++ src/gdft.c 2016-08-28 19:25:01.730120000 +0200
-@@ -139,7 +139,7 @@
- }
- #else
-
--#ifndef HAVE_LIBFONTCONFIG
-+#if 0
- static char * font_pattern(char **fontpath, char *fontpattern)
- {
- (void)fontpath;
-@@ -446,15 +446,15 @@
- return (strcmp (a->fontlist, b->fontlist) == 0 && a->flags == b->flags);
- }
-
-+#ifdef HAVE_LIBFONTCONFIG
- static int useFontConfig(int flag)
- {
--#ifdef HAVE_LIBFONTCONFIG
- if (fontConfigFlag) {
- return (!(flag & gdFTEX_FONTPATHNAME));
- }
--#endif
- return flag & gdFTEX_FONTCONFIG;
- }
-+#endif
-
- static void *
- fontFetch (char **error, void *key)
diff --git a/graphics/gd/pkg-plist b/graphics/gd/pkg-plist
index ae8673b51012..eeac4154cd98 100644
--- a/graphics/gd/pkg-plist
+++ b/graphics/gd/pkg-plist
@@ -29,5 +29,5 @@ lib/libgd.a
lib/libgd.la
lib/libgd.so
lib/libgd.so.6
-lib/libgd.so.6.0.3
+lib/libgd.so.6.0.4
libdata/pkgconfig/gdlib.pc