aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdal-grass/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-04-16 00:04:44 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-04-16 00:04:44 +0000
commit2c231a624077c5a6e2defc8ce12367af4b84e579 (patch)
tree71fd435f577741a2c1840505451e1385673a12d0 /graphics/gdal-grass/Makefile
parent605d39346422eb637e7069f92496e15e15ba79f1 (diff)
downloadports-2c231a624077c5a6e2defc8ce12367af4b84e579.tar.gz
ports-2c231a624077c5a6e2defc8ce12367af4b84e579.zip
Notes
Diffstat (limited to 'graphics/gdal-grass/Makefile')
-rw-r--r--graphics/gdal-grass/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/graphics/gdal-grass/Makefile b/graphics/gdal-grass/Makefile
new file mode 100644
index 000000000000..a3eb27c6647a
--- /dev/null
+++ b/graphics/gdal-grass/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: gdal-grass
+# Date created: Feb 2006
+# Whom: Laurent Courty
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdal-grass
+PORTVERSION= 1.3.1.2
+CATEGORIES= graphics
+MASTER_SITES= http://www.gdal.org/dl/ \
+ ftp://ftp.remotesensing.org/gdal/ \
+ http://gdal.maptools.org/dl/
+
+MAINTAINER= lrntct@gmail.org
+COMMENT= GDAL drivers for GRASS raster and vector files
+
+LIB_DEPENDS= gdal:${PORTSDIR}/graphics/gdal
+BUILD_DEPENDS= grass60:${PORTSDIR}/databases/grass
+RUN_DEPENDS= grass60:${PORTSDIR}/databases/grass
+
+GRASS_INST_DIR= grass
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.3.1
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gdal=${LOCALBASE}/bin/gdal-config \
+ --with-grass=${LOCALBASE}/${GRASS_INST_DIR} \
+ --with-autoload=${GDAL_AUTOLOAD_DIR}
+ALL_TARGET=
+
+.include <bsd.port.pre.mk>
+
+pre-install:
+ ${MKDIR} ${PREFIX}/share/gdal
+
+.if !defined(GDAL_AUTOLOAD_DIR)
+GDAL_AUTOLOAD_DIR=${PREFIX}/lib/gdalplugins
+.endif
+
+.if !defined (GRASS_INST_DIR)
+GRASS_INST_DIR= grass
+.endif
+
+.include <bsd.port.post.mk>