aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdal/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-07-11 11:16:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-07-11 11:16:06 +0000
commit61a8320e094bcc5c2c13f6f8a975e215d6557561 (patch)
tree911f6262582c3313ad33bce1227b7d5e6f253a4c /graphics/gdal/Makefile
parente230048069f5245b1f8598663a5f0b1a41599dd6 (diff)
Notes
Diffstat (limited to 'graphics/gdal/Makefile')
-rw-r--r--graphics/gdal/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 6d0929acde39..efc45a4b7dfc 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gdal
PORTVERSION= 1.11.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/gdal/${PORTVERSION}/ \
ftp://ftp.remotesensing.org/pub/gdal/${PORTVERSION}/ \
@@ -24,15 +24,17 @@ PCRE_DESC= Regular expression support for SQLite
CFLAGS+= -fPIC
CONFIGURE_ARGS= --datadir=${DATADIR} \
- --with-libz=/usr --with-liblzma=yes --with-threads=yes
+ --enable-static=yes \
+ --with-liblzma=yes --with-libz=/usr --with-threads=yes \
+ --without-libtool
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE} -pthread
MAKE_JOBS_UNSAFE= yes
MAKEFILE= GNUmakefile
-USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
USES= gmake
+PLIST_SUB= PORTVERSION=${PORTVERSION}
PORTDATA= *
SLAVEDIRS= graphics/p5-Geo-GDAL graphics/php-gdal graphics/py-gdal graphics/ruby-gdal
@@ -131,8 +133,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$(INST_LIB)/pkgconfig|${PREFIX}/libdata/pkgconfig|' ${WRKSRC}/GNUmakefile
post-install:
+ ${INSTALL_LIB} ${WRKSRC}/libgdal.a ${STAGEDIR}${PREFIX}/lib/
${TOUCH} ${STAGEDIR}${PREFIX}/lib/gdalplugins/.keepme
${INSTALL_DATA} ${WRKSRC}/GDALmake.opt ${STAGEDIR}${DATADIR}/
- -${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/libgdal.so.19
+ -${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/libgdal.so.${PORTVERSION}
.include <bsd.port.mk>