aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdal
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-08 17:11:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-08 17:11:55 +0000
commitf5eaf27d839ffbaa6188a9da0e08d1da001653f4 (patch)
tree7add97b9cbd7a4bf6054f05f9c34af8769cce86d /graphics/gdal
parent62915ef4233e722bca3bc815f1308b8a808f3d66 (diff)
downloadports-f5eaf27d839ffbaa6188a9da0e08d1da001653f4.tar.gz
ports-f5eaf27d839ffbaa6188a9da0e08d1da001653f4.zip
Notes
Diffstat (limited to 'graphics/gdal')
-rw-r--r--graphics/gdal/Makefile7
-rw-r--r--graphics/gdal/distinfo6
-rw-r--r--graphics/gdal/files/patch-frmts-jpeg2000-jpeg2000_vsil_io.cpp11
3 files changed, 5 insertions, 19 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 6985e1236700..7201d84747a6 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gdal
-PORTVERSION= 3.1.3
-PORTREVISION= 1
+PORTVERSION= 3.1.4
CATEGORIES= graphics geography
MASTER_SITES= https://download.osgeo.org/gdal/${PORTVERSION}/ \
LOCAL/sunpoet
@@ -24,9 +23,7 @@ LIB_DEPENDS= libgeotiff.so:graphics/libgeotiff \
libqhull.so.7:math/qhull \
libtiff.so:graphics/tiff
-OPTIONS_DEFINE= ARMADILLO CFITSIO CURL ECW EXPAT FREEXL GEOS GTA HDF5 JASPER \
- KML LIBXML2 MYSQL NETCDF ODBC OPENJPEG PCRE PGSQL SFCGAL \
- SPATIALITE SQLITE WEBP XERCES ZSTD
+OPTIONS_DEFINE= ARMADILLO CFITSIO CURL ECW EXPAT FREEXL GEOS GTA HDF5 JASPER KML LIBXML2 MYSQL NETCDF ODBC OPENJPEG PCRE PGSQL SFCGAL SPATIALITE SQLITE WEBP XERCES ZSTD
OPTIONS_RADIO= PDF
OPTIONS_RADIO_PDF= PODOFO POPPLER
OPTIONS_DEFAULT=JASPER
diff --git a/graphics/gdal/distinfo b/graphics/gdal/distinfo
index 3dbff7605799..2377f3874e2c 100644
--- a/graphics/gdal/distinfo
+++ b/graphics/gdal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1599924233
-SHA256 (gdal-3.1.3.tar.xz) = 161cf55371a143826f1d76ce566db1f0a666496eeb4371aed78b1642f219d51d
-SIZE (gdal-3.1.3.tar.xz) = 12087908
+TIMESTAMP = 1604680086
+SHA256 (gdal-3.1.4.tar.xz) = 7b82486f71c71cec61f9b237116212ce18ef6b90f068cbbf9f7de4fc50b576a8
+SIZE (gdal-3.1.4.tar.xz) = 12092576
diff --git a/graphics/gdal/files/patch-frmts-jpeg2000-jpeg2000_vsil_io.cpp b/graphics/gdal/files/patch-frmts-jpeg2000-jpeg2000_vsil_io.cpp
deleted file mode 100644
index 2a9d06bfc671..000000000000
--- a/graphics/gdal/files/patch-frmts-jpeg2000-jpeg2000_vsil_io.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- frmts/jpeg2000/jpeg2000_vsil_io.cpp.orig 2020-09-01 08:39:25 UTC
-+++ frmts/jpeg2000/jpeg2000_vsil_io.cpp
-@@ -109,7 +109,7 @@ static int JPEG2000_VSIL_read(jas_stream_obj_t *obj, c
- #ifndef PRIjas_seqent
- static int JPEG2000_VSIL_write(jas_stream_obj_t *obj, char *buf, int cnt)
- #else
--static int JPEG2000_VSIL_write(jas_stream_obj_t *obj, char *buf, unsigned int cnt)
-+static int JPEG2000_VSIL_write(jas_stream_obj_t *obj, const char *buf, unsigned int cnt)
- #endif
- {
- jas_stream_VSIFL_t *fileobj = JAS_CAST(jas_stream_VSIFL_t *, obj);