aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdchart
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-09 09:01:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-09 09:01:52 +0000
commit57c4ddbdd52d4622571c9039c14b0fb130d1480b (patch)
treeb7a89b9ef9dcef1014c35272da4c586f22e159e1 /graphics/gdchart
parent5b143ae2e642aed3cef78429e37576795ef1d03e (diff)
downloadports-57c4ddbdd52d4622571c9039c14b0fb130d1480b.tar.gz
ports-57c4ddbdd52d4622571c9039c14b0fb130d1480b.zip
Notes
Diffstat (limited to 'graphics/gdchart')
-rw-r--r--graphics/gdchart/Makefile19
-rw-r--r--graphics/gdchart/pkg-plist5
2 files changed, 11 insertions, 13 deletions
diff --git a/graphics/gdchart/Makefile b/graphics/gdchart/Makefile
index 0aa4bb94a5b8..c8bca3e55b64 100644
--- a/graphics/gdchart/Makefile
+++ b/graphics/gdchart/Makefile
@@ -20,9 +20,8 @@ MAKEFILE= ${FILESDIR}/Makefile
MAKE_ARGS= PREFIX="${PREFIX}" LOCALBASE="${LOCALBASE}"
USE_LDCONFIG= yes
-EXAMPLES= ft_samp.c gdc_pie_samp.c gdc_samp1.c gdc_samp2.c
-
-OPTIONS_DEFINE= DOCS EXAMPLES
+PORTDOCS= README.txt
+PORTEXAMPLES= ft_samp.c gdc_pie_samp.c gdc_samp1.c gdc_samp2.c
.if defined(NO_PROFILE)
PLIST_SUB+= PROFILE="@comment "
@@ -30,25 +29,29 @@ PLIST_SUB+= PROFILE="@comment "
PLIST_SUB+= PROFILE=""
.endif
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e 's/^#ifdef HAVE_JPEG/#ifndef NO_JPEG/' \
-e 's/^#ifdef HAVE_LIBFREETYPE/#ifndef NO_LIBFREETYPE/' \
${WRKSRC}/*.[ch]
# ft_samp.c and gdc_samp?.c miss #include "gdcpie.h"
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e 's/^#include "gdc\.h"/#include "gdcpie.h"/' \
${WRKSRC}/ft_samp.c \
${WRKSRC}/gdc_samp?.c
# gdc_pie_samp.c misses #include "gdchart.h"
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e 's/^#include "gdc\.h"/#include "gdchart.h"/' \
${WRKSRC}/gdc_pie_samp.c
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/graphics/gdchart/pkg-plist b/graphics/gdchart/pkg-plist
index 02f601e43254..519003e13bc2 100644
--- a/graphics/gdchart/pkg-plist
+++ b/graphics/gdchart/pkg-plist
@@ -5,8 +5,3 @@ lib/libgdc.a
lib/libgdc.so
lib/libgdc.so.1
%%PROFILE%%lib/libgdc_p.a
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ft_samp.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gdc_samp1.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gdc_samp2.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gdc_pie_samp.c