aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdchart
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-27 12:23:38 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-27 12:23:38 +0000
commit6b9b1c776c23e728670a22754d39ee1a3493bd5d (patch)
tree26cad8b08761298bec32e706963723bd3d078e34 /graphics/gdchart
parenta1442b6caa2345b4491d90f8d013a2b70ca44afc (diff)
downloadports-6b9b1c776c23e728670a22754d39ee1a3493bd5d.tar.gz
ports-6b9b1c776c23e728670a22754d39ee1a3493bd5d.zip
- Add staging support
- Convert to new options framework
Notes
Notes: svn path=/head/; revision=352414
Diffstat (limited to 'graphics/gdchart')
-rw-r--r--graphics/gdchart/Makefile31
1 files changed, 10 insertions, 21 deletions
diff --git a/graphics/gdchart/Makefile b/graphics/gdchart/Makefile
index 513c4357e189..6f17307cbab9 100644
--- a/graphics/gdchart/Makefile
+++ b/graphics/gdchart/Makefile
@@ -12,24 +12,21 @@ DISTNAME= ${PORTNAME}${PORTVERSION}dev
MAINTAINER= ports@FreeBSD.org
COMMENT= Easy to use fast C API for creating charts and graphs
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
- jpeg:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
libfreetype.so:${PORTSDIR}/print/freetype2
+USES= uidfix
MAKEFILE= ${FILESDIR}/Makefile
MAKE_ARGS= PREFIX="${PREFIX}" LOCALBASE="${LOCALBASE}"
USE_LDCONFIG= yes
-DOCS= README.txt
EXAMPLES= ft_samp.c gdc_pie_samp.c gdc_samp1.c gdc_samp2.c
-.if defined(NO_PROFILE)
-PLIST_SUB+= PROFILE="@comment "
-.else
-PLIST_SUB+= PROFILE=
-.endif
+OPTIONS_DEFINE= DOCS EXAMPLES PROFILE
+OPTIONS_DEFAULT=PROFILE
+OPTIONS_SUB= yes
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} \
-e 's/^#ifdef HAVE_JPEG/#ifndef NO_JPEG/' \
@@ -46,17 +43,9 @@ post-patch:
${WRKSRC}/gdc_pie_samp.c
post-install:
-.if !defined(NOPORTDOCS)
-.for f in ${DOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
-.endfor
-.endif
-.if !defined(NOPORTEXAMPLES)
-.for f in ${EXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}/
-.endfor
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>