aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdk-pixbuf2/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /graphics/gdk-pixbuf2/Makefile
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Notes
Diffstat (limited to 'graphics/gdk-pixbuf2/Makefile')
-rw-r--r--graphics/gdk-pixbuf2/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/graphics/gdk-pixbuf2/Makefile b/graphics/gdk-pixbuf2/Makefile
new file mode 100644
index 000000000000..6fa18c02cecc
--- /dev/null
+++ b/graphics/gdk-pixbuf2/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: gdk-pixbuf
+# Date created: 5th October 1999
+# Whom: Ade Lovett <ade@lovett.com>
+#
+# $FreeBSD$
+# $MCom: ports/graphics/gdk-pixbuf2/Makefile,v 1.9 2010/11/09 09:35:01 kwm Exp $
+
+PORTNAME?= gdk-pixbuf
+PORTVERSION= 2.22.1
+CATEGORIES?= graphics
+MASTER_SITES= GNOME
+MASTER_SITE_SUBDIR= sources/gdk-pixbuf/${PORTVERSION:R}
+DISTNAME= gdk-pixbuf-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A graphic library for GTK+
+
+BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ jpeg.11:${PORTSDIR}/graphics/jpeg \
+ jasper.4:${PORTSDIR}/graphics/jasper
+
+LATEST_LINK= gdk-pixbuf2
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_XORG= xt xi x11
+USE_AUTOTOOLS= libtool:22
+USE_GNOME+= gnomehack glib20 ltverhack
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-introspection=yes --with-libjasper
+
+MAN1= gdk-pixbuf-csource.1 gdk-pixbuf-query-loaders.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|" == "|" = "|g' ${WRKSRC}/configure
+
+post-install:
+ @cd ${WRKSRC}/docs/reference/gdk-pixbuf && gmake install-man1
+
+.include <bsd.port.mk>