aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdk-pixbuf2/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
commit951c1f5d1c7354f058f5919d858dbb0c174dc73e (patch)
tree6146e775343aaf339921799078894a48fef9aa15 /graphics/gdk-pixbuf2/Makefile
parentc9b47f0427d70ba42c2d53271f8b64b8e8096825 (diff)
downloadports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.tar.gz
ports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.zip
Notes
Diffstat (limited to 'graphics/gdk-pixbuf2/Makefile')
-rw-r--r--graphics/gdk-pixbuf2/Makefile44
1 files changed, 20 insertions, 24 deletions
diff --git a/graphics/gdk-pixbuf2/Makefile b/graphics/gdk-pixbuf2/Makefile
index bedda5f0cb2e..692e2c9f2bb3 100644
--- a/graphics/gdk-pixbuf2/Makefile
+++ b/graphics/gdk-pixbuf2/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= gdk-pixbuf
-PORTVERSION= 2.36.11
+PORTVERSION= 2.36.12
CATEGORIES= graphics
MASTER_SITES= GNOME
PKGNAMESUFFIX= 2
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Graphic library for GTK+
@@ -14,42 +14,38 @@ COMMENT= Graphic library for GTK+
LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cpe gmake gnome libtool localbase pathfix pkgconfig \
- shared-mime-info tar:xz
-USE_XORG= xt xi x11
+BUILD_DEPENDS= docbook-xsl>0:textproc/docbook-xsl
+
+USES= cpe gettext gnome localbase:ldflags meson pkgconfig \
+ python:3.4+,build shared-mime-info tar:xz
CPE_VENDOR= gnome
-USE_GNOME+= glib20 introspection:build
+USE_GNOME= glib20 introspection:build libxslt:build
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-introspection=yes --with-x11
-INSTALL_TARGET= install-strip
+MESON_ARGS= -Dman=true
+
+BINARY_ALIAS= python3=${PYTHON_VERSION}
OPTIONS_SUB= yes
-OPTIONS_DEFINE= JASPER JPEG PNG TIFF NLS
-OPTIONS_DEFAULT=JASPER JPEG PNG TIFF
+OPTIONS_DEFINE= JASPER JPEG PNG TIFF X11
+OPTIONS_DEFAULT=JPEG PNG TIFF X11
-JASPER_CONFIGURE_WITH= libjasper
+JASPER_MESON_TRUE= jasper
JASPER_LIB_DEPENDS= libjasper.so:graphics/jasper
-JPEG_CONFIGURE_WITH= libjpeg
+JPEG_MESON_TRUE= jpeg
JPEG_USES= jpeg
-PNG_CONFIGURE_WITH= libpng
+PNG_MESON_TRUE= png
PNG_LIB_DEPENDS= libpng.so:graphics/png
-TIFF_CONFIGURE_WITH= libtiff
+TIFF_MESON_TRUE= tiff
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext
-
-# workaround tiff enable bug in configure
-post-patch:
- @${REINPLACE_CMD} -e 's|$$LIBTIFF|$$TIFF_LIBS|' \
- ${WRKSRC}/configure
+X11_MESON_TRUE= x11
+X11_USE= xorg=x11
post-install:
- @cd ${WRKSRC}/docs/reference/gdk-pixbuf && \
- ${SETENV} DESTDIR=${STAGEDIR} ${GMAKE} install-man1
+ ${RM} -rf ${STAGEDIR}${PREFIX}/libexec/installed-tests
+ ${RM} -rf ${STAGEDIR}${PREFIX}/share/installed-tests
.include <bsd.port.mk>