aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdk-pixbuf2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /graphics/gdk-pixbuf2
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
downloadports-d129587b5d568b0ff5300386f1e1b706c349f38e.tar.gz
ports-d129587b5d568b0ff5300386f1e1b706c349f38e.zip
The FreeBSD GNOME team proudly presents GNOME 3.16 for FreeBSD.
The offical GNOME 3.16 release notes can be found at https://help.gnome.org/misc/release-notes/3.16/ Upgrade instructions for port users: Delete the old tracker package with: # pkg delete -f tracker And user port upgrade tool of choice to upgrade. Thanks to Antoine Brodin for running the exp-runs. This release was made possible by the following people: Gustau Perez Ting-Wei_Lan PR: 201980
Notes
Notes: svn path=/head/; revision=393607
Diffstat (limited to 'graphics/gdk-pixbuf2')
-rw-r--r--graphics/gdk-pixbuf2/Makefile19
-rw-r--r--graphics/gdk-pixbuf2/distinfo4
-rw-r--r--graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_gdk-pixbuf-loader.c25
-rw-r--r--graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_pixops_pixops.c82
-rw-r--r--graphics/gdk-pixbuf2/pkg-plist6
5 files changed, 11 insertions, 125 deletions
diff --git a/graphics/gdk-pixbuf2/Makefile b/graphics/gdk-pixbuf2/Makefile
index d7a560aa88c7..317c78444a02 100644
--- a/graphics/gdk-pixbuf2/Makefile
+++ b/graphics/gdk-pixbuf2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gdk-pixbuf
-PORTVERSION= 2.31.2
-PORTREVISION= 2
+PORTVERSION= 2.31.5
CATEGORIES= graphics
MASTER_SITES= GNOME
PKGNAMESUFFIX= 2
@@ -27,8 +26,8 @@ CONFIGURE_ARGS= --enable-introspection=yes --with-x11
INSTALL_TARGET= install-strip
OPTIONS_SUB= yes
-OPTIONS_DEFINE= JASPER JPEG PNG TIFF
-OPTIONS_DEFAULT=JASPER JPEG PNG TIFF
+OPTIONS_DEFINE= JASPER JPEG PNG TIFF NLS
+OPTIONS_DEFAULT=JASPER JPEG PNG TIFF NLS
JASPER_CONFIGURE_WITH= libjasper
JASPER_LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper
JPEG_CONFIGURE_WITH= libjpeg
@@ -37,16 +36,8 @@ PNG_CONFIGURE_WITH= libpng
PNG_LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
TIFF_CONFIGURE_WITH= libtiff
TIFF_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
post-install:
@cd ${WRKSRC}/docs/reference/gdk-pixbuf && env DESTDIR=${STAGEDIR} ${GMAKE} install-man1
diff --git a/graphics/gdk-pixbuf2/distinfo b/graphics/gdk-pixbuf2/distinfo
index 23bb3eacfad8..d94fca048eb3 100644
--- a/graphics/gdk-pixbuf2/distinfo
+++ b/graphics/gdk-pixbuf2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/gdk-pixbuf-2.31.2.tar.xz) = 9e467ed09894c802499fb2399cd9a89ed21c81700ce8f27f970a833efb1e47aa
-SIZE (gnome2/gdk-pixbuf-2.31.2.tar.xz) = 1624496
+SHA256 (gnome2/gdk-pixbuf-2.31.5.tar.xz) = 0a76e70497cd25ef2ac0da63a489c158ea3926724eb83d5254f9a0bc985ff7a6
+SIZE (gnome2/gdk-pixbuf-2.31.5.tar.xz) = 2402808
diff --git a/graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_gdk-pixbuf-loader.c b/graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_gdk-pixbuf-loader.c
deleted file mode 100644
index b62f8fc62666..000000000000
--- a/graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_gdk-pixbuf-loader.c
+++ /dev/null
@@ -1,25 +0,0 @@
-From 74c418ba2e41ab9e2287420378a6192788b1fab6 Mon Sep 17 00:00:00 2001
-From: Sarita Rawat <sarita.rawat@samsung.com>
-Date: Fri, 5 Jun 2015 06:56:00 +0000
-Subject: Avoid a possible divide-by-zero
-
-Pointed out in
-
-https://bugzilla.gnome.org/show_bug.cgi?id=750440
-
-diff --git a/gdk-pixbuf/gdk-pixbuf-loader.c b/gdk-pixbuf/gdk-pixbuf-loader.c
-index 65845ed..668b703 100644
---- gdk-pixbuf/gdk-pixbuf-loader.c
-+++ gdk-pixbuf/gdk-pixbuf-loader.c
-@@ -330,7 +330,7 @@ gdk_pixbuf_loader_prepare (GdkPixbuf *pixbuf,
- else
- anim = gdk_pixbuf_non_anim_new (pixbuf);
-
-- if (priv->needs_scale) {
-+ if (priv->needs_scale && width != 0 && height != 0) {
- priv->animation = GDK_PIXBUF_ANIMATION (_gdk_pixbuf_scaled_anim_new (anim,
- (double) priv->width / width,
- (double) priv->height / height,
---
-cgit v0.10.2
-
diff --git a/graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_pixops_pixops.c b/graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_pixops_pixops.c
deleted file mode 100644
index 009c15b42ca0..000000000000
--- a/graphics/gdk-pixbuf2/files/patch-gdk-pixbuf_pixops_pixops.c
+++ /dev/null
@@ -1,82 +0,0 @@
-From ffec86ed5010c5a2be14f47b33bcf4ed3169a199 Mon Sep 17 00:00:00 2001
-From: Matthias Clasen <mclasen@redhat.com>
-Date: Mon, 13 Jul 2015 00:33:40 -0400
-Subject: pixops: Be more careful about integer overflow
-
-Our loader code is supposed to handle out-of-memory and overflow
-situations gracefully, reporting errors instead of aborting. But
-if you load an image at a specific size, we also execute our
-scaling code, which was not careful enough about overflow in some
-places.
-
-This commit makes the scaling code silently return if it fails to
-allocate filter tables. This is the best we can do, since
-gdk_pixbuf_scale() is not taking a GError.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=752297
-
-diff --git a/gdk-pixbuf/pixops/pixops.c b/gdk-pixbuf/pixops/pixops.c
-index 29a1c14..ce51745 100644
---- gdk-pixbuf/pixops/pixops.c
-+++ gdk-pixbuf/pixops/pixops.c
-@@ -1272,7 +1272,16 @@ make_filter_table (PixopsFilter *filter)
- int i_offset, j_offset;
- int n_x = filter->x.n;
- int n_y = filter->y.n;
-- int *weights = g_new (int, SUBSAMPLE * SUBSAMPLE * n_x * n_y);
-+ gsize n_weights;
-+ int *weights;
-+
-+ n_weights = SUBSAMPLE * SUBSAMPLE * n_x * n_y;
-+ if (n_weights / (SUBSAMPLE * SUBSAMPLE * n_x) != n_y)
-+ return NULL; /* overflow, bail */
-+
-+ weights = g_try_new (int, n_weights);
-+ if (!weights)
-+ return NULL; /* overflow, bail */
-
- for (i_offset=0; i_offset < SUBSAMPLE; i_offset++)
- for (j_offset=0; j_offset < SUBSAMPLE; j_offset++)
-@@ -1347,8 +1356,11 @@ pixops_process (guchar *dest_buf,
- if (x_step == 0 || y_step == 0)
- return; /* overflow, bail out */
-
-- line_bufs = g_new (guchar *, filter->y.n);
- filter_weights = make_filter_table (filter);
-+ if (!filter_weights)
-+ return; /* overflow, bail out */
-+
-+ line_bufs = g_new (guchar *, filter->y.n);
-
- check_shift = check_size ? get_check_shift (check_size) : 0;
-
-@@ -1468,7 +1480,7 @@ tile_make_weights (PixopsFilterDimension *dim,
- double scale)
- {
- int n = ceil (1 / scale + 1);
-- double *pixel_weights = g_new (double, SUBSAMPLE * n);
-+ double *pixel_weights = g_malloc_n (sizeof (double) * SUBSAMPLE, n);
- int offset;
- int i;
-
-@@ -1526,7 +1538,7 @@ bilinear_magnify_make_weights (PixopsFilterDimension *dim,
- }
-
- dim->n = n;
-- dim->weights = g_new (double, SUBSAMPLE * n);
-+ dim->weights = g_malloc_n (sizeof (double) * SUBSAMPLE, n);
-
- pixel_weights = dim->weights;
-
-@@ -1617,7 +1629,7 @@ bilinear_box_make_weights (PixopsFilterDimension *dim,
- double scale)
- {
- int n = ceil (1/scale + 3.0);
-- double *pixel_weights = g_new (double, SUBSAMPLE * n);
-+ double *pixel_weights = g_malloc_n (sizeof (double) * SUBSAMPLE, n);
- double w;
- int offset, i;
-
---
-cgit v0.10.2
-
diff --git a/graphics/gdk-pixbuf2/pkg-plist b/graphics/gdk-pixbuf2/pkg-plist
index 41213c02d1ea..64a99c0c5afb 100644
--- a/graphics/gdk-pixbuf2/pkg-plist
+++ b/graphics/gdk-pixbuf2/pkg-plist
@@ -4,6 +4,7 @@ bin/gdk-pixbuf-query-loaders
include/gdk-pixbuf-2.0/gdk-pixbuf-xlib/gdk-pixbuf-xlib.h
include/gdk-pixbuf-2.0/gdk-pixbuf-xlib/gdk-pixbuf-xlibrgb.h
include/gdk-pixbuf-2.0/gdk-pixbuf/gdk-pixbuf-animation.h
+include/gdk-pixbuf-2.0/gdk-pixbuf/gdk-pixbuf-autocleanups.h
include/gdk-pixbuf-2.0/gdk-pixbuf/gdk-pixbuf-core.h
include/gdk-pixbuf-2.0/gdk-pixbuf/gdk-pixbuf-enum-types.h
include/gdk-pixbuf-2.0/gdk-pixbuf/gdk-pixbuf-features.h
@@ -34,10 +35,10 @@ lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders/libpixbufloader-xpm.so
lib/girepository-1.0/GdkPixbuf-2.0.typelib
lib/libgdk_pixbuf-2.0.so
lib/libgdk_pixbuf-2.0.so.0
-lib/libgdk_pixbuf-2.0.so.0.3100.2
+lib/libgdk_pixbuf-2.0.so.0.3100.5
lib/libgdk_pixbuf_xlib-2.0.so
lib/libgdk_pixbuf_xlib-2.0.so.0
-lib/libgdk_pixbuf_xlib-2.0.so.0.3100.2
+lib/libgdk_pixbuf_xlib-2.0.so.0.3100.5
libdata/pkgconfig/gdk-pixbuf-2.0.pc
libdata/pkgconfig/gdk-pixbuf-xlib-2.0.pc
man/man1/gdk-pixbuf-csource.1.gz
@@ -91,6 +92,7 @@ share/gir-1.0/GdkPixbuf-2.0.gir
%%NLS%%share/locale/it/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/ja/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/ka/LC_MESSAGES/gdk-pixbuf.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/km/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/kn/LC_MESSAGES/gdk-pixbuf.mo
%%NLS%%share/locale/ko/LC_MESSAGES/gdk-pixbuf.mo