aboutsummaryrefslogtreecommitdiff
path: root/graphics/geeqie
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-12-05 01:42:46 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-12-05 01:42:46 +0000
commit4e067fe5910cc802ab7241ae30d6705eccf9b0c2 (patch)
tree578a672d16e393029ce8ba70ccb8713f1bd12745 /graphics/geeqie
parentf4536e49620c56bf9128e4d986c5a363635a4433 (diff)
downloadports-4e067fe5910cc802ab7241ae30d6705eccf9b0c2.tar.gz
ports-4e067fe5910cc802ab7241ae30d6705eccf9b0c2.zip
graphics/geeqie: add missing dependencies, patch useless warning
This adds missing dependencies for nondefault options. (Two items for USE_GNOME actually snuck into the previous commit already, my apologies for missing that in the commit message. r557035) It also patches out a useless "CFLAGS+=... not found" warning from the "make configure" phase. We can't currently use -Werror anyways for building geeqie with our GTK3 version (deprecation warnings). Approved by: portmgr@ (blanket, dependencies)
Notes
Notes: svn path=/head/; revision=557036
Diffstat (limited to 'graphics/geeqie')
-rw-r--r--graphics/geeqie/Makefile11
-rw-r--r--graphics/geeqie/files/patch-configure.ac9
2 files changed, 19 insertions, 1 deletions
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index 4bf9ab23b12e..b608aeee26f1 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -55,9 +55,15 @@ LIRC_CONFIGURE_ON= --with-lirc-prefix="${LOCALBASE}"
LIRC_BROKEN= does not build with old lirc from ports
MAP_LIB_DEPENDS= libchamplain-0.12.so:graphics/libchamplain \
- libclutter-gtk-1.0.so:graphics/clutter-gtk3
+ libclutter-gtk-1.0.so:graphics/clutter-gtk3 \
+ libclutter-1.0.so:graphics/clutter \
+ libcogl.so:graphics/cogl \
+ libjson-glib-1.0.so:devel/json-glib
+
MAP_CONFIGURE_ENABLE= map gpu-accel
MAP_REQUIRES= GTK3
+MAP_USES= gl xorg
+MAP_USE= GL=egl XORG=xrandr,x11,xext,xdamage,xfixes,xcomposite,xi
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
TIFF_CONFIGURE_ENABLE= tiff
@@ -74,6 +80,9 @@ FFMPEGTHUMBNAILER_DESC= Video file thumbnails generating support
FFMPEGTHUMBNAILER_CONFIGURE_ENABLE= ffmpegthumbnailer
FFMPEGTHUMBNAILER_LIB_DEPENDS= libffmpegthumbnailer.so:multimedia/ffmpegthumbnailer
+GTK2_LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+
NLS_CONFIGURE_ENABLE= nls
HEIF_CONFIGURE_ENABLE= heif
diff --git a/graphics/geeqie/files/patch-configure.ac b/graphics/geeqie/files/patch-configure.ac
index 4f2ee4b8933e..7d63e0332a7a 100644
--- a/graphics/geeqie/files/patch-configure.ac
+++ b/graphics/geeqie/files/patch-configure.ac
@@ -1,5 +1,14 @@
--- configure.ac.orig 2020-11-20 21:36:33 UTC
+++ configure.ac
+@@ -18,7 +18,7 @@ AC_PREREQ(2.57)
+ AC_INIT([geeqie], 1.6, [https://github.com/BestImageViewer/geeqie/issues], [], [http://www.geeqie.org/])
+
+ # Add -Werror to the default CFLAGS
+-CFLAGS+=" -Werror -Wno-error=deprecated-declarations -Wno-error=sign-compare -Wno-error=return-type"
++#CFLAGS+=" -Werror -Wno-error=deprecated-declarations -Wno-error=sign-compare -Wno-error=return-type"
+
+ # Check for rightly dirs
+ AC_CONFIG_SRCDIR([src/main.c])
@@ -525,7 +525,7 @@ AC_ARG_ENABLE([lua],
[liblua=$enableval], [liblua=auto])