aboutsummaryrefslogtreecommitdiff
path: root/graphics/gegl3/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-10-20 18:18:31 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-10-20 18:18:31 +0000
commitfad5b62050010bf3c59c65c9c73f8557aa8e4174 (patch)
treee3cc54a4ff907ca7d1fcb36f6adeda97c854c75a /graphics/gegl3/Makefile
parente067e043d624d37c5bf18837ab55cfdd0ef82449 (diff)
downloadports-fad5b62050010bf3c59c65c9c73f8557aa8e4174.tar.gz
ports-fad5b62050010bf3c59c65c9c73f8557aa8e4174.zip
Notes
Diffstat (limited to 'graphics/gegl3/Makefile')
-rw-r--r--graphics/gegl3/Makefile27
1 files changed, 11 insertions, 16 deletions
diff --git a/graphics/gegl3/Makefile b/graphics/gegl3/Makefile
index ac7fda9fdd7e..1d87a0289665 100644
--- a/graphics/gegl3/Makefile
+++ b/graphics/gegl3/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gegl
-PORTVERSION= 0.3.18
+PORTVERSION= 0.3.20
CATEGORIES= graphics
MASTER_SITES= GIMP
PKGNAMESUFFIX= 3
@@ -16,9 +16,10 @@ LICENSE_FILE_GPLv3+ = ${WRKSRC}/COPYING
LICENSE_FILE_LGPL3+ = ${WRKSRC}/COPYING.LESSER
LIB_DEPENDS= libbabl-0.1.so:x11/babl \
- libjson-glib-1.0.so:devel/json-glib
+ libjson-glib-1.0.so:devel/json-glib \
+ libpng.so:graphics/png
-USES= cpe gettext gmake libtool localbase pathfix pkgconfig \
+USES= cpe gettext gmake jpeg libtool localbase pathfix pkgconfig \
shebangfix tar:bzip2
USE_GNOME= glib20 intltool introspection:build
USE_LDCONFIG= yes
@@ -28,7 +29,7 @@ CONFIGURE_ARGS= --without-vala --disable-docs
CONFIGURE_ARGS+=--without-mrg --without-lensfun
INSTALL_TARGET= install-strip
-GEGL_MINOR= 318
+GEGL_MINOR= 320
GEGL_VER= 0.3
PLIST_SUB+= GEGL_MINOR="${GEGL_MINOR}" GEGL_VER=${GEGL_VER}
@@ -39,11 +40,11 @@ EXAMPLES= 2geglbuffer \
SHEBANG_FILES= tools/xml_insert.sh
OPTIONS_SUB= yes
-OPTIONS_DEFINE= CAIRO ENSCRIPT EXIV2 FFMPEG PIXBUF GRAPHVIZ JASPER JPEG \
- LUA OPENEXR RAW PANGO PNG LIBRSVG2 SDL SPIRO V4L \
+OPTIONS_DEFINE= CAIRO ENSCRIPT EXIV2 FFMPEG PIXBUF GRAPHVIZ JASPER \
+ LUA OPENEXR RAW PANGO LIBRSVG2 SDL SPIRO V4L \
EXAMPLES LCMS2 WEBP TIFF GEXIV2
-OPTIONS_DEFAULT=CAIRO ENSCRIPT EXIV2 PIXBUF GRAPHVIZ JASPER JPEG LCMS2 LUA \
- OPENEXR RAW PANGO PNG LIBRSVG2 SDL SPIRO V4L WEBP TIFF
+OPTIONS_DEFAULT=CAIRO ENSCRIPT EXIV2 PIXBUF GRAPHVIZ JASPER LCMS2 LUA \
+ OPENEXR RAW PANGO LIBRSVG2 SDL SPIRO V4L WEBP TIFF
ENSCRIPT_DESC= Enscript support
SPIRO_DESC= Spiro support
@@ -70,11 +71,8 @@ GRAPHVIZ_CONFIGURE_WITH= graphviz
JASPER_LIB_DEPENDS= libjasper.so:graphics/jasper
JASPER_CONFIGURE_WITH= jasper
-JPEG_USES= jpeg
-JPEG_CONFIGURE_WITH= libjpeg
-
LCMS2_LIB_DEPENDS= liblcms2.so:graphics/lcms2
-LCMS2_CONFIGURE_WITH= lcms
+LCMS2_CONFIGURE_OFF= --without-lcms
LUA_USES= lua
LUA_CONFIGURE_WITH= lua
@@ -86,11 +84,8 @@ OPENEXR_CONFIGURE_WITH= openexr
RAW_LIB_DEPENDS= libraw.so:graphics/libraw
RAW_CONFIGURE_WITH= libraw
-PNG_LIB_DEPENDS= libpng.so:graphics/png
-PNG_CONFIGURE_WITH= libpng
-
LIBRSVG2_USE= GNOME=librsvg2
-LIBRSVG2_CONFIGURE_WITH= librsvg
+LIBRSVG2_CONFIGURE_OFF= --without-librsvg
SDL_USE= SDL=sdl
SDL_CONFIGURE_WITH= sdl